HP Pavillion dv6000 Integrated fan not working at all

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

HP Pavillion dv6000 Integrated fan not working at all

Postby matismasters on Wed Dec 02, 2009 1:38 pm

Hello guys, i've just installed felicia, and i'm pretty happy with it, it even got my media buttons from my laptop. I have only 2 issues. Sound very low. it doesn't matter now.

And the most important.
The temperature of my laptop is very high, and the fan does not start. In windows, as soon as i boot, the fan starts, first slow, and then fast, because its summer here, and its really hot. I'll post my system and laptop information down here.
PD: I got scared because suddenly my laptop just got freesed, and nothing worked out, and my caps lock led, was blinking, was the only thing that was moving...

LinuxMint:
Release 6(felicia)
Kernel Linux 2.6.27-7-generic
Gnome2.24.1
64 bits

Hardware:

Memory: 2.0 GiB
Proccessor : Intel(r) Core(TM)2 Duo CPU T7250 @ 2.00 Ghz
Nvidia 8400GS M

If you need anything else just tell me, but someone told me that it could be the kernel, if it that so maybe upgrading could help, but... i'm new to linux and that seems scary, because i use my laptop for work and i coudln't think of loosing data, and time. I also installed some sensors packages, and it just says that the Graphic card Temp is 59 C. Says nothing about the proccessor or motherboard.

Please if someone can help me on this i really appreciate it, because its a little bit dangerous to my laptop.

THanks everyone
matismasters
Level 1
Level 1
 
Posts: 2
Joined: Wed Dec 02, 2009 1:28 pm

Linux Mint is funded by ads and donations.
 

Re: HP Pavillion dv6000 Integrated fan not working at all

Postby rob2uk on Wed Dec 02, 2009 8:51 pm

First off, make sure you check this: http://h10025.www1.hp.com/ewfrf/wc/document?docname=c01087277&lc=en&cc=us&dlc=en&product=1842189&lang=en - Although HP refuse to admit it, the problems are caused by insufficient cooling.

The BIOS update they mention may solve your problem, as it has an updated fan control (algorithm? Is that the word I'm looking for? *shrug*).

It could also be that Windows pushes your system so hard while booting that your CPU reaches the temperature that triggers your fan, while Linux does not - HP in their infinite wisdom decided that the cut-in temperature should be 85 Celcius. I believe this was lowered in the above BIOS update.

One last thing - is their any reason you're running Felicia? The dv6000 is more than capable of running Gloria or Helena :)
GA-965-DS3, Core 2 Quad 2.4GHz, 8GB DDR2, 2x1TB HDD, Linux Mint 11
Acer Aspire 5332, Pentium dual core 2.2GHz, 4GB DDR3, 500GB HDD, Linux Mint 11, Linux Mint Debian
Compaq CQ-60, Sempron 2.10GHz, 4GB DDR2, 120GB HDD, Tinycore 3.7rc2 (Minecraft server!)
rob2uk
Level 4
Level 4
 
Posts: 285
Joined: Tue Jul 28, 2009 2:44 pm

Re: HP Pavillion dv6000 Integrated fan not working at all

Postby matismasters on Mon Dec 07, 2009 2:48 pm

Thanks for the link, i really appreciate your help. Thanks.
Good point about windows overloading the CPU, I'll try run some benchmarking on linux to push it a little, and see if the fan is still not moving. I'll have to research about benchmarks too.

Bye bye, thanks.
matismasters
Level 1
Level 1
 
Posts: 2
Joined: Wed Dec 02, 2009 1:28 pm


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 14 guests