Internal microphone on Dell Mini 10v

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Internal microphone on Dell Mini 10v

Postby rwhite5279 on Mon Dec 14, 2009 5:15 pm

Hi, all.

Sooooo happy with Linux Mint. Loved the easy install onto the Dell Mini 10v. REALLY frustrated by inability to get internal microphone working on that machine. I've spent over 10 hours over the course of the last few days trying to get the best distro working on a very popular machine, and find it difficult to believe that it's this hard getting it to work. I know, I know: "Welcome to Linux..."

Everything sound-related seems to work as it should, with the exception of the internal microphone, which only faintly, if at all, picks up sound. Recording anything with Sound Recorder only picks up static (which varies with how high I push the gain on the Front Mic). Pushing the gain up on the Front mic delivers static to the speakers non-stop, regardless of whether an app is supposed to be channelling the sound or not. So the question is simply, how do I get the microphone to pick up usable sound when a sound-related app such as Skype needs it?

I'm a bit of a newb here, so I hope this is most of what's needed to help me diagnose this. Thanks in advance for any advice.

Running Linux Mint 7, updated, on a Dell Inspiron Mini 10v
Sound is working fine, an external mike works fine, internal microphone produces static when not muted.
Output from Terminal:
Code: Select all
rwhite@Nautilus ~ $ arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC272 Analog [ALC272 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
rwhite@Nautilus ~ $ lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GME Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GME Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
03:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)


lspci-vvnn produced the following:

Code: Select all
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
   Subsystem: Dell Device [1028:02f4]
   Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 0, Cache Line Size: 64 bytes
   Interrupt: pin A routed to IRQ 22
   Region 0: Memory at f0440000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: <access denied>
   Kernel driver in use: HDA Intel
   Kernel modules: snd-hda-intel



I have already modified /etc/modprobe.d/alsa-base.conf by adding
options snd-hda-intel index=0 model=dell

Alsamixer looks like this:
Image

Thanks in advance for any advice anyone can offer...
rwhite5279
Level 1
Level 1
 
Posts: 3
Joined: Sat Dec 12, 2009 4:49 pm

Linux Mint is funded by ads and donations.
 

Re: Internal microphone on Dell Mini 10v

Postby Husse on Sat Dec 19, 2009 2:56 pm

Sorry for the delayed reply
You have already done what I would have suggested
I have to add this to my list of unsolved topids and come back to you
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Internal microphone on Dell Mini 10v

Postby jlr1701 on Mon Dec 21, 2009 4:28 pm

I have the same machine, and the internal microphone is working great. Here's a couple of screenshots from the Volume Control app:

volumecontrol1.jpeg
volumecontrol1.jpeg (74.64 KiB) Viewed 991 times


volumecontrol2.jpeg
volumecontrol2.jpeg (57.39 KiB) Viewed 991 times


All formats work when recording with Sound Recorder, expect for m4a and ogg. Don't know why those formats don't work, but they don't.

Hope that helps. :)

Jeff
Asus Sabertooth X79 mobo/i7-3930k/Cooler Master Hyper 212 EVO/32GB Corsair Vengeance DDR3 RAM/Nvidia GTX670/Crucial 128GB SSD/Samsung 540GB SSD/ 2 1TB WD hard drives
User avatar
jlr1701
Level 4
Level 4
 
Posts: 235
Joined: Mon Jul 13, 2009 3:22 am
Location: Anchorage, AK

Re: Internal microphone on Dell Mini 10v

Postby rwhite5279 on Thu Dec 31, 2009 1:45 am

Thanks for checking in, Husse & Jeff. I appreciate your taking a look at this.

Still no such luck on my end after playing around with the settings a bit more. I configured my settings as yours are, Jeff, although I only have a single channel showing. Perhaps you're on a Dell Inspiron Mini 10, rather than the 10V?

In any event, I appreciate your efforts here. As I mentioned above, I can hear hissing when I crank up the Front Mic Boost, and my voice every so faintly when I actually try to record. Aside from that, nada.

Hmmm...
rwhite5279
Level 1
Level 1
 
Posts: 3
Joined: Sat Dec 12, 2009 4:49 pm

Re: Internal microphone on Dell Mini 10v

Postby jlr1701 on Thu Dec 31, 2009 10:48 am

I checked just to be sure on Dell's website, and according to them my system is a 10v, which is what I ordered. :) Here's an article on the differences between the 10 and the 10v, but nothing is mentioned about the microphone being any different:

http://www.dell.com/content/topics/segt ... &~lt=popup

Maybe your microphone isn't being detected properly? Being still pretty much a Linux newbie, I'm at a loss for anything else to suggest... I just dunno...
Asus Sabertooth X79 mobo/i7-3930k/Cooler Master Hyper 212 EVO/32GB Corsair Vengeance DDR3 RAM/Nvidia GTX670/Crucial 128GB SSD/Samsung 540GB SSD/ 2 1TB WD hard drives
User avatar
jlr1701
Level 4
Level 4
 
Posts: 235
Joined: Mon Jul 13, 2009 3:22 am
Location: Anchorage, AK


Return to Hardware Support

Who is online

Users browsing this forum: Earendillo and 10 guests