Needing help with Intel 945GM drivers

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Needing help with Intel 945GM drivers

Postby Awesomeish on Wed Jan 27, 2010 5:13 pm

Hello, sorry if this is a stupid question, but I'm completely new to Linux and a lot of things are rather confusing to me :( if someone could please help I'd most appreciative!

I'm having some problems with graphics drivers.. I think. Well, from what I understand, Mint will automatically install the correct drivers for you, though I'm not sure if I have the correct/latest drivers for my (terrible) 945GM graphics. If I try to run something in Wine, then it would either be really blocky, very slow, or just not run at all. If I try to run a native Linux game (Warsow for example), I still get the same problems.

I've tried to download and install (what I believe is) the correct drivers (from here: http://downloadcenter.intel.com/confirm ... *&lang=eng), but I'm really not understanding how to install them :(. I think I need to use the terminal? But as I say, I'm incredibly inexperienced with it :P.

This might be causing other problems too, as Mint is running just a tad bit slower than how I thought it would.

Would installing these drivers help? And if so, how do I do so? :D

And if it helps, here's what I'm using:
Toshiba Satellite laptop dual booting with Mint 8 (main) and Vista
Intel 945 GM graphics
T2080 dual core (1.7 Ghz)
2 GB ram
Awesomeish
Level 1
Level 1
 
Posts: 6
Joined: Sat Jan 23, 2010 9:40 pm

Linux Mint is funded by ads and donations.
 

Re: Needing help with Intel 945GM drivers

Postby remoulder on Wed Jan 27, 2010 6:38 pm

Open a terminal and type inxi -G then copy and paste the output in a reply
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Needing help with Intel 945GM drivers

Postby Awesomeish on Wed Jan 27, 2010 6:55 pm

Thanks for the reply!

Here's what it says:
Code: Select all
Graphics:  Card Intel Mobile 945GM/GMS 943/940GML Express Integrated Graphics Controller X.Org 1.6.4 Res: 1440x900@59.9hz
           GLX Renderer Mesa DRI Intel 945GM GEM 20090712 2009Q2 RC3 x86/MMX/SSE2 GLX Version 1.4 Mesa 7.6
Awesomeish
Level 1
Level 1
 
Posts: 6
Joined: Sat Jan 23, 2010 9:40 pm

Re: Needing help with Intel 945GM drivers

Postby remoulder on Thu Jan 28, 2010 4:12 pm

You are using the correct driver, do not install the intel driver, this is not intended for your system. Have you got an xorg.conf file in /etc/X11? If so try renaming it in a terminal and rebooting your system.
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup


The only other things that might help is to turn off visual effects on the Appearance options and if possible to allocate more system memory to your onboard graphics in the BIOS.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Needing help with Intel 945GM drivers

Postby TonyTonyChopper on Mon Apr 05, 2010 2:07 am

Keywords: Linux, Laptop, Graphics, Resolution, Display, Mirror, External, Monitor, Performance

ISSUE(s): 1. Poor performance of graphically intensive applications. 2. External Monitor Resolution is limited, or low.

SOLUTION(s):
1. The hardware is too slow(old/crappy) to achieve the desired rendering performance for this application. 97% of the time, recent Linux distribution releases will include drivers adequate to run your hardware. As mentioned previously, this can be checked easily by running "inxi -G" from the command line.

2. Control Center > Display Preferences, Uncheck "Mirror screens". Select the notebook display and disable it if desired, then increase the resolution of the external monitor.
TonyTonyChopper
Level 1
Level 1
 
Posts: 1
Joined: Mon Apr 05, 2010 1:56 am


Return to Hardware Support

Who is online

Users browsing this forum: eanfrid and 22 guests