Sound

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Sound

Postby DFergATL on Tue Jul 24, 2007 5:00 pm

I am having a really strange problem with my sound. Sometimes it works sometimes it doesn't. I am confident that the hardware I am using it ok... Here goes.

The Mobo I have has onboard sound "C-Media" this stopped working a long time ago. So, I put in an old SB Live Value card. Now even if I have the "C-Media" disabled in BIOS, Linux can still see it, along with the SB Live Value. I have checked the "Sound" options under Preferences and made sure it was set to the SB, and it is. I have also played with enabling/disabling the old "C-Media" in BIOS. None of this seems to have an effect. But, sometimes when I boot I do get sound without any intervention from me, most of the time I don't. I have every other thing with Mint going just fine. The only thing holding me back is this sound. I know it should work because sometimes it does.

I have tried several live CD's, for example ZenWalk and with the live CD sound works every time.

Also, I don't think that this is specific to Mint. I have had this problem with at least one other Linux distro and with ZetaOS. However, I am so close with Mint and I really want to use it. There has to be somehthing....please my the Linux Gods smile down on me...

Dave
DFergATL
Level 1
Level 1
 
Posts: 24
Joined: Thu Jul 19, 2007 12:36 pm

Linux Mint is funded by ads and donations.
 

More Info

Postby DFergATL on Tue Jul 24, 2007 11:31 pm

OK, I have had some time today to really try and play with this. Here is more on what I have going on.

The Sound setting keeps getting set to "C-Media" after I sent it to my Sound Blaster.

I go into the sound applet and change the setting from "C-Media" to my Sound Blaster.

Then... if I do a "restart"..... I have sound.

If I do a cold boot, I loose sound and the "C-Media" has been re-selected automaticly by the system again......

How to I get it to not change my setting from "Sound Blaster Live" over to "C-Media" whenever the PC is cold booted?


Dave
DFergATL
Level 1
Level 1
 
Posts: 24
Joined: Thu Jul 19, 2007 12:36 pm

Re: More Info

Postby Chinaski on Wed Jul 25, 2007 11:07 am

Try this...

Code: Select all
sudo asoundconf list

Names of available sound cards:
Live
V8237


From the list of soundcards chose the one you want to be default.
Now set the default card. In this example I set it to Live.

Code: Select all
sudo asoundconf set-default-card Live


Live and V8237 are examples
Chinaski
 


Return to Hardware Support

Who is online

Users browsing this forum: feffer, lovenhim and 20 guests