Another solution for sound in Intel ICH7...

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Another solution for sound in Intel ICH7...

Postby jcd on Sat Feb 13, 2010 9:18 pm

lspci:
Code: Select all
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: [b]Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)[/b]
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400
04:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
05:04.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link)
05:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)


Fujitsu-Siemens Amilo Pi 1536

LinuxMint 8 "Helena" Main edition

***
(I put all the above in the beginning of the post so that people searching in the forum might have a better chance of finding this post...)

I've been trying for hours to figure a solution to my "no sound" problem... I tried Husse's standard solution and several other variations, but still I would get no sound...

Strange thing is, I remember hearing the Linux Mint welcome sound when I first logged in, but after installing all the updates and software it was there no more... If I boot from the Live CD it works just fine...

So, to cut it short, the problem was with the proprietary drivers that I was presented with in the tray (you can find it in Menu > Administration > Hardware Drivers)... The title says "Software Modem", and the text underneath says:

The SmartLink modem daemon is the application part of thedriver for recent modems produced by Smart Link Ltd.

This package replaces (along with hardware access drivers) the olddriver generation (2.7.x) which consisted of kernel modules only.

It needs a kernel driver to access the hardware. This can be eitherrecent ALSA (shipped with a newer kernel (>=2.6.4) with Alsa supportand intel8x0m module) which is sufficient for basic operation anddata/Internet connection, or the SmartLink kernel driver which isprovided by separate packages which you can build using the source fromthe sl-modem-source package.

This driver enables the usage of many software modems, as commonly found in laptops.

If this driver is not enabled, you will not be able to use your modem.


I always thought that this has to do with some modem found in my laptop... Modem like in... internet modem...

Well, it seems that this has little to do with the internet and somehow relates to Alsa and sound in my laptop... If I install and go to: Sound Preferences > Hardware tab, there is no device to configure and the Input and Output tabs are grayed out...

If I remove the driver everything returns back to normal...

I wish I understood why but... this is what I found out... This is an entirely ridiculous problem to have, because no solution (found through google, in the ubuntu forums or here) related with Alsa will work, and NOBODY not ONE seems to mention this... Everyone seems to be proposing endless variations of Husse's "standard solution", compiling Alsa drivers (or sth) yourself etc... A total waste of time...


P.S. If someone who reads this knows where to report about the broken drivers, please do so... (I suppose the Mint team should also take a look into this, since it says "Tested by the LinuxMint developers")
jcd
Level 1
Level 1
 
Posts: 28
Joined: Fri Nov 14, 2008 2:34 pm
Location: Athens, Greece

Linux Mint is funded by ads and donations.
 

Re: Another solution for sound in Intel ICH7...

Postby remoulder on Sun Feb 14, 2010 5:22 pm

[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Another solution for sound in Intel ICH7...

Postby jcd on Sun Feb 14, 2010 11:35 pm

I see that now... Thanks! :roll:
jcd
Level 1
Level 1
 
Posts: 28
Joined: Fri Nov 14, 2008 2:34 pm
Location: Athens, Greece


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 11 guests