HP Pavilion dv6, headphone jacks don't output sound

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

HP Pavilion dv6, headphone jacks don't output sound

Postby don_duderino on Sun Feb 14, 2010 6:33 pm

Hi there fellas,
I have here an HP Pavilion dv6 2090eg. At first, sound didn't work at all, but using some of the explanations here I got the internal speakers to work.

In the console:
Code: Select all
$ cat /proc/asound/card0/codec#0 | grep Codec
Codec: IDT 92HD75B3X5


/usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz yielded no exact equivalent, but for STAC92HD71B* I got hp-dv5, which does fit this:
Code: Select all
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


System Information/Devices/PCI Devices gives me this (among others):
Audio device : Intel Corporation 5 Series/3400 Series Chipset High Definition Audio
Audio device : nVidia Corporation Device 0be2


I presume aplay's device 0 (analog) is the Intel component --internal speakers and headphone jacks-- and device 1 is the nVidia component -- HDMI.

Anyway, I added this to my /etc/modprobe.d/alsa-base.conf:
Code: Select all
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel index=0 model=hp-dv5
options snd-hda-intel enable_msi=1


This leads to the current situation:
- Internal speakers work :)
- Internal mike works :)
- Headphone jacks (indeed, this thing has two) are dead :(

Someone else here had a similar problem, and the solution seems to have been to try some different models in the alsa-base file, but I already use the most fitting model. So, I regard it as rather pointless to randomly try some other models.

Any pointers as to what I should try?

Cheers
Don
don_duderino
Level 1
Level 1
 
Posts: 1
Joined: Sun Feb 14, 2010 5:54 pm

Linux Mint is funded by ads and donations.
 

Re: HP Pavilion dv6, headphone jacks don't output sound

Postby Husse on Fri Feb 19, 2010 7:36 am

You might be helped with a "stack" line in alsa-base.conf - check here
Add it or replace the hp-dv5 line
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 18 guests