Pcmcia hard drive not recognized in disc utility

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Pcmcia hard drive not recognized in disc utility

Postby gevetri on Wed Feb 17, 2010 11:16 am

Greetings All,
I am very new to linux. Using mint 8. Cannot get my pcmcia hard drive to be detected in disc utility. I want to use the drive for iso 'burning'. Upon plugging the unit in, it spins up but no other indications on what is happening. What to do? Googled and checked the various forums with no success, so far.

So far, I like mint 8. Just a few complaints. 1. can not use my ultranav the way it was intended. 2. Is the learning curve steep?
gevetri
Level 1
Level 1
 
Posts: 5
Joined: Wed Feb 17, 2010 10:42 am

Linux Mint is funded by ads and donations.
 

Re: Pcmcia hard drive not recognized in disc utility

Postby remoulder on Wed Feb 17, 2010 11:56 am

gevetri wrote:Cannot get my pcmcia hard drive to be detected in disc utility.


Can you open a terminal and posts the outputs of the following with the card plugged in
Code: Select all
lspcmcia -v
psmod | grep pcmcia
dmesg | tail - do this just after you plug in your card
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Pcmcia hard drive not recognized in disc utility

Postby gevetri on Thu Feb 18, 2010 8:40 am

This is what the terminal shows after inputing your suggestion:

==> standard input <==
[ 1793.499374] ata3: PATA max PIO0 cmd 0x31f0 ctl 0x33f6 irq 4
[ 1798.776074] ata3.00: qc timeout (cmd 0xf8)
[ 1798.776081] ata3.00: failed to read native max address (err_mask=0x4)
[ 1799.044374] ata3.01: NODEV after polling detection
[ 1809.052198] ata3.00: qc timeout (cmd 0xf8)
[ 1809.052211] ata3.00: failed to read native max address (err_mask=0x4)
[ 1809.320378] ata3.01: NODEV after polling detection
[ 1819.328203] ata3.00: qc timeout (cmd 0xf8)
[ 1819.328215] ata3.00: failed to read native max address (err_mask=0x4)
[ 1819.596385] ata3.01: NODEV after polling detection
gevetri
Level 1
Level 1
 
Posts: 5
Joined: Wed Feb 17, 2010 10:42 am

Re: Pcmcia hard drive not recognized in disc utility

Postby remoulder on Thu Feb 18, 2010 8:45 am

What about the other bits?
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Pcmcia hard drive not recognized in disc utility

Postby gevetri on Thu Feb 18, 2010 11:54 pm

OK, How about this:
gevetri@gevetri-laptop ~ $ lspcmcia -v
Socket 0 Bridge: [yenta_cardbus] (bus ID: 0000:02:00.0)
Configuration: state: on ready: unknown
Voltage: 5.0V Vcc: 5.0V Vpp: 12.0V
Socket 0 Device 0: [pata_pcmcia] (bus ID: 0.0)
Configuration: state: on
Product Name: ARC ATA V2 (C) ARCHOS S.A.1995-98 Fax +33 1 60 13 99 18
Identification: manf_id: 0x5241 card_id: 0x0043
function: 4 (fixed disk)
prod_id(1): "ARC" (0x1600c80b)
prod_id(2): "ATA" (0xae540ea1)
prod_id(3): "V2" (0x2436ab52)
prod_id(4): "(C) ARCHOS S.A.1995-98 Fax +33 1 60 13 99 18" (0x1d73f1e9)
gevetri@gevetri-laptop ~ $ psmod | grep pcmcia
No command 'psmod' found, did you mean:
Command 'lsmod' from package 'module-init-tools' (main)
psmod: command not found
gevetri@gevetri-laptop ~ $ dmesg | tail
[ 1538.630015] ata3: PATA max PIO0 cmd 0x31f0 ctl 0x33f6 irq 4
[ 1543.904101] ata3.00: qc timeout (cmd 0xf8)
[ 1543.904114] ata3.00: failed to read native max address (err_mask=0x4)
[ 1544.172379] ata3.01: NODEV after polling detection
[ 1554.180195] ata3.00: qc timeout (cmd 0xf8)
[ 1554.180208] ata3.00: failed to read native max address (err_mask=0x4)
[ 1554.448398] ata3.01: NODEV after polling detection
[ 1564.456098] ata3.00: qc timeout (cmd 0xf8)
[ 1564.456111] ata3.00: failed to read native max address (err_mask=0x4)
[ 1564.724389] ata3.01: NODEV after polling detection
gevetri
Level 1
Level 1
 
Posts: 5
Joined: Wed Feb 17, 2010 10:42 am

Re: Pcmcia hard drive not recognized in disc utility

Postby remoulder on Fri Feb 19, 2010 8:45 am

gevetri wrote:Product Name: ARC ATA V2 (C) ARCHOS S.A.1995-98 Fax +33 1 60 13 99 18
Identification: manf_id: 0x5241 card_id: 0x0043
function: 4 (fixed disk)


It does seem to be recognized, though not sure if
gevetri wrote:[ 1543.904101] ata3.00: qc timeout (cmd 0xf8)
[ 1543.904114] ata3.00: failed to read native max address (err_mask=0x4)
[ 1544.172379] ata3.01: NODEV after polling detection

is the reason it's not mounting.

gevetri wrote:No command 'psmod

Sorry my bad typing, should be lsmod | grep pcmcia (lowercase L). Can you also do a sudo fdisk -l and post the output.
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Pcmcia hard drive not recognized in disc utility

Postby gevetri on Fri Feb 19, 2010 11:02 pm

Thanks for being patient.

gevetri@gevetri-laptop ~ $ lspcmcia -v
Socket 0 Bridge: [yenta_cardbus] (bus ID: 0000:02:00.0)
Configuration: state: on ready: unknown
Voltage: 5.0V Vcc: 5.0V Vpp: 12.0V
Socket 0 Device 0: [pata_pcmcia] (bus ID: 0.0)
Configuration: state: on
Product Name: ARC ATA V2 (C) ARCHOS S.A.1995-98 Fax +33 1 60 13 99 18
Identification: manf_id: 0x5241 card_id: 0x0043
function: 4 (fixed disk)
prod_id(1): "ARC" (0x1600c80b)
prod_id(2): "ATA" (0xae540ea1)
prod_id(3): "V2" (0x2436ab52)
prod_id(4): "(C) ARCHOS S.A.1995-98 Fax +33 1 60 13 99 18" (0x1d73f1e9)
gevetri@gevetri-laptop ~ $ lsmod | grep pcmcia
pata_pcmcia 11228 1
pcmcia 36808 1 pata_pcmcia
pcmcia_core 35792 3 pcmcia,yenta_socket,rsrc_nonstatic
gevetri@gevetri-laptop ~ $ dmesg | tail
[ 482.522778] ata3: PATA max PIO0 cmd 0x31f0 ctl 0x33f6 irq 4
[ 487.796195] ata3.00: qc timeout (cmd 0xf8)
[ 487.796207] ata3.00: failed to read native max address (err_mask=0x4)
[ 488.064382] ata3.01: NODEV after polling detection
[ 498.072193] ata3.00: qc timeout (cmd 0xf8)
[ 498.072205] ata3.00: failed to read native max address (err_mask=0x4)
[ 498.340377] ata3.01: NODEV after polling detection
[ 508.348190] ata3.00: qc timeout (cmd 0xf8)
[ 508.348202] ata3.00: failed to read native max address (err_mask=0x4)
[ 508.616375] ata3.01: NODEV after polling detection
gevetri@gevetri-laptop ~ $ sudo fdisk -l
[sudo] password for gevetri:

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x348007bb

Device Boot Start End Blocks Id System
/dev/sda1 * 1 9641 77441301 83 Linux
/dev/sda2 9642 9729 706860 5 Extended
/dev/sda5 9642 9729 706828+ 82 Linux swap / Solaris
gevetri@gevetri-laptop ~ $
gevetri
Level 1
Level 1
 
Posts: 5
Joined: Wed Feb 17, 2010 10:42 am

Re: Pcmcia hard drive not recognized in disc utility

Postby remoulder on Sat Feb 20, 2010 12:55 pm

Sorry gevetri, I don't have an easy answer for you on this. The card is being detected and recognized but the system is unable to initialize the drive and create a block device which could be mounted.

I have been looking for a solution to your problem but so far haven't found anything specific that might help. I realize that you are new to linux but unsure of your knowledge of computers in general so I am giving you these links in the hope they may be some use if you can understand them.

firstly have a look at http://www.linux-on-laptops.com/ and see if there's anything there specific to your model or make.

You might also want to look at http://pcmcia-cs.sourceforge.net/ftp/doc/PCMCIA-HOWTO.html#toc1 and http://tldp.org/HOWTO/PCMCIA-HOWTO.html#toc1 for information, though these are fairly heavy going in places.

You could also try the suggestion in http://ubuntuforums.org/showthread.php?t=1237360 but I have doubts whether it will help.

Anyone else have any suggestions?
[Edit] your original post and add [SOLVED] once your question is resolved.

“The people are my God” stressing the factor determining man’s destiny lies within man not in anything outside man, and thereby defining man as the dominator and remoulder of the world.
User avatar
remoulder
Level 17
Level 17
 
Posts: 7667
Joined: Fri May 09, 2008 1:14 pm

Re: Pcmcia hard drive not recognized in disc utility

Postby gevetri on Sat Feb 20, 2010 1:29 pm

Thanks for the try. The sourceforge (2nd link) suggestion seems to be the one with the correct information but, it's too heavy for me to understand.
gevetri
Level 1
Level 1
 
Posts: 5
Joined: Wed Feb 17, 2010 10:42 am

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 11 guests