[SOLVED] Wireless Switch not automatically turning on

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

[SOLVED] Wireless Switch not automatically turning on

Postby bp96 on Fri Feb 19, 2010 5:25 am

When I startup my Mint 8, my wireless switch doesn't automatically turn on. It used to but now it doesn't. To get it turned on I have to run this command after logging on: gksudo modprobe iwl3945
I've added it to the list of startup apps but every time I startup my computer, I have to enter my password twice (1. to log on 2. to run gksudo modprobe command)
Also, when I turn my computer on and I want to login to another account, I have to login to my account to get wireless working and then switch users. And then I have to wait a while for nm-applet to connect. I've tried using wicd but I had problems with it so I reinstalled nm-applet again.

So, how do I get my wireless switch to automatically turn on when starting up without running the command after login?
Last edited by bp96 on Mon Mar 08, 2010 1:16 pm, edited 1 time in total.
bp96
Level 3
Level 3
 
Posts: 107
Joined: Fri Feb 19, 2010 5:16 am

Linux Mint is funded by ads and donations.
 

Re: Wireless Switch not automatically turning on

Postby viking777 on Fri Feb 19, 2010 6:51 am

In a terminal

Code: Select all
sudo gedit /etc/modules


Add iwl3945 to the end of the file, save and reboot.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: Wireless Switch not automatically turning on

Postby bp96 on Fri Feb 19, 2010 9:29 am

Thanks it worked!
bp96
Level 3
Level 3
 
Posts: 107
Joined: Fri Feb 19, 2010 5:16 am


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 18 guests