2007 Macbook - no sound from headphone jack

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

2007 Macbook - no sound from headphone jack

Postby souslefauteuil on Wed Mar 31, 2010 11:18 pm

Hello all,

I just installed Linux Mint 8 (main edition, not universal) on my Macbook (bought in August 2007) this evening, and everything's going well so far except trying to get sound out of my headphones. I have been searching Google with all different combinations of keywords for the past hour and a half trying to find a fix, but I can't figure it out. I get sound from my computer's speakers if I unplug my headphones, but as soon as I plug them in there's no sound at all.

I downloaded the latest ALSA driver and attempted to mod it as instructed on this page: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/184314/comments/49, but got a ton of errors building it so it didn't work.

I also installed the gnome-alsamixer from the Package Manager, and that did nothing as well.

I'm a Linux newbie -- this is my first time having anything besides Windows or OS X installed on my computer -- so I'm kind of completely lost right now. If anybody has any help or advice they could offer (hopefully in a newbie-friendly way), I would be extremely appreciative. (I just want to listen to my music while my roommate is sleeping!). If there is any other information you need me to post, please let me know.

Thanks in advance
souslefauteuil
Level 1
Level 1
 
Posts: 1
Joined: Wed Mar 31, 2010 11:04 pm

Linux Mint is funded by ads and donations.
 

Re: 2007 Macbook - no sound from headphone jack

Postby Jay514 on Thu Apr 01, 2010 1:03 am

Welcome To Linux Mint
I am unsure about Macs as I do not know what the specs of your sound card are , although you may find one of the routes & or links in the How To Post loacated HERE = viewtopic.php?f=42&t=32293
I hope this helps, Have a Good Day
Image
" Do Not Do Wrong Twice,That Which You Could Have Done Right The First Time"

Main = HP Pavilion DV4-1275mx - OS=Mint_CE x64KDE/LXDE,& x64Kubuntu
User avatar
Jay514
Level 5
Level 5
 
Posts: 658
Joined: Wed Mar 25, 2009 2:14 pm
Location: Atlanta GA USA


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 20 guests