Ati Mobility X1600 with Philips Monitor

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Ati Mobility X1600 with Philips Monitor

Postby Bommel on Fri May 14, 2010 12:03 pm

I'm using an 'old' laptop. A HP (Compaq) NX9420 with ATI Radeon Mobility X1600 graphics card. The TFT screen of the laptop does not work anymore. So I made a desktop of this machine by using an external Philips 22" TFT screen.
In Linux Mint 8 this works fine. I disabled the laptop screen and enabled only the Philips.
Now I want to use Linux Mint 9 and this screen does not work anymore. The Philips screen gives an unusable 'waving/shivering' screen. In the resolution 1440x800 (I believe) it is like a sea of waves scrolling from left to right. When I change to the right resolution 1650x1250 (Both 60Hz) the screen is in a high speed shivering wave which makes the screen totally unusable.
I have tried many restarts with live CD and with blank installations. ( I mean no update, but formatting the HD and a new install).
Just one time I had a nice screen like it has to be, so it must be possible to let it work fine.

It is not a problem of the monitor. I connected today the monitor to another PC (with Linux Mint 9 livecd and a NVidia graphics card) and I had inmediately a perfect screen. So it has to be a problem of the ATI driver.

I’m trying Ubuntu 10.04 too. This monitor/graphics driver problem is in 10.04 exactly the same.

I wish you succes with developping Linux Mint 9!!

Best regards
Hans Baars
The Netherlands

Can anyone help me to solve this problem?
Thanks!!
Bommel
Level 1
Level 1
 
Posts: 4
Joined: Sat May 01, 2010 11:45 am

Linux Mint is funded by ads and donations.
 

Re: Ati Mobility X1600 with Philips Monitor

Postby Godfather8850 on Wed Jun 23, 2010 8:19 pm

Hello my friend!!

I am writing to ask you if you were able to solve the problem with your ATI Radeon X1600 and the VGA connection with your TV. I have the same problem too with a Samsung TV and any advice can be helpful! I have looked all over the place and the screen seems to have the same problem with yours. Shaking image etc.

Thank you in advance for your assistance.

Best Regards,
Stan
Godfather8850
Level 1
Level 1
 
Posts: 3
Joined: Wed Jun 23, 2010 7:26 pm


Return to Hardware Support

Who is online

Users browsing this forum: Google [Bot] and 15 guests