no 3d support with nvidia 7300 GT

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

no 3d support with nvidia 7300 GT

Postby bjb1959 on Sun Sep 09, 2007 10:20 am

I recently upgraded my video card from a geforce 5200 fx to a geforce 7300 gt and Just installed mint 3. After I install the NVIDIA drivers I can't get mint to see the card as anything but "vesa" when I run the installer and reboot the X-server crashes and I have to change the xorg.conf line to use the "nv" driver to get x to start. I was finally able to get x to start using the nvidia-xconfig command. X starts now but I don't have any 3d support and mint just sees the card as a vesa card with framebuffer settings only. I can't change the card or anything. Never had this problem with the geforce 5200 fx card. Here is my xorg.conf file.... this is modified by the nvidia-xconfig utility. I am not able to change the display settings for the card from framebuffer or vesa to get 3d support. According to the nvidia site the 7300 GT is supported by the latest driver which is what I am using. Any ideas?

Section "ServerLayout"
Identifier "Layout[all]"
Screen "Screen[0]" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "microsoftpro"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "12"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech USB-PS/2 Optical Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
ModeLine "1280x1024" 107.0 1280 1360 1496 1712 1024 1025 1028 1059
ModeLine "1280x1024" 87.8 1280 1328 1360 1440 1024 1027 1034 1053 +hsync -vsync
ModeLine "1152x864" 105.0 1152 1224 1352 1552 864 865 868 902
ModeLine "1152x864" 96.8 1152 1224 1344 1536 864 865 868 900
ModeLine "1152x864" 89.6 1152 1224 1344 1536 864 865 868 897
ModeLine "1152x864" 86.8 1152 1200 1232 1312 864 867 871 895 +hsync -vsync
ModeLine "1152x864" 81.6 1152 1216 1336 1520 864 865 868 895
ModeLine "1024x768" 81.8 1024 1080 1192 1360 768 769 772 802
ModeLine "1024x768" 76.2 1024 1080 1192 1360 768 769 772 800
ModeLine "1024x768" 69.7 1024 1080 1184 1344 768 769 772 798
ModeLine "1024x768" 69.5 1024 1072 1104 1184 768 771 775 796 +hsync -vsync
ModeLine "1024x768" 64.1 1024 1080 1184 1344 768 769 772 795
ModeLine "800x600" 48.9 800 840 920 1040 600 601 604 627
ModeLine "800x600" 45.5 800 840 920 1040 600 601 604 625
ModeLine "800x600" 44.0 800 848 880 960 600 603 607 622 +hsync -vsync
ModeLine "800x600" 42.1 800 840 920 1040 600 601 604 623
ModeLine "800x600" 38.2 800 832 912 1024 600 601 604 622
ModeLine "768x576" 45.5 768 808 888 1008 576 577 580 602
ModeLine "768x576" 41.7 768 800 880 992 576 577 580 600
ModeLine "768x576" 40.8 768 816 848 928 576 579 583 597 +hsync -vsync
ModeLine "768x576" 38.6 768 800 880 992 576 577 580 598
ModeLine "768x576" 35.0 768 792 872 976 576 577 580 597
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "SAM"
ModelName "SAMSUNG SYNCMASTER"
UseModes "Modes[0]"
DisplaySize 376 301
HorizSync 30.0 - 81.0
VertRefresh 43.0 - 75.0
Option "CalcAlgorithm" "XServerPool"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "VESA"
BoardName "Framebuffer Graphics"
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "800x600" "768x576"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600" "768x576"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "768x576"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "800x600" "768x576"
EndSubSection
EndSection
User avatar
bjb1959
Level 1
Level 1
 
Posts: 22
Joined: Fri Jul 27, 2007 11:26 am
Location: Omaha, NE

Linux Mint is funded by ads and donations.
 

Postby Husse on Tue Sep 11, 2007 5:59 am

Your xorg.conf looks a bit bizarre
Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "VESA"
BoardName "Framebuffer Graphics"
EndSection

This is completely wrong!
vesa is no vendor and framebuffer as board name....
It has been all mixed up some way
Try reinstalling in Envy or if you prefer the "conventional way"
First uninstall the driver and then install
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

reinstall

Postby bjb1959 on Tue Sep 11, 2007 8:33 am

Husse wrote:Your xorg.conf looks a bit bizarre
Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "VESA"
BoardName "Framebuffer Graphics"
EndSection

This is completely wrong!
vesa is no vendor and framebuffer as board name....
It has been all mixed up some way
Try reinstalling in Envy or if you prefer the "conventional way"
First uninstall the driver and then install


I have already done this once, did a fresh install and then used envy first thing with the same result but I will try it again tonight and respond tomorrow.
User avatar
bjb1959
Level 1
Level 1
 
Posts: 22
Joined: Fri Jul 27, 2007 11:26 am
Location: Omaha, NE

Postby carlos on Tue Sep 11, 2007 11:23 am

You can also go to the nvidia site and download the i386 driver for your card and run its installer. Just read the instructions in the readme file. its pretty straight forward. it will write out the xorg file for you with the correct settings.
____________ ________ ______ ____ ___ __ __ _
http://www.designdrifter.com
The Purpose of Life is for DNA to reproduce.
User avatar
carlos
Level 5
Level 5
 
Posts: 526
Joined: Thu Dec 14, 2006 4:30 pm
Location: USA

Postby Husse on Wed Sep 12, 2007 6:40 am

Come to think of it - you could also try to reconfigure x
Code: Select all
sudo dpkg-reconfigure -phigh xserver-xorg
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Thanks Husse....

Postby bjb1959 on Thu Sep 13, 2007 6:47 pm

Don't know what it was but I re-installed and just used the restricted driver the nvidia driver worked. I had to use dpkg-reconfigure -phigh xserver-xorg to set the resolution to 2048x1024. after installing the latest compiz-fusion and emerald I also had to use nvidia-xconfig --add-argb-glx-visuals -d 24 to be able to get emerald to work but after that everything worked great. Thanks for all of your help....
User avatar
bjb1959
Level 1
Level 1
 
Posts: 22
Joined: Fri Jul 27, 2007 11:26 am
Location: Omaha, NE


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 13 guests