[SOLVED] sound on Fujitsu Li 1718 Laptop

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

[SOLVED] sound on Fujitsu Li 1718 Laptop

Postby roadrash on Sun Sep 16, 2007 7:10 pm

I have just installed Linux Mint cassandra Kde edition on my laptop & havent been able to get the sound to work.
Before I installed mint i had already installed Ubuntu 7.04 & got the network & sound working on that first so when i used the same proceedure on mint i expected it to work for that as well.
I got the wireless network working but not the sound.
The sound system is ATi Sb450 HDA audio and to get it to work in Ubuntu I had to append the file \etc\modprobe.d\alsa-base with the following line:-

options snd-hda-intel index=0 model=3stack


But this didn't work for mint cassandra. Does anyone know whats wrong?
Last edited by roadrash on Mon Sep 17, 2007 10:30 am, edited 1 time in total.
User avatar
roadrash
Level 2
Level 2
 
Posts: 77
Joined: Tue Nov 21, 2006 4:11 pm
Location: Huntingdon U.K.

Linux Mint is funded by ads and donations.
 

Fixed it

Postby roadrash on Mon Sep 17, 2007 10:30 am

It's Ok I fixed it.

I had to get hold of a alsaconf shell script & put it in the /usr/sbin/ folder.
then open a terminal & run sudo alsaconf
User avatar
roadrash
Level 2
Level 2
 
Posts: 77
Joined: Tue Nov 21, 2006 4:11 pm
Location: Huntingdon U.K.

Postby Monkwarrior on Mon Sep 17, 2007 1:05 pm

Where did you get that alsaconf script ?
Did you use the repositories for that ?

Monk.
Monkwarrior
Level 1
Level 1
 
Posts: 12
Joined: Sun Sep 16, 2007 2:55 am

Postby roadrash on Wed Sep 19, 2007 9:45 am

its available in a lot of distros but not in mint for some reason.

Ok right click on this link and select save as:

http://homepage.ntlworld.com/roadrash/alsa.conf

The file should be saved as alsa.conf and then copy it into the /usr/sbin/ folder.

now add this extra line to the end of the /etc/modprobe.d/alsa-base file.

options snd-hda-intel index=0 model=3stack


now open a terminal & enter:
sudo alsaconf

when asked something just keep selecting ok or enter.
once its done the sound should work but you may need to log out and in again first.
User avatar
roadrash
Level 2
Level 2
 
Posts: 77
Joined: Tue Nov 21, 2006 4:11 pm
Location: Huntingdon U.K.


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 16 guests