For those with TV cards...

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

For those with TV cards...

Postby cyberguy03 on Sat Sep 29, 2007 1:57 pm

I have an MSI TV@nywhere and had a few issues getting it working well, especially sound-wise, so maybe it can help out people with other cards.

Mint has the video4linux drivers already set to go so....

For TV watching:
Get tvtime.

Code: Select all
sudo apt-get install tvtime


It works very fast, is easy to configure, and detects the card seamlessly with v4l. Its only downfall is that audio doesn't work. Not the program's fault, really, the card is picky about it and runs the sounds through DMA. For that, we need sox and a little OSS emulation.

I know what you're thinking, "OSS? C'mon." I know, I know. I'm an alsa man myself, really. But running the sounds from the card through the OSS DSP does work out better. Fear not though, you can run OSS on top of (or, I guess, under) your alsa with little problem.

Code: Select all
sudo apt-get install sox


For OSS install info, check around for one of its many, many tutorials.

Anyway, then make yourself a little script with the following:

Code: Select all
#!/bin/sh
(sleep 5; amixer -q -c 0 sset PCM 80%,80%  unmute; exec sox -q -c 2 -s -w -r 32000 -t ossdsp /dev/dsp1 -t ossdsp -w -r 32000 /dev/dsp) &
tvtime --mixer=/dev/mixer:pcm
kill `ps | awk '/sox/ && !/awk/ {print $1}'`
amixer -q -c 0 sset PCM 80%,80%  unmute

Huzzah! Great picture AND great sound.

For TV Recording:

Coming Soon to a TiVo near you. Just kidding, sort of. I actually haven't messed around much with TV recording yet, but I will try to do some experimenting with mencoder and mythTV and post an update.

For Radio Listening/Recording:

Get gnomeradio. I figure I can skip the whole apt-get code snippet this time, I'm sure you can figure it out

Unfortunately, this suffers from the same flaw that tvtime did, no sound. However, the fix is the same:

Code: Select all
#!/bin/sh
(sleep 5; amixer -q -c 0 sset line 80%,80%  unmute; exec sox -q -c 2 -s -w -r 32000 -t ossdsp /dev/dsp1 -t ossdsp -w -r 32000 /dev/dsp) &
gnomeradio
kill `ps | awk '/sox/ && !/awk/ {print $1}'`
amixer -q -c 0 sset line 80%,80%  unmute


You may need to change the radio device setting (default is /dev/radio), as for whatever reason my system has it as /dev/radio0. Additionally, it wouldn't hurt to sudo chmod 755 /dev/radio (or radio0 or what have you) just to be safe.

Happy TV watching and radio listening!
cyberguy03
Level 1
Level 1
 
Posts: 15
Joined: Sun Nov 19, 2006 5:09 pm

Linux Mint is funded by ads and donations.
 

Postby Husse on Sun Sep 30, 2007 11:34 am

Thanks!
I made a small edit so that
Huzzah! Great picture AND great sound.
ended up outside the code box :)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: For those with TV cards...

Postby barkhat on Sat Dec 01, 2007 5:00 pm

Thanks for the instructions, Cyberguy. I will give it a whirl. But first...

When I open the program it says: "No video source. No signal. Cannot open capture device /dev/video0." I"m not sure why I am getting this but here are the computer particulars:

Gateway computer that came with Vista installed. (I already have a problem getting back to Vista, but that's posted in another forum). I have two hard drives. The second one (and this is the only one I can access) has Mint 4.0 on it now. When I check the stats on the gateway site I read that this model computer : TV Tuner Cards - 6008105R - AVerMedia M791 NTSC/ATSC TV Tuner Card .

I really don't know what the problem is as I could watch TV fine when I was able to access Vista. Any guidance would be appreciated. I'm no entirely new to Linux but I"m not that experienced, either.

Thanks.
User avatar
barkhat
Level 2
Level 2
 
Posts: 53
Joined: Sat Jun 16, 2007 1:28 am


Return to Hardware Support

Who is online

Users browsing this forum: djalf, IMH and 14 guests