Enabling Laptop_Mode

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

Enabling Laptop_Mode

Postby smashbadger on Sat Dec 01, 2007 4:55 am

Hello,

I'm new to linux and I've been struggling with this one for awhile =/ My laptop suffers from its load_cycle increasing to rapidly , leading to an early death for its hard drive (its a Dell Vostro 1500, btw). Anyway, I thought the best way to get around this problem was enabling laptop mode and editing its .conf file so that hdparm sets the proper power management and spindown settings. My problem now is that I just can't seem to enable it, heres what I get:
Code: Select all
$ sudo laptop_mode start
: integer expression expected86: [: 0
: integer expression expected04: [: 7200
: integer expression expected07: [: 7200
: integer expression expected10: [: 7200
: integer expression expected13: [: 7200
: integer expression expected16: [: 7200
: integer expression expected04: [: 320
: integer expression expected07: [: 320
: integer expression expected10: [: 320
: integer expression expected13: [: 320
: integer expression expected16: [: 320
: integer expression expected04: [: 7200
: integer expression expected07: [: 7200
: integer expression expected10: [: 7200
: integer expression expected13: [: 7200
: integer expression expected16: [: 7200
: integer expression expected22: [: 1
: integer expression expected47: [: 1
: integer expression expected96: [: 1
: integer expression expected13: [: 1
Laptop mode enabled, active.
: integer expression expected37: [: 1
: integer expression expected98: [: 0
: integer expression expected28: [: 1
")syntax error: invalid arithmetic operator (error token is "


Even though it says laptop mode enabled, it isn't as when I pull out the ac plug and check to see what the power savings status is of my hard drive it hasn't changed to the new setting I put in laptop-mode.conf . Before it would beltch out stuff about commands not found on such and such line, but I realized that it was trying to interpret all those blank lines in the file that weren't commented out. Many #'s solved that one. Any help would be great, as I'd like to stop worrying about my hdd impedending doom :> (I also tried the 'ugly fix' but that didn't work)

-smashbadger
smashbadger
Level 1
Level 1
 
Posts: 3
Joined: Tue Nov 27, 2007 2:46 am

Linux Mint is funded by ads and donations.
 

Re: Enabling Laptop_Mode

Postby Husse on Sat Dec 01, 2007 1:46 pm

Take a look at this post with a long discussion about the wear and tear of hard disks. And if I remember correctly there's also an example for how configure this
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 9 guests