Mint 11 - USB 3.0 not working

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Mint 11 - USB 3.0 not working

Postby HellMan on Tue Jun 21, 2011 3:52 am

Hello!
I've installed Mint 11 and sadly USB 3.0 port is not working, though on Mint 10 it was.
Laptop is Asus N53SV.

Here's some info:
Code: Select all
~ $ lsusb
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 003: ID 09da:000a A4 Tech Co., Ltd Port Mouse
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 04f2:b1bb Chicony Electronics Co., Ltd
Bus 001 Device 003: ID 13d3:3304 IMC Networks
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Code: Select all
~ $ lspci | grep -i usb
00:1a.0 USB Controller: Intel Corporation 6 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1d.0 USB Controller: Intel Corporation 6 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
04:00.0 USB Controller: Fresco Logic FL1000G USB 3.0 Host Controller (rev 04)


Code: Select all
~ # lspci -vvnn
04:00.0 USB Controller [0c03]: Fresco Logic FL1000G USB 3.0 Host Controller [1b73:1000] (rev 04) (prog-if 30 [XHCI])
   Subsystem: ASUSTeK Computer Inc. Device [1043:1039]
   Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
   Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Latency: 0, Cache Line Size: 64 bytes
   Interrupt: pin A routed to IRQ 44
   Region 0: Memory at dd200000 (32-bit, non-prefetchable) [size=64K]
   Capabilities: [50] Power Management version 3
      Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0+,D1-,D2-,D3hot+,D3cold-)
      Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
   Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
      Address: 00000000feeff00c  Data: 4179
   Capabilities: [80] Express (v1) Endpoint, MSI 00
      DevCap:   MaxPayload 128 bytes, PhantFunc 0, Latency L0s <2us, L1 <32us
         ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
      DevCtl:   Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
         RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
         MaxPayload 128 bytes, MaxReadReq 512 bytes
      DevSta:   CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
      LnkCap:   Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 unlimited, L1 unlimited
         ClockPM- Surprise- LLActRep- BwNot-
      LnkCtl:   ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
         ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
      LnkSta:   Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
   Kernel driver in use: xhci_hcd
   Kernel modules: xhci-hcd


Also, if i put something in this USB 3.0 port, and then run lsusb, it hangs for some time. After that dmesg shows this:
Code: Select all
[17297.051892] xhci_hcd 0000:04:00.0: Timeout while waiting for a slot
[17297.051905] hub 3-0:1.0: couldn't allocate port 2 usb_device
<O/
User avatar
HellMan
Level 1
Level 1
 
Posts: 12
Joined: Tue Sep 29, 2009 9:26 am
Location: St. Petersburg, Russia

Linux Mint is funded by ads and donations.
 

Re: Mint 11 - USB 3.0 not working

Postby AlbertP on Tue Jun 21, 2011 11:56 am

There's a bug in the xhci_hcd driver at the moment: https://bugs.launchpad.net/ubuntu/+sour ... bug/775543

Probably it's fixed when installing the 2.6.39 kernel. This kernel also introduces USB 3.0 hub support.
Here's a tutorial how to install it: viewtopic.php?f=42&t=40185
And here the actual kernel: http://kernel.ubuntu.com/~kernel-ppa/ma ... 1-oneiric/
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Mint 11 - USB 3.0 not working

Postby HellMan on Wed Jun 22, 2011 8:40 am

Thanks for the answer!
I've installed 2.6.39 kernel and it hasn't helped. Also, maybe the problem is that I am using pae kernel?

Code: Select all
~ $ uname -a
Linux hellpc 2.6.39-0-generic-pae #5~20110427-Ubuntu SMP Wed Apr 27 18:53:48 UTC 2011 i686 i686 i386 GNU/Linux
<O/
User avatar
HellMan
Level 1
Level 1
 
Posts: 12
Joined: Tue Sep 29, 2009 9:26 am
Location: St. Petersburg, Russia

Re: Mint 11 - USB 3.0 not working

Postby AlbertP on Wed Jun 22, 2011 9:09 am

It shouldn't really matter. You could try booting the non-PAE kernel with the 'Older Linux versions' option in the boot menu, but I don't think it will help.

Please open the bug link that I gave, and click the link that it also affects you. That way the bug gets more importance.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 16 guests