No Surround Sound In LM11:XtremeAudio

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

No Surround Sound In LM11:XtremeAudio

Postby SpawnHappyJake on Wed Jun 29, 2011 2:56 pm

Dear Linux Mint People,

The question: how do I get 5.1 surround sound with the Creative Labs Sound Blaster X-Fi XtremeAudio sound card in Linux Mint 11 64-bit?

I have a new Dell XPS 8300 dual booted between Linux Mint 11 Katya 64-bit and Windows 7 Home Premium 64-bit. i7 processor, 8 gigs of RAM, the Creative Labs Sound Blaster X-Fi XtremeAudio sound card, and a Redwood Radeon HD 5600 Series graphics card. Very nice computer indeed. Linux has become my main OS, so after imaging, installing a Mint side was the first thing I did - before even booting into Windows! I've been using Mint since Mint 7. I'm not a Linux n00b, but not a super-guru either. Just to know where I'm coming from, I have used terminal, compiled from source, hunted for dependencies, edited config files, mounted from terminal, and know about hardware abstraction files. But apparently, I'm NOT good enough yet to get this sucker.
The sound card is a Creative Xtreme Audio sound card. It is capable of stereo, 5.1, and 7.1. I have a 5.1 speaker set. Just put the green in the green the yellow in the orange and the black in the black, told Windows that I want 5.1, and it sounds BEAUTIFUL in surround...in Windows. Well, you know how Windows is. I would like to be able to have surround sound in Linux! No...LOVE to be able to have surround sound in Linux!
Note that the graphics card also shows up as a sound device.
I went down to the speaker icon (by defualt in the lower right), clicked it, went to sound preferences, went to the Hardware tab, selected "[SB X-Fi Xtreme Audio] CA0110-IBG", and made the profile be "Analog Surround 5.1 Output" like it should be. I went to the output tab and I selected this card, which unselects the other audio device that used to be selected: "Redwood HDMI Audio [Radeon HD 5600 Series] Digital Stereo (HDMI)". NOTHING is muted. I even installed and ran gnome-alsamixer - no channels muted.
I select this card under the hardware tab, go to "Test Speakers" and NONE of the speakers fire when I click any of the "Test" buttons.
I open an audio file with vlc and sound comes ONLY out of the left front and right front speakers, like normal stereo. The SAME audio file played on my Windows side yields a beautiful surround sound.
Also, not to ask another question, but rather to bring in more relevant info, I compiled WINE 1.3.23 from source and tried to install and play Battle for Naboo. After compiling, Battle for Naboo said that it could not detect a sound card, had several errors, and was just very unhappy. Ultimately it crashes before you even get into the LucasArts, Factor5, etc. ads. I know I compiled sound support because the only thing I left out was OpenCL support, and ./configure gave no warnings (I did --without-opencl which makes that warning go away). Still crashed and was still silent after doing a "killall pulsaudio".
I did A LOT of Googling. Hours. Almost instantly I found out about the Creative open-sourced X-Fi beta driver. Every download link was a wild goose chase that ultimately looped back on itself. I WAS able to get the XFiDrv_Public_US_1.00.tar.gz file. Not the 1.18 that everyone talks about. I have NO CLUE where they got that. Lots of former links now yield a 404 error (page not found). It doesn't compile. I get make errors, just like everyone else on the Internet says. But unlike everyone else on the Internet, I can't go to sound/whatever.h(or c) and edit the source code like whatshisname says because there is no sound folder in the 1.00 tarball. There are NO folders in the 1.00 tarball. Everything is on the root directory. And the files they mention to edit aren't there either.
I don't even know if this driver will fix the situation even if I DID get it compiled. That driver isn't really intended for the XtremeAudio, but there is a note saying that it might work with it: http://opensource.creative.com/soundcard.html. Just Ctrl+F for "{" and that note will pop right up. Oddly, even if you do follow the alleged links (either Asian, US, OR World-Wide), pick the sound blaster sound card, then pick a sound card, then go down and click "View All Downloads", the beta driver is NOT in the list. But if you type in "Linux" in the search bar, the 1.00 driver tarball DOES come up, and that's how I got it. But NO 1.18!
I have found other elaborate methods on the Internet, but they say their methods are useless if you have a new kernel because the new kernels already support it.

It would be really nice if I got this working with OSS because WINE doesn't do ALSA anymore. If I have do, I guess I can just get an ALSA-to-OSS wrapper. But I also read at the ALSA website that ALSA is backward compatible with OSS. Doing a "killall pulseaudio" is supposed to get sound to work in WINE.

But don't get too distracted that I mentioned WINE. Let's focus on getting native vlc to output surround sound. I went into vlc preferences and tried the different auido outputs except for UNIX OSS audio output because I don't know which hardware abstraction file to pick. The default hardware abstraction file for UNIX OSS audio output is /dev/dsp, which doesn't exist on my computer. I don't know how to tell the kernel to make an abstraction file for my sound card, either. Do I need to do that?
I know that the current driver or kernel module or whatever it is CAN detect the sound card as a sound device because it shows up that way in the above mentioned hardware tab, in HardInfo, in lspci, and other things. It just can't use it as a 5.1 device.

And shouldn't that terribly startling noise when I log into Mint be 5.1 if it's enabled :wink: ?
User avatar
SpawnHappyJake
Level 1
Level 1
 
Posts: 36
Joined: Mon Apr 25, 2011 1:15 am

Linux Mint is funded by ads and donations.
 

Re: No Surround Sound In LM11:XtremeAudio

Postby SpawnHappyJake on Fri Jul 01, 2011 1:09 am

Ok, never mind the WINE stuff. I installed WINE from the ppa and Battle for Naboo installed without a compliant. WINE/ Battle for Naboo detected the sound card, and I DID get sound through my left front and right front speakers, like normal for that game.
The issues still stands that I am not getting 5.1 surround sound when I play an audio file in Linux and I DO get 5.1 surround sound from that same audio file played in Windows.
It would be really great if someone helped me.

Cheers,
Jake
User avatar
SpawnHappyJake
Level 1
Level 1
 
Posts: 36
Joined: Mon Apr 25, 2011 1:15 am

Biweekly Bump

Postby SpawnHappyJake on Mon Jul 11, 2011 10:48 pm

Anyone know how to get the Creative Labs XtremeAudio sound card working and making 5.1 surround audio in Linux Mint?
It's been two weeks minus one day since I posted this and no one other than me has posted back.
As of now, if I want to use my surround sound, I have no choice but to boot into Windows. Isn't that sad?
User avatar
SpawnHappyJake
Level 1
Level 1
 
Posts: 36
Joined: Mon Apr 25, 2011 1:15 am

Sort of Solved

Postby SpawnHappyJake on Wed Jul 13, 2011 5:39 pm

I'm here to report a miracle! I re-installed Linux Mint 11 64-bit yesterday, and today I turned up the volume (no one else was home but me and my deaf dog - I'm her hearing human.), and the surround sound kicked in!
There are still some bugs that need to be fixed. One of them is that in sound preferences I have my XtremeAudio sound card on the default profile of "Analog Stereo Duplex", yet it is pumping out 5.1 surround (maybe not "true" 5.1 surround, the rear speakers seem to simply be duplicating the front left and right speakers, but there is sound coming out of all 5 speakers and the subwoofer).
When I switch the profile to 5.1, sound comes out of all speakers, but just barely out of the front left and front right. It's easy to tell that the rear left and rear right are making sound. I held the front left and front right up to my ears and thought the sound I was hearing was coming from the nearby center speaker until I moved and pointed the center speaker off to the left and unpluged the left front speaker and held the left front speaker up to my left ear and the right front speaker up to my right ear. Compared to the silence in my left ear, I could tell sound was going to the front right. I rigged the experiment that way so that I would know that any sound coming from the left (other than rear) was coming from the center and not the front left. I can't simply unplug the center because no speakers will produce sound unless the center is plugged in.
And I can't do the normal sound test where you click the speaker you want to send sound to because that is not working. When I am using the 5.1 profile, I have the six test buttons to click, but none of them send sound to the speakers or subwoofer, yet playing a song does. When I use the "Analog Stereo Duplex" profile, I have two test buttons to click, and neither of those work either, yet sound is sent to all 5 speakers and the subwoofer when playing a song in that profile as well.
When I am using the "Analog Stereo Duplex" profile, it is easy to tell that audio is going to my left and right front speakers, and they are much louder (than they are in the 5.1 profile), but not as loud as the rear. It makes sense to make the rears louder because they are farther away. The front and rear volume ratio seems as it should from the soundpoint of where I am sitting.

There seems to be a volume "cutoff" level where it decides to cut sound to certain speakers (or maybe make them so quite I can't notice them when I put my ear up to them). When I went over this cutoff for the first time, (in the default "Analog Stereo Duplex" profile), I could notice the sound coming out of each speaker. Before I was only getting sound from the front. Now when I reduce the sound below the cutoff while in this profile, instead of cutting off the rear and only using the front speakers (maybe the center, can't remember) like before, it cuts sound to the front right and front left and keeps sound to the rear right and rear left and also has sound going to the center, creating a sort of 3.1 surround.

Of course in the 5.1 profile, left front and right front are so faint it seems like the same "3.1 surround" again.

In Windows, I have it in 5.1 mode. The tester works where I can click a speaker or the sub and get sound, for all of them. Unless I have the EAX turned on (or whichever one it is that lets you pick theater, royal hall, orchestra pit, jazz club, etc for the acoustic) a song does not send audio to the rear.

Hope this helps someone and that this gets fixed.

Cheers,
Jake
User avatar
SpawnHappyJake
Level 1
Level 1
 
Posts: 36
Joined: Mon Apr 25, 2011 1:15 am

Re: No Surround Sound In LM11:XtremeAudio

Postby mads on Fri Aug 19, 2011 4:38 pm

Hi! Other people having the same issue, check this post.
User avatar
mads
Level 6
Level 6
 
Posts: 1309
Joined: Wed Nov 03, 2010 3:44 pm

Re: No Surround Sound In LM11:XtremeAudio

Postby SpawnHappyJake on Mon Aug 22, 2011 3:15 am

Thank you Mads for your concern. I replied over where you linked me to: http://forums.linuxmint.com/viewtopic.php?f=141&t=79606&p=463794#p463794

I already had the surround sound working, but the "test speaker" buttons in Sound Preferences with the smiley face don't work (when 5.1 mode is selected). After doing the linked-to solution, that is still the case. Though the surround sound worked from the get-go this time (after selecting 5.1), rather than having to "activate" it by increasing the volume way high.
And I am all too familiar with the crackling noise (brought up by Hawkwind). I'll see if that is reduced or eliminated by this. It seems worst when the system volume is very low. I can have the system volume way high, and the volume of the end program that I am playing the media file with down, and it's not as bad. But when it's there I can't totally get rid of it. Right now I don't have it. Maybe this fixed that.
Thanks again...a lot.

Cheers,
Jake
User avatar
SpawnHappyJake
Level 1
Level 1
 
Posts: 36
Joined: Mon Apr 25, 2011 1:15 am

3.1 Strikes Again

Postby SpawnHappyJake on Mon Aug 22, 2011 1:26 pm

Still not there yet.
To be more specific, I had surround working by using the Analog Stero Duplex profile. That doesn't make sense, I know, but that's how it was. Sound was coming out of all 5 speakers and the sub. Using the 5.1 profile, front left and front right sound was missing, creating a "3.1 surround sound". Now after I have done this fix, I just realized that no profile will pump sound out of all speakers, and I always have "3.1 surround sound".
So this thread remains unsolved. I'm looking for two main things: 1) getting audible sound out of all 5 speakers, and for the sub to move air, and 2) have the operating system/sound programs not be confused, i.e, the profile should be the 5.1 profile, and get 5.1 output, all the test buttons should work when in that profile, etc.

Cheers,
Jake
User avatar
SpawnHappyJake
Level 1
Level 1
 
Posts: 36
Joined: Mon Apr 25, 2011 1:15 am

Re: No Surround Sound In LM11:XtremeAudio

Postby Polaczek on Fri Sep 16, 2011 12:57 am

I can sympathize with you if you want 5.1 working. Especially it you had before!

Here's what I did (assuming you are using ALSA)

Test if it is possible to get all the channels, open a terminal window.

Code: Select all
speaker-test -Dplug:surround51 -c6


You should hear white noise in all the speakers. If you can hear white noise then this means that you don't have a mode that uses all the speakers at the same time. I did some googling and learned of upmixing. Essentially, what I understand, is that they send the sound to each device: hw0,0 (which is front left and right), hw0,1 (center and low frequency), hw0,2 (rear left and right).

Make a file asound.conf in /etc (so /etc/asound.conf)

and put all this goodness in there...

Code: Select all
# Expand stereo to all channels including LFE
pcm.20to51 {
  type route
  slave.pcm surround51
  slave.channels 6
  ttable.0.0 1
  ttable.1.1 1
  ttable.0.2 1
  ttable.1.3 1
  ttable.0.4 0.33
  ttable.1.4 0.33
  ttable.1.5 0.33
  ttable.0.5 0.33
}

# Create the SoftMaster mixer device that controls *all* channels
pcm.!default {
    type             softvol
    slave.pcm       "20to51"
    control {
        name "SoftMaster"
        card 0
    }
}


Reboot your machine and in your audio player use the default pcm mode and you should have happy times!
Polaczek
Level 1
Level 1
 
Posts: 1
Joined: Thu Sep 15, 2011 10:59 pm

Re: No Surround Sound In LM11:XtremeAudio

Postby SpawnHappyJake on Fri Sep 16, 2011 2:43 am

Thank you very much for the love, Polaczek. But I have no /etc/asound.conf file, and when I try the terminal entry you suggested, I get this:
speaker-test 1.0.24.2

Playback device is plug:surround51
Stream parameters are 48000Hz, S16_LE, 6 channels
Using 16 octaves of pink noise
Playback open error: -2,No such file or directory


And of course, no sound from speakers.

I think it is upmixing now. I just want Linux to properly support my sound card. Or at least handle the sound stuff it says it can do properly and consistently.

Cheers,
Jake
User avatar
SpawnHappyJake
Level 1
Level 1
 
Posts: 36
Joined: Mon Apr 25, 2011 1:15 am

Re: No Surround Sound In LM11:XtremeAudio

Postby SpawnHappyJake on Fri Sep 16, 2011 2:52 am

I noticed that Synaptic has ALSA driver source code, but no ALSA driver (compiled). Am I expected to compile the driver from source?
Jake
User avatar
SpawnHappyJake
Level 1
Level 1
 
Posts: 36
Joined: Mon Apr 25, 2011 1:15 am

Re: No Surround Sound In LM11:XtremeAudio

Postby guruwannabe on Sat Dec 10, 2011 2:59 am

Polaczek wrote:I can sympathize with you if you want 5.1 working. Especially it you had before!

Here's what I did (assuming you are using ALSA)

Test if it is possible to get all the channels, open a terminal window.

Code: Select all
speaker-test -Dplug:surround51 -c6


You should hear white noise in all the speakers. If you can hear white noise then this means that you don't have a mode that uses all the speakers at the same time. I did some googling and learned of upmixing. Essentially, what I understand, is that they send the sound to each device: hw0,0 (which is front left and right), hw0,1 (center and low frequency), hw0,2 (rear left and right).

Make a file asound.conf in /etc (so /etc/asound.conf)

and put all this goodness in there...

Code: Select all
# Expand stereo to all channels including LFE
pcm.20to51 {
  type route
  slave.pcm surround51
  slave.channels 6
  ttable.0.0 1
  ttable.1.1 1
  ttable.0.2 1
  ttable.1.3 1
  ttable.0.4 0.33
  ttable.1.4 0.33
  ttable.1.5 0.33
  ttable.0.5 0.33
}

# Create the SoftMaster mixer device that controls *all* channels
pcm.!default {
    type             softvol
    slave.pcm       "20to51"
    control {
        name "SoftMaster"
        card 0
    }
}


Reboot your machine and in your audio player use the default pcm mode and you should have happy times!


Hi Polaczek,
Thanks for your post. It helps tremendously.
I am here to document my experience with your guide and hope that it help others who google here later.
I am using Linux Mint 11, 64bit edition.
General Note: Please ensure physical connections are proper: mine was loose and didn't have any sound on the Front Right. Yes, Front Left working but Front Right no sound. So make sure connection are all properly connected.
I ran the test twice: Once before creating /etc/asound.conf and again after creating /etc/asound.conf and restarting the system. Tips: I put his command into a bash script - test51.sh; easier in the future. The test will run continuously until pressing [Ctrl+C] to cancel.
Code: Select all
#!/bin/bash

speaker-test -Dplug:surround51 -c6

First Run experience:
Code: Select all
$ sh ./test51.sh

I heard a 'pssssr' sound in Front Left (FL), nothing in centre (Ctr), nothing in Front Right (FR), nothing in Rear Right (RR), nothing in Rear Left(RL), 'pssssr' in Subwoofer (LFE).
note: I started to check and fix the physical connection while the test goes into the loop cycles.
note: use [Ctrl+C] to break out of the loop.
Result of First Run: FL, FR and LFE working (2.1) that is.
Then I created the /etc/asound.conf as describled and Restarted the System.

Second Run experience:
-- 1st loop: FL, FR and LFE (still 2.1)
note: I ran the 'Sound Preferences' to do some 'tweaking' to [Output] of 'Balance', 'Fade' & 'Subwoofer' as the command loops thru several cycles. I finally tweaked my settings to:
Centre for left-right Balance
Centre for rear-front Fade
Centre for min-max Subwoofer
Important Note: I needed to perform the above 'Bal', 'Fade' & 'Subwoofer' 'tweaking' by running the speaker-test command a few times before all the 5.1 speakers work.

Conclusion: The command works. In retrospect, I might not need to create the '/etc/asound.conf' file.
Thanks again, Polaczek.
Bob
guruwannabe
Level 1
Level 1
 
Posts: 14
Joined: Fri Jul 08, 2011 10:57 pm

Re: 3.1 Strikes Again

Postby guruwannabe on Sat Dec 10, 2011 1:17 pm

SpawnHappyJake wrote:Still not there yet.
To be more specific, I had surround working by using the Analog Stero Duplex profile. That doesn't make sense, I know, but that's how it was. Sound was coming out of all 5 speakers and the sub. Using the 5.1 profile, front left and front right sound was missing, creating a "3.1 surround sound". Now after I have done this fix, I just realized that no profile will pump sound out of all speakers, and I always have "3.1 surround sound".
So this thread remains unsolved. I'm looking for two main things: 1) getting audible sound out of all 5 speakers, and for the sub to move air, and 2) have the operating system/sound programs not be confused, i.e, the profile should be the 5.1 profile, and get 5.1 output, all the test buttons should work when in that profile, etc.

Cheers,
Jake


Hi,
My experience is kinda similar: I hear audio from the same speaker no matter which button I click.
I was playing around with some other liveCD a little - Dream Studio base on Ubuntu 11.04 - just to try out other Audio/Video software. Well, for the first time, I hear the right sound from the correct speaker with different loudness and location accordingly. Another observation is that the 'speaker' icon lighted up too.
In LM11, my 5.1 is working in A/V playback and the 'speaker-test' command as I posted earlier.
Regards,
Bob
guruwannabe
Level 1
Level 1
 
Posts: 14
Joined: Fri Jul 08, 2011 10:57 pm

Re: No Surround Sound In LM11:XtremeAudio

Postby pepe333 on Mon Dec 09, 2013 4:59 pm

this was the way I got 5.1 sound
http://www.youtube.com/watch?v=eeOuseUqe9Y
pepe333
Level 1
Level 1
 
Posts: 2
Joined: Mon Dec 09, 2013 4:38 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: fotonix and 18 guests