USB Stick not shown

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

USB Stick not shown

Postby bigphredo on Sat Dec 22, 2007 10:42 pm

I have USB memory stick and when I plug it in nothing happens, it works in windows on the same PC plus I'm pretty sure it worked before. The stick light comes on but now it does not show up on my desktop or in my mounted media. Is there anything I can try to get this to work?
bigphredo
Level 1
Level 1
 
Posts: 25
Joined: Mon Nov 19, 2007 5:50 pm

Linux Mint is funded by ads and donations.
 

Re: USB Stick not shown

Postby Husse on Sun Dec 23, 2007 9:47 am

Have you done anything (on the stick/in Mint) to "prepare it"
And you should have a line like this in /etc/fstab

none /proc/bus/usb usbfs auto,devmode=0666 0 0
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: USB Stick not shown

Postby bigphredo on Sun Dec 23, 2007 12:14 pm

I don't have "none /proc/bus/usb usbfs auto,devmode=0666 0 0" anywhre in that fie. Should I copy and paste it in. This what I have

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/hdd1
UUID=88a9e880-e984-4c53-b9d9-dee80bc23cb7 / ext3 defaults,errors=remount-ro 0 1
# /dev/hdd5
UUID=7fc67f09-e5c4-4c8d-b652-83c4aba9b5e7 none swap sw 0 0
/dev/hdb /media/cdrom0 udf,iso9660 user,noauto,exec 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec 0 0
bigphredo
Level 1
Level 1
 
Posts: 25
Joined: Mon Nov 19, 2007 5:50 pm

Re: USB Stick not shown

Postby Husse on Sun Dec 23, 2007 1:11 pm

The line
none /proc/bus/usb usbfs auto,devmode=0666 0 0
is necessary for a USB stick I think
Put it directly below the other line with proc in it (you need sudo for that)
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: USB Stick not shown

Postby cmost on Sun Dec 23, 2007 2:27 pm

I had this but after upgrading from Celena to Daryna. Have you tried this?
Unplug the misbehaving USB key (might be an MP3 player too.)
Type Alt+F2
Type gconf-editor; press enter.

In Gconf-editor, navigate to...
/system/storage/default_options/vfat
double-click the key listed in the right-hand pane and then remove the word "usefree" from the bottom of the list.
Close gconf-editor

Plug back in your USB key and see if it now automounts.

Good luck! :-)
cmost
Level 4
Level 4
 
Posts: 398
Joined: Tue Sep 18, 2007 7:36 am
Location: Newport, Kentucky


Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 18 guests