No headphones.

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

No headphones.

Postby LinuxNS on Sat Jan 07, 2012 1:45 pm

Hello,

I have installed Lisa on my laptop to gain some more experience with Linux (so I'm fairly new). The only problem I can't seem to overcome is that the headphone jack won't work. The laptop speakers work fine. In fact the onboard speakers correctly mute when headphones are plugged in, but there is simply no sound in the headphones.

This seems to be a fairly common problem but this seems to have a bit of twist that I haven't seen too many forum posts addressing... The alsamixer doesn't show a channel for the headphone jack. Under the Output tab of Sound Settings the only device listed is "Internal Audio Analog Stereo" and under the "Connector" field it just has "Analog Speaker" with no other option. I've gone around in circles with this one and even added "options snd-hda-intel model=thinkpad" to alsa-base.conf just to be safe, but no luck. I know the headphones are good and I know the stereo jack is good as it works fine with WinXP (not dual boot, XP is on a separate HDD).

Here are the particulars:

Lenovo Thinkpad R61
AlsaMixer v1.0.24.2
Card: HDA Intel
Chip: Conexant CX20549 (Venice)

Any ideas of where to go next with troubleshooting this?

Tks.
LinuxNS
Level 1
Level 1
 
Posts: 2
Joined: Sat Jan 07, 2012 1:22 pm

Linux Mint is funded by ads and donations.
 

Re: No headphones.

Postby z06gal on Sat Jan 07, 2012 2:00 pm

I have the same issue but the headphones work for me when I open volume control settings > output > change it back to speakers. The only issue is every time you plug your headphones in, you'll have to do this. The other option is what I chose to do because I hate pulseaudio:


http://ptspts.blogspot.com/2010/11/how- ... buntu.html


You will lose your volume applet but I use my gnome alsamixer for volume settings or you can add a volume control to your dock [cairo dock in my case] :wink:
z06gal
Level 5
Level 5
 
Posts: 668
Joined: Sat Jun 13, 2009 7:16 pm

Re: No headphones.

Postby mankapo on Sun Jan 08, 2012 3:05 pm

Hello LinuxNS,

I've got an identical setup here and also went more than one cyle,
-purging pulseaudio
-adding several options to alsa-base.conf
...
Here the solution was adding "options snd-hda-intel model=generic" to alsa-base.conf and reinstalling pulseaudio.
If you haven't purged pulseaudio until now, I guess adding the specified line will do it

Found this on:
https://bugs.launchpad.net/ubuntu/+sour ... bug/876020
mankapo
Level 1
Level 1
 
Posts: 4
Joined: Sun Jan 08, 2012 2:54 pm

[SOLVED]Re: No headphones.

Postby LinuxNS on Sun Jan 08, 2012 7:19 pm

z06gal/makapo - Thanks very much for the help. Adding "options snd-hda-intel model=generic" did the trick.
LinuxNS
Level 1
Level 1
 
Posts: 2
Joined: Sat Jan 07, 2012 1:22 pm


Return to Hardware Support

Who is online

Users browsing this forum: johnfound and 22 guests