[SOLVED]: No HDMI Sound Output - Mint 12 64-bit on Zotac Mag

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read this

[SOLVED]: No HDMI Sound Output - Mint 12 64-bit on Zotac Mag

Postby Steve Redmond on Thu Feb 02, 2012 12:37 pm

Zotac Mag HD-ND01 has Nvidia ION GPU. Specs are here: http://www.zotac.com/pdbrochures/mini-pc/ZOTAC-%20MAG_v1.pdf . It is Linux friendly, see here: http://www.linuxuser.co.uk/reviews/zotac-mag-hd-nd01-nettop-review/. I have successfully run Ubuntu 10.10 32-bit version, including HDMI sound output to my TV/monitor.

I have a new, up to date, Linux Mint 12 64-bit installation. I have installed the Nvidia proprietary driver(s). I have unmuted the HDMI ouput in alsamixer. I have tried system sound settings to Digital Stereo (HDMI) Output, without success. I can get 'normal' Analog Stereo Output through the earphone/speaker jack.

Please Help:
** How can I get HDMI sound output?
** How can I check for proper configuration to get HDMI sound output?
** Is there potentially enough difference between my previous 32-bit Ubuntu and new Mint 12 64-bit installations to have broken the HDMI sound output? Would Linux Mint 12 32-bit version be any different?

Here are my aplay outputs:
Code: Select all
steve@zotac ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC888 Analog [ALC888 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC888 Digital [ALC888 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
steve@zotac ~ $ aplay -L
null
    Discard all samples (playback) or generate zero samples (capture)
pulse
    Playback/recording through the PulseAudio sound server
front:CARD=NVidia,DEV=0
    HDA NVidia, ALC888 Analog
    Front speakers
surround40:CARD=NVidia,DEV=0
    HDA NVidia, ALC888 Analog
    4.0 Surround output to Front and Rear speakers
surround41:CARD=NVidia,DEV=0
    HDA NVidia, ALC888 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=NVidia,DEV=0
    HDA NVidia, ALC888 Analog
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=NVidia,DEV=0
    HDA NVidia, ALC888 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=NVidia,DEV=0
    HDA NVidia, ALC888 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=NVidia,DEV=0
    HDA NVidia, ALC888 Digital
    IEC958 (S/PDIF) Digital Audio Output
hdmi:CARD=NVidia,DEV=0
    HDA NVidia, HDMI 0
    HDMI Audio Output
dmix:CARD=NVidia,DEV=0
    HDA NVidia, ALC888 Analog
    Direct sample mixing device
dmix:CARD=NVidia,DEV=1
    HDA NVidia, ALC888 Digital
    Direct sample mixing device
dmix:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample mixing device
dsnoop:CARD=NVidia,DEV=0
    HDA NVidia, ALC888 Analog
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=1
    HDA NVidia, ALC888 Digital
    Direct sample snooping device
dsnoop:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct sample snooping device
hw:CARD=NVidia,DEV=0
    HDA NVidia, ALC888 Analog
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=1
    HDA NVidia, ALC888 Digital
    Direct hardware device without any conversions
hw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Direct hardware device without any conversions
plughw:CARD=NVidia,DEV=0
    HDA NVidia, ALC888 Analog
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=1
    HDA NVidia, ALC888 Digital
    Hardware device with all software conversions
plughw:CARD=NVidia,DEV=3
    HDA NVidia, HDMI 0
    Hardware device with all software conversions
steve@zotac ~ $


On advice from others, http://crunchbanglinux.org/forums/topic/2310/hdmi-ati-hda-sound-how-i-got-hdmi-sound-working-in/, I have tried adding this configuration file, /etc/asound.conf , and restarted the system, with no effect.
Code: Select all
pcm. !default {
type hw
card 0
device 3
}


I am pretty much exhausted over this. It's far from plug and play. I left Ubuntu because we are not in unity over the HMI. I thought Mint would help me get over that, but this niggling HDMI sound problem can break my interest. http://en.wikipedia.org/wiki/For_Want_of_a_Nail_%28proverb%29. My appreciation for a solution. Help help help!

RSVP

Steve
Last edited by Steve Redmond on Sun Feb 05, 2012 1:55 am, edited 1 time in total.
Steve Redmond
Level 1
Level 1
 
Posts: 8
Joined: Thu Feb 02, 2012 10:54 am

Linux Mint is funded by ads and donations.
 

Re: No HDMI Sound Output - Mint 12 64-bit on Zotac Mag HD-ND

Postby ibe63 on Thu Feb 02, 2012 2:30 pm

This is maybe stupid question but just to make sure that you have connected your HDMI cable straightly from PC-card HDMI connector to monitor/tv HDMI connector without any adapters like DVI/HDMI or something. Those adapters doesn't support HDMI sound as far as i know .
ibe63
Level 1
Level 1
 
Posts: 21
Joined: Sun Jan 30, 2011 7:52 am

Re: No HDMI Sound Output - Mint 12 64-bit on Zotac Mag HD-ND

Postby Steve Redmond on Fri Feb 03, 2012 1:17 pm

No, there are no interposing converters or adapters between the computer and TV/monitor. It's just a simple HDMI cable, and it has worked before with Ubuntu 10.10, including sound, connected in exactly the same way. Further, I can verify that the HDMI video at least is AOK, since I have been running the Linux Mint through it. I think it is most probably a Linux sound setup or Nvidia driver problem, and nothing external to the computer.

Thanks for asking.
Steve Redmond
Level 1
Level 1
 
Posts: 8
Joined: Thu Feb 02, 2012 10:54 am

Re: No HDMI Sound Output - Mint 12 64-bit on Zotac Mag HD-ND

Postby Steve Redmond on Fri Feb 03, 2012 9:25 pm

Additional Information wrt 64-bit vs 32-bit:

I ran a Live DVD of Linux Mint 12 32-bit. I made no updates and installed no drivers or anything that wasn't part of the DVD distro.

I had the same problem; no HDMI sound output. I checked alsamixer to be sure the master was enabled. I tested for sound out using the system Sound Settings (accessed through speaker widget).

I think I will go back and try Ubuntu 10.10, to re-establish my baseline - hope it still works!

(Edit 120204) I tried Ubuntu 10.10 32-bit, from my original distro disk. I had exactly the same appearance and problems 'out of the box' as I am having now with Linux Mint 12. From this I assume that it is neither Mint 64-bit nor 32-bit that are the root of my problem. Instead I believe it is more generally to do with Linux (period). There are 100's of equally distressed users of various distros looking for an answer on how to get HDMI output, switch between HDMI and built-in analog, etc.

Unfortunately I did not record how I got the HDMI sound working in the first place with the Ubuntu 10.10 distro, so I am now at square zero again. I am combing the plethora of problem-advice threads, to find something that will work for me. I'll appreciate any help I can get from this forum, and bring back the news if I find a solution.
Steve Redmond
Level 1
Level 1
 
Posts: 8
Joined: Thu Feb 02, 2012 10:54 am

Re: No HDMI Sound Output - Mint 12 64-bit on Zotac Mag HD-ND

Postby Steve Redmond on Sun Feb 05, 2012 1:44 am

:D :D :D OK, I think I have this solved :D :D :D

After much browsing and sifting, I came to rest on this tutorial, at Linux Mint no less: http://community.linuxmint.com/tutorial/view/628. The man deserves kudos for this - thanks.

It took me a while to make the association between S/PDIF and HDMI sound output. Sorry, but I know less about HDMI and S/PDIF than I do about Linux, which to be not too self-deprecating, is a tenth of not much.

Here is what I did to get HDMI sound output on my TV/Monitor:
Code: Select all
1. Make sure the System Sound Preferences Hardware Profile is set to one of the analog sound options, e.g., Analog Stereo Duplex
2. open Terminal and run "alsamixer".  Unmute all the S/PDIF outputs, e.g., I had S/PDIF, S/PDIF Def and S/PDIF 1, and had to unmute two of them.  That left Master, PCM, and all S/PDIF's unmuted. Hit Esc to exit alsamixer.
3. Still in Terminal, run "gstreamer-properties".  in the window titled Multimedia Systems Selector, set the Default Output Plugin: to Alsa - Advanced Linux Sound Architecture.  Try Pipeline Test to be sure you get HDMI/TV sound output. Close that window.
4.Go back to System Sound Preferences Hardware Profile and select one of the HDMI output options, e.g., Digital Stereo (HDMI) Output + Analog Stereo Input.  Test Speakers to make sure you get left and right sound through the TV/Monitor.
5. That's it.  Close up.  Enjoy HDMI sound.

P.S1. I did go back and clean out the etc/asound.conf that I had previously tried.  I found there was no diffedrence/problem when it was gone.

P.S2. I did find that having gone through this procedure once, I could go back to gstream-properties and set the Audio Default Output Plugin back to Autodetect.  However, after I restarted the system, the resulting sound was weak, so I have fixed it at Alsa - ... for now.

P.S3. I did check that now you can change the sound output destination by simply going to the System Sound Preferences Hardware Profile.  There is no need to return to gstream-properties and alsamixer to make a change or keep this working.  So some aspect of this procedure is 'one-time' only.

P.S4. I don't pretend to know and understand all that goes on in the system to setup sound output.  If anyone wants to add to this to clarify, feel free.


I have seen much more complicated solutions than above. Some solutions intended to go beyond simply getting HDMI to work 'permanently' instead of the analog speakers. One thread tries a complex script to detect plugging/inplugging an HDMI cable and switching the sound output back and forth automatically on the fly. That's really smart, but beyond my simple need, and current understanding. Some users are seeking more than just stereo sound, e.g., 5.1 or 7.1. I have no solution for that, as I only see/need stereo sound output options and I don't think the Zoitac can do 5.1 sound.

Anyway, I think this is resolved, and for now Linux Mint 12 is all Green to Go.

Thanks for reading. I hope it helps some other struggling, freshly Minted user.

Steve
Steve Redmond
Level 1
Level 1
 
Posts: 8
Joined: Thu Feb 02, 2012 10:54 am

Re: [SOLVED]: No HDMI Sound Output - Mint 12 64-bit on Zotac

Postby mrjane on Mon Feb 06, 2012 4:11 pm

How did you unmute all the S/PDIF outputs?

Mine just have 00 (zero zero) and I cant increase the volume.

Thanks
mrjane
Level 1
Level 1
 
Posts: 2
Joined: Mon Feb 06, 2012 4:08 pm

Re: [SOLVED]: No HDMI Sound Output - Mint 12 64-bit on Zotac

Postby Steve Redmond on Mon Feb 06, 2012 5:29 pm

I assume you can see the "00" in alsamixer. That is "un-muted", while "MM" is muted.

That is all I did, set the flags in alsamixer, from "MM" to "00". I didn't need/try to adjust levels there. I don't think you can, except for Master, PCM and MIC (at least in my case). I think the point here is to patch the digital sound output(S/PDIF), to go somewhere, rather than adjust volume. That is my tiny understanding, but there may be more to it, from a guru.

I did all my volume control through the Speaker widget (top right of the screen), after setting the sound output in System Sound Settings to HDMI. There is also a Gnome Alsa Mixer (GUI), where you can do some muting/un-muting and set volumes. That is preferable to me, e.g., to turn on the microphone, set levels.

I hope that helps.
Steve
Steve Redmond
Level 1
Level 1
 
Posts: 8
Joined: Thu Feb 02, 2012 10:54 am

Re: [SOLVED]: No HDMI Sound Output - Mint 12 64-bit on Zotac

Postby mrjane on Mon Feb 06, 2012 6:10 pm

Thanks for the reply Steve, I'll try and poke around to see if I can get it to work :)

Regards
mrjane
Level 1
Level 1
 
Posts: 2
Joined: Mon Feb 06, 2012 4:08 pm

Re: [SOLVED]: No HDMI Sound Output - Mint 12 64-bit on Zotac

Postby FearTheNoFear on Tue Feb 07, 2012 11:27 pm

Every time I enter the System Sound Preferences Hardware Profile after trying to change it to Analog Stereo Duplex, it's already back at the HDMI sound option. Not sure what to think of that.
FearTheNoFear
Level 1
Level 1
 
Posts: 4
Joined: Mon Sep 12, 2011 5:59 pm
Location: Round Lake, IL

Re: [SOLVED]: No HDMI Sound Output - Mint 12 64-bit on Zotac

Postby Steve Redmond on Wed Feb 08, 2012 1:03 am

Sorry, I can't help you on that behaviour. I am able to change System Sound Settings back and forth between analog and digital outputs, and the settings stick until I change them again.
Steve Redmond
Level 1
Level 1
 
Posts: 8
Joined: Thu Feb 02, 2012 10:54 am

Re: [SOLVED]: No HDMI Sound Output - Mint 12 64-bit on Zotac

Postby FearTheNoFear on Wed Feb 08, 2012 1:09 am

Yeah, I just realized that I needed to install the propietary drivers which now has the sound going through my HDMI. I just upgraded from 11 to 12 yesterday hence why I somehow forgot to get the additional drivers. No more problem for me then.
FearTheNoFear
Level 1
Level 1
 
Posts: 4
Joined: Mon Sep 12, 2011 5:59 pm
Location: Round Lake, IL

Re: [SOLVED]: No HDMI Sound Output - Mint 12 64-bit on Zotac

Postby ael on Tue Jul 17, 2012 4:14 pm

no more audio on laptop speaker after follow this steps! I reset at autodetect but no audio anymore :(

how can i do without music :|

Someone can help me?
ael
Level 1
Level 1
 
Posts: 6
Joined: Thu Apr 19, 2012 4:21 pm

Re: [SOLVED]: No HDMI Sound Output - Mint 12 64-bit on Zotac

Postby Hades[PT] on Tue Feb 19, 2013 8:39 pm

Damn! I was having the same problem! Thx for the help! (noob here xD)

Cheers
Hades[PT]
Level 1
Level 1
 
Posts: 1
Joined: Tue Feb 19, 2013 8:35 pm

Linux Mint is funded by ads and donations.
 

Return to Hardware Support

Who is online

Users browsing this forum: No registered users and 14 guests