Problems with OBD2 interface

Questions about hardware,drivers and peripherals
Forum rules
Before you post please read how to get help

Problems with OBD2 interface

Postby Bartul on Fri Mar 30, 2012 5:44 am

Hi!

I have car diagnostic device ELM327 with usb port connection, but Mint can't recognize it.
Here is the list of devices from terminal:

~ $ lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 09da:000e A4 Tech Co., Ltd
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 7073:3037
Bus 003 Device 002: ID 046d:c215 Logitech, Inc. Extreme 3D Pro
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

That device is listed as "Bus 003 Device 003" and, as you can see, has no description.

Any suggestions?

Thanks!
Bartul
Level 1
Level 1
 
Posts: 2
Joined: Fri Mar 30, 2012 4:57 am

Linux Mint is funded by ads and donations.
 

Re: Problems with OBD2 interface

Postby AlbertP on Fri Mar 30, 2012 7:51 am

That it has no description just means that nobody has submitted the name of the device on https://usb-ids.gowdy.us/ yet. You don't need a proper description for the device to work, you need a driver instead. Drivers don't look for descriptions, but use 7073:3037 codes or the like instead.
I found a Polish forum thread about it, which I translated with Google Translate. It says FTDI, manufacturer of the device, has a Linux driver to be able to use this interface as a serial port.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6522
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Problems with OBD2 interface

Postby Bartul on Sun Apr 01, 2012 8:20 am

Thanks for your help,

I installed ftdi driver as you said, but the device did not work so I searched the internet and found this command:

modprobe ftdi_sio vendor=0x7073 product=0x3037


Now the device is working properly. :D
Here is link that might help someone with same problem: http://ftdi-usb-sio.sourceforge.net/
Bartul
Level 1
Level 1
 
Posts: 2
Joined: Fri Mar 30, 2012 4:57 am


Return to Hardware Support

Who is online

Users browsing this forum: rameshiit19 and 12 guests