<SOLVED>How to keep USB HDD from auto-mounting a partition?

Forum rules
Before you post please read this

<SOLVED>How to keep USB HDD from auto-mounting a partition?

Postby hibba on Mon Dec 02, 2013 4:56 am

Hi all,

I notice that when I log into my user account, the system tries to auto-mount some of the partitions of the USB hard drive. One of the partitions is the one that I use for backups, and I'd prefer not to have it mounted more often than I needed it to, for security. Also, I'd rather not have it listed in /etc/fstab (which could keep it from being auto-mounted, but also means it will get mounted if someone manages to run 'mount -a' on my system).

Could someone give me a few directions on how to disable auto-mounting for this partition, please?

Thanks,

Hibba


EDIT: Found what I needed: https://help.ubuntu.com/community/Mount/USB

If anyone else has the same issue, just run "sudo apt-get install dconf-tools" in a terminal without the quotes, and then follow the Configuring Automounting section of the above guide.
hibba
Level 1
Level 1
 
Posts: 4
Joined: Mon Dec 02, 2013 4:45 am

Linux Mint is funded by ads and donations.
 

Re: <SOLVED>How to keep USB HDD from auto-mounting a partiti

Postby mdavies5 on Thu Aug 28, 2014 1:58 am

If you are using the Nemo File Explorer just go to Preferences/Behaviour/Media Handling and uncheck the Automount checkbox. Other File Managers may well have the same functionality.
Cheers, Mike
User avatar
mdavies5
Level 3
Level 3
 
Posts: 114
Joined: Sat Aug 11, 2012 1:02 am


Return to Mounting Partitions

Who is online

Users browsing this forum: No registered users and 1 guest