[Solved]Error Mounting HDD

Forum rules
Before you post please read this

[Solved]Error Mounting HDD

Postby owweeee on Wed Nov 28, 2012 5:58 pm

I've inserted a new HDD into my computer and now I am getting this error on one of the partitions on one of my other drives.

Error mounting: mount exited with exit code 1: helper failed with:
mount: wrong fs type, bad option, bad superblock on /dev/sdc2,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Doing "dmesg | tail" reported the following

[ 23.958126] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 23.958129] Bluetooth: BNEP filters: protocol multicast
[ 24.009144] Bluetooth: RFCOMM TTY layer initialized
[ 24.009151] Bluetooth: RFCOMM socket layer initialized
[ 24.009153] Bluetooth: RFCOMM ver 1.11
[ 24.110873] forcedeth 0000:00:0a.0: irq 43 for MSI/MSI-X
[ 35.104027] eth0: no IPv6 routers present
[ 56.689259] EXT3-fs (sdc2): error: couldn't mount because of unsupported optional features (240)
[ 212.043386] EXT3-fs (sdc2): error: couldn't mount because of unsupported optional features (240)
[ 455.511175] EXT3-fs (sdc2): error: couldn't mount because of unsupported optional features (240)

Doing "sudo fsck -f /dev/sdc2" reported the following

fsck from util-linux 2.20.1
e2fsck 1.42 (29-Nov-2011)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
also: 4714/42049536 files (12.1% non-contiguous), 159671551/168168420 blocks

If anybody has any ideas I would be grateful.

Isn't it the way that you figure out what is going wrong after you post for help. Anyway if anybody else come across this problem, this is how I fixed it:
I had accidentally swapped two sata data cables around on two drives and the one partition that was EXT3 rather then EXT4 couldn't handle it and blocked the mounting of the one at its mount point.
Doing "sudo gedit /etc/fstab" and then editing the sd letters (ie sdb1 became sdc1 etc) so they were correct for the drives as shown in the drive utility or Gparted fixed it.
Running Linux Mint 17.1 Rebecca 64bit with Cinnamon
Level 1
Level 1
Posts: 30
Joined: Sat Sep 12, 2009 10:47 pm
Location: Swansea, Wales

Linux Mint is funded by ads and donations.

Return to Mounting Partitions

Who is online

Users browsing this forum: No registered users and 1 guest