fstab root(/) partition errors=remount

Forum rules
Before you post please read this

fstab root(/) partition errors=remount

Postby MarcelSFaas on Tue Apr 16, 2013 9:06 am

Hi there,
I have the following problem.
Since yesterday I found out that my Root partition is running full with unknown data.
Yesterday I already removed a 5.8 Gb log file, but the problem is returning.
I think the problem occured after a hard reboot I had to do after a total freeze of Mint13 Mate
On every boot or reboot there's less diskspace left and according to fstab
the Root partition is read-only:
    marcel@AMD2800 /media $ cat /etc/fstab
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    #Entry for /dev/sda1 :
    UUID=7dd92e0f-251d-4167-8701-1e42653d4f18 / ext4 errors=remount-ro 0 1

    #Entry for /dev/sda5 :
    UUID=127c34c4-1578-438f-b073-703e1271d2fd /home ext4 defaults 02
    #Entry for /dev/sdb5 :
    UUID=1058C61758C5FB8A /media/Backup ntfs-3g defaults,nosuid,nodev,locale=en_US.UTF-8 0 0
    #Entry for /dev/sda4 :
    UUID=4758A78C56BA37BD /media/Data\040PC ntfs-3g defaults,nosuid,nodev,locale=en_US.UTF-8 0 0
    #Entry for /dev/sda3 :
    UUID=216EF14B4E348E49 /media/Data_Marcel ntfs-3g defaults,locale=en_US.UTF-8 0 0
    #Entry for /dev/sda6 :
    UUID=77c38ca4-7b5f-4585-b784-f9b280d692c6 none swap sw 0 0
    /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
Output for mount:
    marcel@AMD2800 /media $ mount
    /dev/sda1 on / type ext4 (rw,errors=remount-ro)
    proc on /proc type proc (rw,noexec,nosuid,nodev)
    sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
    none on /sys/fs/fuse/connections type fusectl (rw)
    none on /sys/kernel/debug type debugfs (rw)
    none on /sys/kernel/security type securityfs (rw)
    udev on /dev type devtmpfs (rw,mode=0755)
    devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
    tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
    none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
    none on /run/shm type tmpfs (rw,nosuid,nodev)
    /dev/sda5 on /home type ext4 (rw)
    /dev/sdb5 on /media/Backup type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
    /dev/sda4 on /media/Data PC type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
    /dev/sda3 on /media/Data_Marcel type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
    binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
    gvfs-fuse-daemon on /home/marcel/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=marcel)
I guess the problem of running out of diskspace has to do with being RO of the Root partition

Already tried all the possible options in Recovery mode, like clean, fsck and
the command "mount -n -o remount,rw /", but I'm out of ideas right now.
Anyone a solution for my problem?

TIA
-----------------
AMD 2800
2 Gb DDR Ram
Mint 13 Mate

Update:

After looking around at the Ubuntu forum  I found out that the 
logfile I deleted yesterday appeared in 
/root/.local/share/Trash/files.
I opened the folder as administrator, but when I try to delete the 
file it appears again after a few seconds.
The name of the file is uvcdynctrl-udev.2.2.2.log, but there is 
more to delete in this folder.
Guess it has to do with  Root(/) being read-only.
MarcelSFaas
Level 1
Level 1
 
Posts: 7
Joined: Thu Mar 31, 2011 3:02 pm

Linux Mint is funded by ads and donations.
 

Re: fstab root(/) partition errors=remount

Postby viking777 on Tue Apr 16, 2013 11:52 am

This is a known bug relating to faulty webcam software, it has nothing to do with read only file systems.

The temporary workround is this:

Code: Select all
sudo killall -9 uvcdynctrl


Which will stop the software from working.

Then delete the log file as you did before.

Then

Code: Select all
sudo pluma /lib/udev/uvcdynctrl


(change pluma to whatever text editor you are actually using)

Then edit this file to read debug=0 instead of debug=1.

Of course this is really only a workround that stops logging the error files it doesn't solve the webcam problem.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: fstab root(/) partition errors=remount

Postby MarcelSFaas on Tue Apr 16, 2013 12:36 pm

Thanks viking777, but it didn't work for me.
There is no process running with the name uvcdynctrl and
the command sudo pluma /lib/udev/uvcdynctrl gives an empty file.
Tried to remove the log file, but it keeps coming back.
I also tried tried to remove files like _usr_bin_transmission-gtk.2.1000.crash,
syslog.2.1 and kern.2.2.2.log.1. They disappear for 2 seconds and
then appear again. Tried to move them to another folder without success
MarcelSFaas
Level 1
Level 1
 
Posts: 7
Joined: Thu Mar 31, 2011 3:02 pm

Re: fstab root(/) partition errors=remount

Postby viking777 on Tue Apr 16, 2013 1:42 pm

You have obviously caused a massive amount of damage to your system somehow, because all these error logs are filling up in seconds after you delete them. If it was just one error like the webcam one you could just live without the logging of those errors, but if you have multiple instances of the same problem I would guess that you system is just about finished and you need to start again by reinstalling. You could disable the syslog deamon which should (I think) stop all error logging until you next boot, but you are just covering up a massive wound with a sticking plaster, it is not going to work for long.

If you want to try it use

Code: Select all
sudo service rsyslog stop


This should enable you to remove the error logs that are filling your root file system and enable you to delete the existing logs. You could even add this command to startup applications so it is permanent, but I really don't recommend it, something is seriously broken and I don't know what it is.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: fstab root(/) partition errors=remount

Postby MarcelSFaas on Tue Apr 16, 2013 2:55 pm

Now way I can delete the log files, because the Root is Read-Only and doesn't allow deleting files.
Every time I delete a file it returns to the same place.
So I try to find a way to make the Root RW again, although I already tried with fsck and mount -n -o remount,rw /.
MarcelSFaas
Level 1
Level 1
 
Posts: 7
Joined: Thu Mar 31, 2011 3:02 pm

Re: fstab root(/) partition errors=remount

Postby altair4 on Tue Apr 16, 2013 3:48 pm

You seem to have 2 problems and I'm not sure if they are related to one another or not. The partition being mounted as read only is by design because of this line in fstab:
UUID=7dd92e0f-251d-4167-8701-1e42653d4f18 / ext4 errors=remount-ro 0 1

It's not the "remount-ro" part as much as it is the "errors" part:
errors={continue|remount-ro|panic}
Define the behaviour when an error is encountered. (Either ignore errors and just mark the filesystem erroneous and continue, or remount the filesystem read-only, or panic and halt the system.) The default is set in the filesystem superblock, and can be changed using tune2fs(8).

If during the boot process the system sees an error in the filesystem it will mount it read only.

Maybe corruption of the filsystem from this happening:
I think the problem occured after a hard reboot I had to do after a total freeze of Mint13 Mate


Not good with hardware issues myself but some folks here are.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 15
Level 15
 
Posts: 5804
Joined: Tue Feb 03, 2009 10:27 am

Re: fstab root(/) partition errors=remount

Postby viking777 on Wed Apr 17, 2013 3:52 am

But you are assuming that your drive is ro. It might be or it might not. Just because fstab says errors=remount-ro doesn't mean that it is ro. My fstab says exactly the same, but it isn't ro. About the only way to see if it is really ro is to try and write to it. Do:

Code: Select all
touch newfile


Then look in your home directory for the file 'newfile'. If it there then your system is rw if it is not, or you get an error message, then it is ro. Even this is not a foolproof answer though because if the disk is full of log files you won't be able to write to it even if it is rw :?

Either way though you must have some serious error to cause all this. The point of errors=remount-ro is basically to make it easier to save your personal files to a safe place before reinstalling and that is what I would suggest.

However if you want to try changing the behaviour use

Code: Select all
sudo tune2fs -e continue


Then reboot and see what happens. It will probably just freeze within minutes and you will then have to use a command line next time you boot to change it back again (sudo tune2fs -e remount-ro). It is up to you if you want to try that.

Another tactic would be to try and error check the partition from something like partition magic or the live cd.

Code: Select all
sudo fsck -f /dev/sdxX


Where x is the drive letter and X is the Mint partition number.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).
Image
User avatar
viking777
Level 14
Level 14
 
Posts: 5153
Joined: Mon Dec 01, 2008 11:21 am

Re: fstab root(/) partition errors=remount

Postby catweazel on Wed Apr 17, 2013 4:02 am

viking777 wrote:But you are assuming that your drive is ro. It might be or it might not. Just because fstab says errors=remount-ro doesn't mean that it is ro. My fstab says exactly the same, but it isn't ro. About the only way to see if it is really ro is to try and write to it.

Just fyi, I was plagued by a read-only root filesystem in a clean install of Mint 14 Cinnamon on a brand new SSD with not a zit or pimple in sight on it.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1063354
It turned out that disabling NCQ fixed it.

Cheers.
Mint Testing Team & Mint Donor #3606
KDE 4.12.0, custom preemptive kernel 3.12.5,
Intel i7 4770K @ 4.7GHz, 16GB 2666MHz XMP,
4 Samsung 840 PRO 512GB SSDs in RAID0,
6TB HW RAID10, dual 24" Acer X243H,
Gigabyte nVidia GTX 680 Super Overclock
User avatar
catweazel
Level 7
Level 7
 
Posts: 1656
Joined: Fri Oct 12, 2012 9:44 pm

[Resolved]Re: fstab root(/) partition errors=remount

Postby MarcelSFaas on Wed Apr 17, 2013 8:21 am

Thanks guys for all the tips.
The solution for deleting the files permanently was easy
Code: Select all
Open in the File Manager the Root partition as Administrator to find out where you have to delete the files
In my case it was in /root/.local/share/Trash

Open a Root Terminal

cd  /root/.local/share/Trash/files

rm -rf <filename> or <foldername>



That's it
After doing this I now have left 7.3 Gb at my Root partition and isn't getting less
MarcelSFaas
Level 1
Level 1
 
Posts: 7
Joined: Thu Mar 31, 2011 3:02 pm

Linux Mint is funded by ads and donations.
 

Return to Mounting Partitions

Who is online

Users browsing this forum: No registered users and 1 guest