Need help mounting ext4 partition from second HDD

Forum rules
Before you post please read this

Need help mounting ext4 partition from second HDD

Postby cuddlypike on Fri May 03, 2013 8:47 pm


I have a separate 3TB harddrive with data that I want to access. It has 4 partitions on it, but I only want access to the 4th one, which is using ext4.

I've connected it to my computer and it seems to detect properly. I see an icon in Computer that shows the name 3.0 TB Hard Disk 3.0 TB Volume. Clicking on this icon results in the following error:

Error mounting /dev/sdb4 at /media/colin/77c9c286-fda8-43ca-9353-671ea3baf1dc: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdb4" "/media/colin/77c9c286-fda8-43ca-9353-671ea3baf1dc"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdb4,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Considering Computer only shows one icon for the 3TB HDD, I would imagine I need to tell the OS to mount the 4th one specifically.

I tried looking at the partitions using:
sudo parted -l

And this is what it returned:

Model: ATA WDC WD30EZRS-11J (scsi)
Disk /dev/sdb: 3001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
3 15.7MB 528MB 513MB primary
1 528MB 2576MB 2048MB ext3 primary raid
2 2576MB 4624MB 2048MB ext3 primary raid
4 4624MB 3001GB 2996GB ext4 primary

Some additional info:

sudo blkid -c dev/null
/dev/sda1: LABEL="Windows XP" UUID="168CEAE58CEABDFD" TYPE="ntfs"
/dev/sda2: UUID="ecfefebc-d338-4162-9fca-7b0815601f0d" TYPE="ext4"
/dev/sda3: UUID="7f5daa69-ba1a-4157-a98b-991f1b1e7cfa" TYPE="swap"
/dev/sda5: LABEL="Stuff" UUID="26E047F4E047C8AF" TYPE="ntfs"
/dev/sdb1: UUID="6c290884-f600-51eb-5842-a427fb1e5a14" TYPE="linux_raid_member"
/dev/sdb2: UUID="6c290884-f600-51eb-5842-a427fb1e5a14" TYPE="linux_raid_member"
/dev/sdb4: UUID="77c9c286-fda8-43ca-9353-671ea3baf1dc" TYPE="ext4"
/dev/sdc1: LABEL="Windows 8" UUID="DA082F40082F1AD1" TYPE="ntfs"

cat /etc/fstab

# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sdb2 during installation
UUID=ecfefebc-d338-4162-9fca-7b0815601f0d / ext4 errors=remount-ro 0 1
# swap was on /dev/sdb3 during installation
UUID=7f5daa69-ba1a-4157-a98b-991f1b1e7cfa none swap sw 0 0


/dev/sda2 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
gvfsd-fuse on /run/user/colin/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=colin)
/dev/sdc1 on /media/colin/Windows 8 type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)

I tried adding the following line to the fstab file:
UUID=77c9c286-fda8-43ca-9353-671ea3baf1dc /mnt/sdb4 ext4 defaults,noatime 0 2

However, I got the same error when attempting to mount all. (mount -a)

How would I go about accessing this data?
I'm rather new to this, so any and all help you could give me would be greatly appreciated.

Level 1
Level 1
Posts: 1
Joined: Fri May 03, 2013 7:39 pm

Linux Mint is funded by ads and donations.

Return to Mounting Partitions

Who is online

Users browsing this forum: No registered users and 1 guest