[Solved] Shared NTFS drive automounts with different UUID ..

Forum rules
Before you post please read this

[Solved] Shared NTFS drive automounts with different UUID ..

Postby ItDontMeanAThing on Fri Jun 21, 2013 11:50 am

My laptop dual boots Mint 14 Mate 32 bit and Win 7 Home Premium 32 bit. Everything works OK. I've been using them as seperate machines, creating files with a Win only app, then copying them to a shared 10gb NTFS partion for reading from Mint.

Now I want to share files, both OSs reading and writing to the same 100gb NTFS partion. I created the partion when installing Win but haven't used it until now. There are test files on the partition now. Both OSs read and write ok, until I rebooted.

The shared partion automounts when I boot Mint. I can't recall if I did anything to make that happen. But everytime I boot into Mint the UUID is different. That breaks the sharing and the path in the Mint backup software. I think I need to mount the shared 100gb drive in fstab to get a consistent UUID. Correct?

Hopefully useful stuff:
$ sudo blkid
/dev/sda1: LABEL="System Reserved" UUID="FE74175274170D51" TYPE="ntfs"
/dev/sda2: UUID="3A681B85681B3ED7" TYPE="ntfs"
/dev/sda5: UUID="7a4d2f14-53e5-4dd8-a571-b33ffbe41130" TYPE="ext3"
/dev/sda6: UUID="17dcdc2d-3106-4377-b589-5a06f67f7892" TYPE="swap"
/dev/sda7: UUID="4E2E0D14358332E1" TYPE="ntfs"
/dev/sda8: UUID="bb85dd97-a1ef-4751-b78a-2539ba3524e4" TYPE="ext3"
/dev/sdb1: LABEL="My Passport" UUID="B4D48115D480DB4E" TYPE="ntfs"

sda2 is the shared 100gb drive.


$ cat fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda5 during installation
UUID=7a4d2f14-53e5-4dd8-a571-b33ffbe41130 / ext3 errors=remount-ro 0 1
# /home was on /dev/sda8 during installation
UUID=bb85dd97-a1ef-4751-b78a-2539ba3524e4 /home ext3 defaults 0 2
# swap was on /dev/sda6 during installation
UUID=17dcdc2d-3106-4377-b589-5a06f67f7892 none swap sw 0 0
Last edited by ItDontMeanAThing on Mon Jun 24, 2013 12:44 am, edited 2 times in total.
ItDontMeanAThing
Level 1
Level 1
 
Posts: 15
Joined: Sun Sep 12, 2010 5:46 am

Linux Mint is funded by ads and donations.
 

Re: Shared NTFS drive automounts with different UUID each ti

Postby grimdestripador on Fri Jun 21, 2013 12:44 pm

give it a label. and mount it though the label name.

Code: Select all
sudo tune2fs /dev/sda -L YourDriveLabel


Code: Select all
sudo mount /dev/disk/by-label/YourDriveLabel


Of course, if you have a /etc/fstab entry, you should change those to use the /dev/disk/by-label/YourDriveLabel
User avatar
grimdestripador
Level 6
Level 6
 
Posts: 1069
Joined: Fri Feb 16, 2007 2:26 am

Re: Shared NTFS drive automounts with different UUID each ti

Postby altair4 on Fri Jun 21, 2013 1:24 pm

** I don't see how it's possible for the UUID to change each time it boots since that's built into the partition itself and won't change unless you reformat it.

** According to fstab you are not automount this partition since there is nothing in fstab referencing any ntfs partition.

** You might want to check your Startup Applications ( Menu > Preferences > Startup Applications ) to see if you're automounting it that way. The next time you reboot immediately run the following command t see if it's actually mounted:
Code: Select all
mount


To have it automount in fsab I would suggest something like the following especially since you are sharing this with Windows:

[1] Create a permenent mount point:
Code: Select all
sudo mkdir /media/Shared

[2] Then add to the end of fstab:
Code: Select all
UUID=3A681B85681B3ED7 /media/Shared ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.
altair4
Level 16
Level 16
 
Posts: 6214
Joined: Tue Feb 03, 2009 10:27 am

Re: Shared NTFS drive automounts with different UUID each ti

Postby grimdestripador on Sat Jun 22, 2013 12:44 am

Its quite possible. For example I have an old MSI motherboard which has the VIA south bridge with fakeRAID and also a an actual Promise chipset running Raid, also with aditional SATA ports. According to the motherboard, not all of my sata ports are active if i'm using some of the pata ports. I had this very issue of UUIDs changing frequently. The UUID is not just a number that originated from the harddrive. It is a calculation of randomness depending on the harddrive, and its particular chipset. This is touted as a feature, because if you swap HDs around between chipsets, they will only mount (when using the UUID from last boot) when in a similar configuration.

When you mount a drive by its label, the correct harddrive will mount independtly of where its physically connected. There is even a trick to actually reference your linux kernel during boot with its by-label association; fixing many peoples problems when the drives re-arranged their order when booting from USB. (some motherboards call the USB device /dev/sda, which is of course not what most installers expect.
User avatar
grimdestripador
Level 6
Level 6
 
Posts: 1069
Joined: Fri Feb 16, 2007 2:26 am

Re: Shared NTFS drive automounts with different UUID each ti

Postby ItDontMeanAThing on Mon Jun 24, 2013 12:42 am

Mea culpa (Latin for 'my mistake'). I know better than to post when both frustrated and tired.
- The drive doesn't automount. It appears in the file manager (Caja) side pane without the mounted symbol. I was mounting it in Caja.
- When I mount the drive by first clicking on it in Caja, everything works as it should.
- I can't reproduce the changing UUID, ergo it wasn't changing.

The following worked perfectly. Thank you.

altair4 wrote:** You might want to check your Startup Applications ( Menu > Preferences > Startup Applications ) to see if you're automounting it that way. The next time you reboot immediately run the following command t see if it's actually mounted:
Code: Select all
mount


To have it automount in fsab I would suggest something like the following especially since you are sharing this with Windows:

[1] Create a permenent mount point:
Code: Select all
sudo mkdir /media/Shared

[2] Then add to the end of fstab:
Code: Select all
UUID=3A681B85681B3ED7 /media/Shared ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0
ItDontMeanAThing
Level 1
Level 1
 
Posts: 15
Joined: Sun Sep 12, 2010 5:46 am


Return to Mounting Partitions

Who is online

Users browsing this forum: No registered users and 3 guests