Unable to print HP PHOTOSMART D110A

Forum rules
Before you post please read this

Unable to print HP PHOTOSMART D110A

Postby felipesenger on Wed May 22, 2013 2:14 am

Hi,

I recently installed MATE 64 of mint, but the only thing i'm having problem, is my hp photosmart d110A. The scanner works fine, but doesnt print.

Syslog says that when i try print.
May 22 01:51:25 felipe-pc hp-check: hp-check[3502]: warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro 1 version
May 22 01:51:42 felipe-pc hp-check: io/hpmud/jd.c 806: mdns lookup HP66C201.local retry 1...
May 22 01:51:46 felipe-pc hp-check: hp-check[3502]: error: 'ghostscript' package is missing/incompatible
May 22 02:03:59 felipe-pc hpcups[3771]: prnt/hpcups/HPCupsFilter.cpp 559: cupsRasterOpen failed, fd = 0
May 22 02:03:59 felipe-pc hp[3772]: prnt/backend/hp.c 839: ERROR: null print job total=0


http://localhost:631 says
Photosmart_D110 WIFI WIFI HP Photosmart d110 Series, hpcups 3.13.5 Idle - "/usr/lib/cups/filter/hpcups failed"

hp-check says

Saving output in log file: /home/felipe/hp-check.log

HP Linux Imaging and Printing System (ver. 3.13.5)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are
installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the
proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).

Check types:
a. EXTERNALDEP - External Dependencies
b. GENERALDEP - General Dependencies (required both at compile and run time)
c. COMPILEDEP - Compile time Dependencies
d. [All are run-time checks]
PYEXT SCANCONF QUEUES PERMISSION

Status Types:
OK
MISSING - Missing Dependency or Permission or Plug-in
INCOMPAT - Incompatible dependency-version or Plugin-version

warning: linuxmint-1 version is not supported. Using linuxmint-14 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

Kernel: 3.2.0-4-amd64 #1 SMP Debian 3.2.32-1 GNU/Linux
Host: felipe-pc
Proc: 3.2.0-4-amd64 #1 SMP Debian 3.2.32-1 GNU/Linux
Distribution: linuxmint 1
Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.13.5
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro 1 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf. Generated from hplip.conf.in by configure.

[hplip]
version=3.13.5

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.13.5
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.13.5
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=no
hpijs-only-build=no
lite-build=no
udev-acl-rules=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no


Current contents of '/var/lib/hp/hplip.state' file:
[plugin]
installed = 1
eula = 1
version = 3.12.6



Current contents of '~/.hplip/hplip.conf' file:
[installation]
date_time = 22-05-2013 01:51:25
version = 3.13.5

[last_used]
device_uri = "hp:/net/Photosmart_D110_series?zc=HP66C201"
printer_name = Photosmart_D110
working_dir = .

[settings]
systray_visible = 0
systray_messages = 0

[commands]
scan = /usr/bin/simple-scan %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

[upgrade]
notify_upgrade = false
last_upgraded_time = 1369188204.51447
pending_upgrade_time = 0
latest_available_version = 3.13.5


<Package-name> <Package-Desc> <Required/Optional> <Min-Version> <Installed-Version> <Status> <Comment>

--------------------------
| External Dependencies |
--------------------------

error: gs Ghostscript REQUIRED 7.05 - MISSING 'gs needs to be installed'
network Network-wget OPTIONAL - 1.13.4 OK -
dbus DBus REQUIRED - 1.6.8 OK -
scanimage Shell-Scanning OPTIONAL 1.0 1.0.22 OK -
policykit Admin-Policy-framework OPTIONAL - 0.105 OK -
xsane SANE-GUI OPTIONAL 0.9 0.998 OK -
cups CUPS REQUIRED 1.1 1.5.3 OK 'CUPS Scheduler is running'

-------------------------
| General Dependencies |
-------------------------

reportlab Python-PDF-Lib OPTIONAL 2.0 2.5 OK -
libcrypto OpenSSL-Crypto-Lib REQUIRED - 1.0.1 OK -
pil Python-Image-Lib OPTIONAL - 1.1.7 OK -
pyqt4-dbus PyQt4-DBUS REQUIRED 4.0 4.9.3 OK -
libjpeg JPEG-Lib REQUIRED - - OK -
libpthread POSIX-Threads-Lib REQUIRED - 2.13 OK -
python-dbus Python-DBUS REQUIRED 0.80.0 1.1.1 OK -
python-devel Python-SDK REQUIRED 2.2 2.7.3 OK -
pyqt4 Python-Qt4 REQUIRED 4.0 4.9.3 OK -
cups-devel CUPS-SDK REQUIRED - 1.5.3 OK -
sane-devel SANE-SDK REQUIRED - 1.0.22 OK -
libusb USB-Lib REQUIRED - 1.0 OK -
sane Scan-Lib REQUIRED - 1.0.22 OK -
cups-image CUPS-Image-Lib REQUIRED - 1.5.3 OK -
libnetsnmp-devel SNMP-Networking-SDK REQUIRED 5.0.9 5.4.3 OK -
python-xml Python-XML-Lib REQUIRED - 2.1.0 OK -
python-notify Desktop-notifications OPTIONAL - - OK -

------------------------------
| Compile Time Dependencies |
------------------------------

gcc gcc-Compiler REQUIRED - 4.7.2 OK -
libtool Build-tools REQUIRED - 2.4.2 OK -
make GNU-Build-tools REQUIRED 3.0 3.81 OK -

----------------------
| Python Extentions |
----------------------

cupsext CUPS-Extension REQUIRED - 3.13.5 OK -
pcardext PhotoCard-Extension REQUIRED - 3.13.5 OK -
hpmudext IO-Extension REQUIRED - 3.13.5 OK -

-----------------------
| Scan Configuration |
-----------------------

hpaio HPLIP-SANE-Backend REQUIRED - 3.13.5 OK 'hpaio found in /etc/sane.d/dll.conf'
scanext Scan-SANE-Extension REQUIRED - 3.13.5 OK -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/net/Photosmart_D110_series?zc=HP66C201' is a Hewlett-Packard Photosmart_D110_series all-in-one
device `v4l:/dev/video0' is a Noname Video WebCam virtual device


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------


Photosmart_D110
---------------
Type: Printer
Device URI: hp:/net/Photosmart_D110_series?zc=HP66C201
PPD: /etc/cups/ppd/Photosmart_D110.ppd
PPD Description: HP Photosmart d110 Series, hpcups 3.13.5
Printer status: printer Photosmart_D110 is idle. enabled since Ter 21 Mai 2013 22:02:52 BOT
Communication status: Good


--------------
| PERMISSION |
--------------

groups user-groups Required - - OK felipe adm lp dialout cdrom floppy sudo audio dip video plugdev lpadmin sambashare


-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'ghostscript' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
None


Total Errors: 1
Total Warnings: 0

Re-run 'hp-doctor' command to prompt and fix the issues.

Alredy run the hp-doctor, but doesnt fix the issues.
Try installing a new version of the hplip, samething.
Try install the ghostscript, but it is already installed.

Anyone?
felipesenger
Level 1
Level 1
 
Posts: 2
Joined: Wed May 22, 2013 1:52 am

Linux Mint is funded by ads and donations.
 

Re: Unable to print HP PHOTOSMART D110A

Postby felipesenger on Thu May 23, 2013 1:49 am

Solved the problem 'printer-resolution' has value '(unknown IPP tag):
Update with python-cups_1.9.61_amd64.deb
And the error message of ghostscript with
ln -s /usr/lib/libgs.so.8 /usr/lib/libgs.so.9

The test communication works, and the printer works. but a simple test page doesnt work and I have this message
May 23 01:37:26 felipe-pc hp[6418]: prnt/backend/hp.c 839: ERROR: null print job total=0
May 23 01:38:39 felipe-pc hp[6433]: prnt/backend/hp.c 839: ERROR: null print job total=0

sorry about the bad english.

Anyone?
felipesenger
Level 1
Level 1
 
Posts: 2
Joined: Wed May 22, 2013 1:52 am

you seem to be missing Ghostscript; for your HP D110A

Postby pdc_2 on Sat May 25, 2013 6:04 pm

the error I can see

error: gs Ghostscript REQUIRED 7.05 - MISSING 'gs needs to be installed'


and I see it says it at the end

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'ghostscript' package is missing/incompatible


I assume the usual command

sudo apt-get install ghostscript


may do the trick
pdc_2
Level 6
Level 6
 
Posts: 1211
Joined: Mon May 11, 2009 1:21 am


Return to Printers & Scanners

Who is online

Users browsing this forum: ES44AC8102 and 3 guests