HP Officejet 8000 Pro on Mint 14: No Options Available

Forum rules
Before you post please read this

HP Officejet 8000 Pro on Mint 14: No Options Available

Postby mungo59 on Wed Jan 16, 2013 1:08 pm

Hi all,

I am new to Mint, though not new to Linux, as I used Ubuntu for years.

After installing Mint 14 Cinnamon (64 bit) on an AMD machine, all does well, except my printer: There is HPLIP installed, but the GUI is not ready to provide any options, e.g. double-sided printing.
In fact the HPLIP Toolbox is missing at all (I know how it is supposed to look, as I had it under Ubuntu).

Thank you for any hints.
--
Confidence is what you feel just before you fully understand the problem.
mungo59
Level 1
Level 1
 
Posts: 6
Joined: Sun Dec 23, 2012 8:11 am

Linux Mint is funded by ads and donations.
 

Re: HP Officejet 8000 Pro on Mint 14: No Options Available

Postby pdc_2 on Wed Jan 16, 2013 2:59 pm

here is the Ubuntu how-to for HP

https://help.ubuntu.com/community/HpAllInOne

a magic command seems to be

sudo hp-setup


......... then the waters of the sea seem to part after that........
pdc_2
Level 5
Level 5
 
Posts: 844
Joined: Mon May 11, 2009 1:21 am

Re: HP Officejet 8000 Pro on Mint 14: No Options Available

Postby mungo59 on Wed Jan 16, 2013 3:52 pm

Nope.
I do not want to add a new printer - the one available is exactly the device I need.
And it appears that there is no duplexer recognized though it used to work under Ubuntu 12.10.

As for now, in HPLIP 3.12.11 (Device Manager 15.0 (Qt4)) under "Print Settings"/"Installable Options" there is a "Duplexer Installed" section, but it is greyed out. So, no wonder how comes that LibreOffice cannot print double-sided.

Any chance to get that running under Mint 14?
--
Confidence is what you feel just before you fully understand the problem.
mungo59
Level 1
Level 1
 
Posts: 6
Joined: Sun Dec 23, 2012 8:11 am

Re: HP Officejet 8000 Pro on Mint 14: No Options Available

Postby mungo59 on Sat Jan 19, 2013 4:02 am

Update:
I can print PDFs double-sided from Evince.

There is no such option in LibreOffice.

Still there is the Duplexer-option greyed out and set to "Off" in the Print Settings of the Device Manager in HPLIP.
In the Device Information/Status Data under #64 I find a key named duplexer set to "1".
So far I have not found, what that means and how to chance it eventually.

I ran hp-check -t and got
Code: Select all
HP Linux Imaging and Printing System (ver. 3.12.11)
Dependency/Version Check Utility ver. 15

Copyright (c) 2001-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                   
2. Run-time check mode (-r or --run): Use this mode to determine if a distro   
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                     
3. Both compile- and run-time check mode (-b or --both) (Default): This mode   
will check both of the above cases (both compile- and run-time dependencies).   

Check types:                                                                   
a. EXTERNALDEP - External Dependencies                                         
b. GENERALDEP - General Dependencies (required both at compile and run time)   
c. COMPILEDEP - Compile time Dependencies                                       
d. [All are run-time checks]                                                   
PYEXT SCANCONF QUEUES PERMISSION                                               

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

Saving output in log file: /home/jockel/hp-check.log

Initializing. Please wait...
warning: linuxmint-14 version is not supported. Using linuxmint-13 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 GNU/Linux
 Host: tiggr
 Proc: 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 GNU/Linux
 Distribution: linuxmint 14

-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.12.11
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro  14 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.12.11

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.12.11
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=no
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.12.11
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=no
hpijs-only-build=no
lite-build=no
udev-acl-rules=yes
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[upgrade]
notify_upgrade = true
last_upgraded_time = 1358363098
pending_upgrade_time = 0
latest_available_version = 3.12.11

[settings]
systray_visible = 0
systray_messages = 2

[last_used]
device_uri = "hp:/usb/Officejet_Pro_8000_A809?serial=CN0242Q028"
printer_name =
working_dir = .

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

[installation]
date_time = 19.01.2013 08:46:03
version = 3.12.11


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

--------------------------
|  External Dependencies |
--------------------------

 gs                   Ghostscript               REQUIRED        7.05            9.06            OK         -
 network              Network-wget              OPTIONAL        -               1.13.4          OK         -
 dbus                 DBus                      REQUIRED        -               1.6.4           OK         -
 scanimage            Shell-Scanning            OPTIONAL        1.0             1.0.23          OK         -
 policykit            Admin-Policy-framework    OPTIONAL        -               0.104           OK         -
 xsane                SANE-GUI                  OPTIONAL        0.9             0.998           OK         -
 cups                 CUPS                      REQUIRED        1.1             1.6.1           OK         'CUPS Scheduler is running'

-------------------------
|  General Dependencies |
-------------------------

 reportlab            Python-PDF-Lib            OPTIONAL        2.0             2.5             OK         -
 libcrypto            OpenSSL-Crypto-Lib        REQUIRED        -               1.0.1           OK         -
 pil                  Python-Image-Lib          OPTIONAL        -               1.1.7           OK         -
 pyqt4-dbus           PyQt4-DBUS                REQUIRED        4.0             4.9.3           OK         -
 libjpeg              JPEG-Lib                  REQUIRED        -               -               OK         -
 libpthread           POSIX-Threads-Lib         REQUIRED        -               2.15            OK         -
 python-dbus          Python-DBUS               REQUIRED        0.80.0          1.1.1           OK         -
 python-devel         Python-SDK                REQUIRED        2.2             2.7.3           OK         -
 pyqt4                Python-Qt4                REQUIRED        4.0             4.9.3           OK         -
 cups-devel           CUPS-SDK                  REQUIRED        -               1.6.1           OK         -
 sane-devel           SANE-SDK                  REQUIRED        -               1.0.23          OK         -
 libusb               USB-Lib                   REQUIRED        -               1.0             OK         -
 sane                 Scan-Lib                  REQUIRED        -               1.0.23          OK         -
 cups-image           CUPS-Image-Lib            REQUIRED        -               1.6.1           OK         -
 libnetsnmp-devel     SNMP-Networking-SDK       REQUIRED        5.0.9           5.4.3           OK         -
 python-xml           Python-XML-Lib            REQUIRED        -               2.1.0           OK         -
 python-notify        Desktop-notifications     OPTIONAL        -               -               OK         -

------------------------------
|  Compile Time Dependencies |
------------------------------

 gcc                  gcc-Compiler              REQUIRED        -               4.7.2           OK         -
 libtool              Build-tools               REQUIRED        -               2.4.2           OK         -
 make                 GNU-Build-tools           REQUIRED        3.0             3.81            OK         -

----------------------
|  Python Extentions |
----------------------

 cupsext              CUPS-Extension            REQUIRED        -               3.12.11         OK         -
 pcardext             PhotoCard-Extension       REQUIRED        -               3.12.11         OK         -
 hpmudext             IO-Extension              REQUIRED        -               3.12.11         OK         -

-----------------------
|  Scan Configuration |
-----------------------

 hpaio                HPLIP-SANE-Backend        REQUIRED        -               3.12.11         OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension       REQUIRED        -               3.12.11         OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                        Model                     
  --------------------------------  --------------------------
  hp:/usb/Officejet_Pro_8000_A809?  HP Officejet Pro 8000 A809
  serial=CN0242Q028                                           

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
Officejet_Pro_8000_A809
-----------------------
Type: Printer
Device URI: hp:/usb/Officejet_Pro_8000_A809?serial=CN0242Q028
PPD: /etc/cups/ppd/Officejet_Pro_8000_A809.ppd
PPD Description: HP Officejet Pro 8000 a809, hpcups 3.12.6
Printer status: printer Officejet_Pro_8000_A809 is idle.  enabled since Sa 19 Jan 2013 0ready to print
Communication status: Good


--------------
| PERMISSION |
--------------

groups          user-groups                    Required        -        -        OK       jockel adm lp cdrom sudo dip plugdev lpadmin sambashare

USB             Officejet_Pro_8000_A809        Required        -        -        OK       Node:'/dev/bus/usb/002/003' Perm:'  root  lp rw- rw- rw- rw- r--'

-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
None


Total Errors: 0
Total Warnings: 0

No errors or warnings.

Done.

To me it seems that because Mint 14 is not supported, some information may not have come through to HPLIP, as in fact there *is* a scanner and as well the duplexer is physically installed (and surprisingly working with Evince).

I might only need to tell LibreOffice...
--
Confidence is what you feel just before you fully understand the problem.
mungo59
Level 1
Level 1
 
Posts: 6
Joined: Sun Dec 23, 2012 8:11 am


Return to Printers & Scanners

Who is online

Users browsing this forum: No registered users and 4 guests