SOLVED - Can't get ink levels on Canon MP270

Forum rules
Before you post please read this

SOLVED - Can't get ink levels on Canon MP270

Postby iain_j on Tue Apr 23, 2013 4:47 pm

I've got Mint 14 KDE on my laptop, and have just installed Canon's drivers for my Pixma MP270 printer/scanner. I've not tried the scanner yet, but the printer is fine - it prints OK, the cngpij command brings up Canon's page setup / maintenance options dialog, and all the maintenance tools (nozzle check, head cleaning, etc) work fine... all except for the printer status monitor and the ink levels.

The driver user guide says to run the command cngpijmonmp270 (snappy name eh) followed by the printer name, and this will open up a window showing the printer status (in their example it reads "Paper out! Load paper. Press the printers start button"), and underneath, two icons, one for the colour ink level, and one for the black ink.

On mine though, the status shows "Ready" regardless of what's going on (I forced an error by printing from LibreOffice with no paper in, but it still shows "Ready"), and there's nothing where the ink level icons should be. I've tried running sudo cngpijmonmp270 but it makes no difference. The only error I get through the terminal is "Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated" which I don't think is relevant.

The ink command doesn't report the ink level either:

Code: Select all
iain@iain-G70 ~ $ sudo ink -d /dev/usb/lp1
ink 0.5.1 (c) 2010 Markus Heinz

Canon MP270 series

Black:                          0%
Color:                          0%


I'm very certain the ink cartridges are more than 0% full :?

I've tried Epson's mtink utility after reading it also works on Canon printers, but that just opens showing empty cartridges, and it freezes up too.

Any suggestions?
Last edited by iain_j on Thu Apr 25, 2013 3:00 am, edited 2 times in total.
Linux Mint 14 KDE (32 bit) -- HP G70 Laptop
Intel Pentium Dual Core T3400 @ 2.16GHz -- 3Gb DDR2 RAM -- 250Gb HDD
Intel Mobile 4 Series graphics -- Intel 82801I audio
Atheros AR242x/AR542x wireless network adapter
iain_j
Level 2
Level 2
 
Posts: 81
Joined: Wed Jul 04, 2012 9:22 am

Linux Mint is funded by ads and donations.
 

Re: Can't get ink levels on Canon MP270

Postby pdc_2 on Wed Apr 24, 2013 3:35 am

I need to have a read and find where Canon store all the advice

for my MG3100 aniother command I had was

cngpij -P MG3100


so I guess the equivalent for you might be

cngpij -P MP270
.......does that help?

___________________________

curiously the mon command you quote does not give any icons for ink for my MG3100
_____________________________

I found ink gave reasonable readings............I guessed....................

Turboprint can give such levels accurately

http://www.turboprint.info/

......go on .......install it .....you know you deserve it ...........

__________________________________________________________________

actually I did have the guide set up to open from Firefox: it seems Canon didn't intend the cngpij command to monitor ink levels
pdc_2
Level 6
Level 6
 
Posts: 1132
Joined: Mon May 11, 2009 1:21 am

Re: Can't get ink levels on Canon MP270

Postby iain_j on Wed Apr 24, 2013 4:12 am

The cngpij -P MP270 command is what I use to open the config & maintenance dialog, but as you say, it doesn't show ink levels and wasn't intended to.

It's odd that cngpijmon___ command doesn't show your ink levels either, when Canon's own user guide shows a screenshot with them. I've heard of turboprint, and will give the free trial a go, but considering everything else on the printer is working I'd rather not pay €30 just to check my ink :?

I found I couldn't run ink without running it as sudo; is that normal or could there be something up with my permissions, stopping it from reading the levels?
Linux Mint 14 KDE (32 bit) -- HP G70 Laptop
Intel Pentium Dual Core T3400 @ 2.16GHz -- 3Gb DDR2 RAM -- 250Gb HDD
Intel Mobile 4 Series graphics -- Intel 82801I audio
Atheros AR242x/AR542x wireless network adapter
iain_j
Level 2
Level 2
 
Posts: 81
Joined: Wed Jul 04, 2012 9:22 am

Re: Can't get ink levels on Canon MP270

Postby iain_j on Wed Apr 24, 2013 4:27 am

I think what I'll do tonight is uninstall Canon's drivers and install the open source ones (gutenprint) and see if the ink command works that way.

I'd rather use Canon's though for the extra config & maintenance options.
Linux Mint 14 KDE (32 bit) -- HP G70 Laptop
Intel Pentium Dual Core T3400 @ 2.16GHz -- 3Gb DDR2 RAM -- 250Gb HDD
Intel Mobile 4 Series graphics -- Intel 82801I audio
Atheros AR242x/AR542x wireless network adapter
iain_j
Level 2
Level 2
 
Posts: 81
Joined: Wed Jul 04, 2012 9:22 am

Re: Can't get ink levels on Canon MP270

Postby iain_j on Wed Apr 24, 2013 4:44 pm

Update...

Tonight I removed the Canon drivers, and reinstalled the printer using the gutenprint driver (v5.2.9) that's listed in the Add New Printer dialog. I had trouble getting it working: I clicked Maintenance > Test page; nothing happened. So I went to localhost:631 and found the printer was paused. So I unpaused it from there, and requested another test page, and was this time told the printer wasn't accepting jobs. I went looking through the settings, selected the port again (the same one I had in the first place...) and voila, I got my test page.

With the gutenprint driver set up, the ink command returned 0% on both cartridges again.

So I uninstalled the printer again, downloaded turboprint and set it up. Same result: 0% ink on all four colours :evil: it is however giving me the right printer status which Canon's monitor didn't.

I'm stumped. It's obviously a well-supported printer, gutenprint and turboprint both support it, and Canon provide their own driver, but it's just not playing ball.
Linux Mint 14 KDE (32 bit) -- HP G70 Laptop
Intel Pentium Dual Core T3400 @ 2.16GHz -- 3Gb DDR2 RAM -- 250Gb HDD
Intel Mobile 4 Series graphics -- Intel 82801I audio
Atheros AR242x/AR542x wireless network adapter
iain_j
Level 2
Level 2
 
Posts: 81
Joined: Wed Jul 04, 2012 9:22 am

Re: Can't get ink levels on Canon MP270

Postby iain_j on Wed Apr 24, 2013 5:13 pm

:idea: :idea: Haaaaaang on a minute! :idea: :idea:

It's just occurred to me - the black cartridge is a Jet Tec compatible one, not authentic Canon. A quick google search reveals a few people have the same issue, on the standard Windows drivers, when they're using compatible / refilled cartridges. The colour cartridge is still the original Canon one, but maybe the compatible throws the ink monitor altogether.

I'm going to mark this as solved... for now. Sorry to have wasted your time, I'll go and put my dunce hat on :wink:
Linux Mint 14 KDE (32 bit) -- HP G70 Laptop
Intel Pentium Dual Core T3400 @ 2.16GHz -- 3Gb DDR2 RAM -- 250Gb HDD
Intel Mobile 4 Series graphics -- Intel 82801I audio
Atheros AR242x/AR542x wireless network adapter
iain_j
Level 2
Level 2
 
Posts: 81
Joined: Wed Jul 04, 2012 9:22 am

Re: SOLVED (maybe) - Can't get ink levels on Canon MP270

Postby pdc_2 on Wed Apr 24, 2013 7:35 pm

thanks; these are all useful things to talk out and sort out; your willingness and confidence to try different drivers is valuable; and your ability to troubleshoot and solve

enjoy your printer and enjoy Mint!
pdc_2
Level 6
Level 6
 
Posts: 1132
Joined: Mon May 11, 2009 1:21 am

Re: SOLVED (maybe) - Can't get ink levels on Canon MP270

Postby iain_j on Thu Apr 25, 2013 2:59 am

As an aside, I was playing in the terminal later on, and out of interest I entered:

Code: Select all
cat /dev/usb/lp1


Don't know why I did it; I was only expecting binary data to come back. To my surprise though, the printer started returning a status report in XML format, over and over again every few seconds, until I stopped it with ctrl-c.

Apart from odd words like "idle" most of it was meaningless acronyms. However, two stood out: BLK:000,CLR:000 (or something like that - this is from memory). To my untrained brain that looks like ink levels, both saying zero. From the horses' mouth so to speak.

I'll deduce from this that all the drivers I tried are fine, they're just reporting what the printer's telling them. The problem lies in the printer, not Linux.
Linux Mint 14 KDE (32 bit) -- HP G70 Laptop
Intel Pentium Dual Core T3400 @ 2.16GHz -- 3Gb DDR2 RAM -- 250Gb HDD
Intel Mobile 4 Series graphics -- Intel 82801I audio
Atheros AR242x/AR542x wireless network adapter
iain_j
Level 2
Level 2
 
Posts: 81
Joined: Wed Jul 04, 2012 9:22 am

Re: SOLVED - Can't get ink levels on Canon MP270

Postby pdc_2 on Thu Apr 25, 2013 3:27 pm

interesting you entered lp1 as most folks only have one printer and it would be lp0; we have two printers hooked up and I have to turn them on in the correct sequence; ie what I want to be lp0 as the first! I need to make the time to set up a udev rule as here

http://hintshop.ludvig.co.nz/show/persi ... l-devices/
pdc_2
Level 6
Level 6
 
Posts: 1132
Joined: Mon May 11, 2009 1:21 am

Re: SOLVED - Can't get ink levels on Canon MP270

Postby iain_j on Fri Apr 26, 2013 10:42 am

Yeah, I thought that was odd too, at first i thought it was because I was installing printer drivers on top of each other and confusing the system, but after installing them properly and starting again, it's still on lp1. Trying lp0 just returns device not found.
Linux Mint 14 KDE (32 bit) -- HP G70 Laptop
Intel Pentium Dual Core T3400 @ 2.16GHz -- 3Gb DDR2 RAM -- 250Gb HDD
Intel Mobile 4 Series graphics -- Intel 82801I audio
Atheros AR242x/AR542x wireless network adapter
iain_j
Level 2
Level 2
 
Posts: 81
Joined: Wed Jul 04, 2012 9:22 am

Linux Mint is funded by ads and donations.
 

Return to Printers & Scanners

Who is online

Users browsing this forum: No registered users and 2 guests