EPSON NX430 printing colors out of phase

Forum rules
Before you post please read this

EPSON NX430 printing colors out of phase

Postby bxd20 on Wed Apr 24, 2013 8:41 am

I used to run LM 13 and the built in driver for my Epson NX430 printed just fine over WiFi.

I wiped and installed LM 14 and although black printing (text) is crisp, colors are all out of phase. You can see the individual inks separately because they aren't laid on top of each other to create the final intended color. Each color is printed on a different spot on the paper. Also the printing is very slow, the test page takes 2 min to finish.

I confirmed with a WiFi Windows laptop and a Windows desktop that the printer is fine.

I also went to the Epson web site and downloaded the latest "full featured" Linux driver and installed the DEB package, but it doesn't seem to have made any difference. I also don't see any "features" when I look at the Printer properties. Maybe I didn't do everything necessary to actually update the driver? Is it possible to install the software package but not update the driver? I am new to Linux.

Thanks!!
bxd20
Level 1
Level 1
 
Posts: 2
Joined: Wed Apr 24, 2013 8:34 am

Linux Mint is funded by ads and donations.
 

Re: EPSON NX430 printing colors out of phase

Postby bxd20 on Thu Apr 25, 2013 10:58 am

I noticed that in some places it calls my printer a NX420 but in the main view under Printers it does see it as NX430 correctly. Perhaps the head alignment is slightly different between the two models causing each color head to not line up.

Should installing a driver from the Epson site simply be a matter of installing the DEB package? Or is there a step to assign that driver to the hardware, like in Windows where you'd go under Device Manager and point it to a new driver file.
bxd20
Level 1
Level 1
 
Posts: 2
Joined: Wed Apr 24, 2013 8:34 am


Return to Printers & Scanners

Who is online

Users browsing this forum: No registered users and 6 guests