Centrino-N 1000 frequent disconnects

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Centrino-N 1000 frequent disconnects

Postby tyraen on Tue Mar 12, 2013 8:29 pm

Hi there,

Just installed Mint 14 KDE edition 64-bit on my Lenovo T510. inxi tells me the wireless is a Centrino-N 1000. I have no problems seeing networks, but it seems that as soon as I start sending traffic to an authenticated WPA2 AP I get two "Michael MIC Failure Detected" messages, and am disconnected.

I've done some searching and haven't been able to find anyone with the exact same problem, though there do seem to be lots of wireless issues. Any suggestions?

Thanks.
tyraen
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 12, 2013 8:25 pm

Linux Mint is funded by ads and donations.
 

Re: Centrino-N 1000 frequent disconnects

Postby tyraen on Tue Mar 12, 2013 9:07 pm

Whoops. Sorry for not reading things, here's the output of mintWifi and some relevant syslog entries as well:

Code: Select all
wlan0     IEEE 802.11bgn  ESSID:********* 
          Mode:Managed  Frequency:2.452 GHz  Access Point: *********************   
          Bit Rate=18 Mb/s   Tx-Power=14 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=55/70  Signal level=-55 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:75   Missed beacon:0

eth0      Link encap:Ethernet  HWaddr *******************
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Memory:f2400000-f2420000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1245 (1.2 KB)  TX bytes:1245 (1.2 KB)

wlan0     Link encap:Ethernet  HWaddr **********************
          inet addr:192.168.1.37  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: ************************** Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:25 errors:0 dropped:0 overruns:0 frame:0
          TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4602 (4.6 KB)  TX bytes:17057 (17.0 KB)

Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service smbd reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload smbd
Server:      192.168.1.1
Address:   192.168.1.1#53

Non-authoritative answer:
Name:   google.com
Address: 173.194.43.6
Name:   google.com
Address: 173.194.43.5
Name:   google.com
Address: 173.194.43.4
Name:   google.com
Address: 173.194.43.3
Name:   google.com
Address: 173.194.43.2
Name:   google.com
Address: 173.194.43.1
Name:   google.com
Address: 173.194.43.0
Name:   google.com
Address: 173.194.43.14
Name:   google.com
Address: 173.194.43.9
Name:   google.com
Address: 173.194.43.8
Name:   google.com
Address: 173.194.43.7

-------------------------
* I. scanning WIFI PCI devices...
  -- Intel Corporation Centrino Wireless-N 1000
      ==> PCI ID = 8086:0084
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
-------------------------
* IV. querying ifconfig...
-------------------------
* V. querying DHCP...
-------------------------
* VI. querying nslookup google.com...


Code: Select all
Mar 12 21:59:54 minty-titan wpa_supplicant[978]: wlan0: Michael MIC failure detected
Mar 12 21:59:54 minty-titan wpa_supplicant[978]: wlan0: Michael MIC failure detected
Mar 12 21:59:54 minty-titan wpa_supplicant[978]: wlan0: WPA: Sending EAPOL-Key Request (error=1 pairwise=0 ptk_set=1 len=99)
Mar 12 21:59:54 minty-titan wpa_supplicant[978]: wlan0: WPA: Sending EAPOL-Key Request (error=1 pairwise=0 ptk_set=1 len=99)
Mar 12 21:59:54 minty-titan wpa_supplicant[978]: wlan0: TKIP countermeasures started
Mar 12 21:59:54 minty-titan kernel: [  149.456600] wlan0: deauthenticating from ********************** by local choice (reason=14)
Mar 12 21:59:54 minty-titan wpa_supplicant[978]: wlan0: Michael MIC failure detected
Mar 12 21:59:54 minty-titan wpa_supplicant[978]: wlan0: Failed to read BSSID for EAPOL-Key request
Mar 12 21:59:54 minty-titan wpa_supplicant[978]: wlan0: Failed to read BSSID for EAPOL-Key request
Mar 12 21:59:54 minty-titan wpa_supplicant[978]: wlan0: TKIP countermeasures started
Mar 12 21:59:54 minty-titan kernel: [  149.506164] cfg80211: All devices are disconnected, going to restore regulatory settings
Mar 12 21:59:54 minty-titan kernel: [  149.506175] cfg80211: Restoring regulatory settings
Mar 12 21:59:54 minty-titan kernel: [  149.506190] cfg80211: Calling CRDA to update world regulatory domain
Mar 12 21:59:54 minty-titan wpa_supplicant[978]: wlan0: CTRL-EVENT-DISCONNECTED bssid=00:00:00:00:00:00 reason=14
Mar 12 21:59:54 minty-titan kernel: [  149.511593] cfg80211: Ignoring regulatory request Set by core since the driver uses its own custom regulatory domain
Mar 12 21:59:54 minty-titan kernel: [  149.511599] cfg80211: World regulatory domain updated:
Mar 12 21:59:54 minty-titan kernel: [  149.511601] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
Mar 12 21:59:54 minty-titan kernel: [  149.511604] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Mar 12 21:59:54 minty-titan kernel: [  149.511607] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Mar 12 21:59:54 minty-titan kernel: [  149.511610] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
Mar 12 21:59:54 minty-titan kernel: [  149.511613] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
Mar 12 21:59:54 minty-titan kernel: [  149.511615] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
tyraen
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 12, 2013 8:25 pm

Re: Centrino-N 1000 frequent disconnects

Postby tyraen on Wed Mar 13, 2013 9:56 am

This is probably the issue:

https://bugs.launchpad.net/ubuntu/+sour ... mments=all

I may try patching the kernel if I get brave enough.
tyraen
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 12, 2013 8:25 pm

Re: Centrino-N 1000 frequent disconnects

Postby tyraen on Wed Mar 13, 2013 10:40 am

I checked and it seems the patch mentioned in that bug report has been applied to 3.8, so I switched to a PPA of 3.8 (3.8.2-030802-generic). I'll test on the same wireless network later, but I can connect at work though it is very slow (shows 1MBps in KDE).
tyraen
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 12, 2013 8:25 pm

Re: Centrino-N 1000 frequent disconnects

Postby tyraen on Thu Mar 14, 2013 10:59 pm

There is still something wrong. I still get the Michael MIC failure with 3.8.2. The only way I can use wireless at this point is on unsecured APs. Pretty disappointing.

Would an older kernel even work with Mint 14? I could try going back to one of the original ones supporting the Centrino-N 1000.
tyraen
Level 1
Level 1
 
Posts: 6
Joined: Tue Mar 12, 2013 8:25 pm


Return to Wireless

Who is online

Users browsing this forum: No registered users and 13 guests