Wifi not working, Mint Cinnamon 14, 64 bit

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help

Wifi not working, Mint Cinnamon 14, 64 bit

Postby robco32 on Thu Mar 14, 2013 1:01 am

Hello, I am new to Linux and have installed Mint Cinnamon on my HP Pavilion and can't get the wifi to work.
It was working before I installed Cinnamon but its not now.
The internet will work if I am wired to it.
I have a physical switch for wifi.
I have done some research and found that I could check if the software and hardware were working by doing "rfkill list all".
Below is my results:

Code: Select all
rfkill list all
0: hp-wifi: Wireless LAN
   Soft blocked: no
   Hard blocked: no


It seems like other people have more info on their output than I do so I'm not sure if there is more problems than I know or not.

Thanks in advance for your help getting the wifi working.

(update)
Sorry, I forgot to add some more info.

Code: Select all
-------------------------
* I. scanning WIFI PCI devices...
  -- Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)
      ==> PCI ID = 14e4:4311 (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
eth0      no wireless extensions.

lo        no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0      Link encap:Ethernet  HWaddr 00:16:d3:16:e4:94 
          inet addr:192.168.1.105  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::216:d3ff:fe16:e494/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1132 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1030 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1239522 (1.2 MB)  TX bytes:171596 (171.5 KB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:80 errors:0 dropped:0 overruns:0 frame:0
          TX packets:80 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8253 (8.2 KB)  TX bytes:8253 (8.2 KB)

-------------------------
* V. querying DHCP...
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service smbd reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload smbd
RTNETLINK answers: File exists
-------------------------
* VI. querying nslookup google.com...
Server:      192.168.0.1
Address:   192.168.0.1#53

Non-authoritative answer:
Name:   google.com
Address: 74.125.225.166
Name:   google.com
Address: 74.125.225.167
Name:   google.com
Address: 74.125.225.168
Name:   google.com
Address: 74.125.225.169
Name:   google.com
Address: 74.125.225.174
Name:   google.com
Address: 74.125.225.160
Name:   google.com
Address: 74.125.225.161
Name:   google.com
Address: 74.125.225.162
Name:   google.com
Address: 74.125.225.163
Name:   google.com
Address: 74.125.225.164
Name:   google.com
Address: 74.125.225.165



Thanks
robco32
Level 1
Level 1
 
Posts: 3
Joined: Thu Mar 14, 2013 12:35 am

Linux Mint is funded by ads and donations.
 

Re: Wifi not working, Mint Cinnamon 14, 64 bit

Postby kc1di on Thu Mar 14, 2013 6:55 am

you'll need a temporary wired lan hookup for this.
Then Go to
Additional drivers
To install additional drivers, please run the "Software Sources" tool from "Menu->Preferences->Software Sources" and click on the "Additional Drivers" tab. The tool used in previous versions of Linux Mint (Jockey) was discontinued upstream in Ubuntu.

install the b43 drivers and reboot you should be all set.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 7
Level 7
 
Posts: 1522
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wifi not working, Mint Cinnamon 14, 64 bit

Postby robco32 on Thu Mar 14, 2013 1:58 pm

Hi Kc1di,

Thank you so much for your response. When I went to the "Software Sources" location you mentioned at the "Additional Drivers" tab there wasn't a b43 driver option to load. I was wired to lan while doing this.

I'm new enough to Linux that I'm not sure how to do a screen shot for you of what was in the tab but listed in there were 2 things.

"Broadcom Corp:BCM4311 802.11b/g WLAN" was listed with radio buttons in there with the 2 options.
off 1. "Using Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary)
on 2. "Do not use the device"

It was set to not be used so I tried to set it to be used and rebooted but that didn't fix the problem.

Also in there was listed NVidia Corp: C51 [GeForce Go 6150]. It was followed by 4 different options regarding its use.
off 1. "Using Nvidia binary Xorg driver, kernel module and VDPAU library from nvidia-current (proprietary,test)
on 2. "Using X.Org X server -- Nouveau display driver from xserver-xorg-video-nouveau (open source)
off 3. " Using Nvidia binary Xorg driver, kernel module and VDPAU library from nvidia-current-updates (proprietary)
off 4. "Using Experimental Nvidia binary Xorg driver, kernel module and VDPAU library from nvidia-experimental-304 (prorietary)

Do one of the Nvidia settings need changed or is there something totally different needed?
robco32
Level 1
Level 1
 
Posts: 3
Joined: Thu Mar 14, 2013 12:35 am

Re: Wifi not working, Mint Cinnamon 14, 64 bit

Postby kc1di on Thu Mar 14, 2013 2:33 pm

Ok the Nividia drivers are for your video card, you don't need them if everything is working with the open source driver.

The Sta driver listed is the wrong one for your card.
Do this then:
In a terminal type the following commands (enter your passwd when asked)

Code: Select all
sudo apt-get remove bcmwl-kernel-source
sudo apt-get install firmware-b43-installer b43-fwcutter

after those finish installing type in the terminal:
Code: Select all
sudo modprobe b43

Give network manager a minute to react and check and see if you see your wireless network.
now in order to have it start automatically you need to add b43 to the /etc/modules file. see my post in this thread to find out how to do that.
http://forums.linuxmint.com/viewtopic.php?f=53&t=128326

Of course you'll have to do this while connected to the net.
Good luck :)
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 7
Level 7
 
Posts: 1522
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wifi not working, Mint Cinnamon 14, 64 bit

Postby robco32 on Thu Mar 14, 2013 3:11 pm

Fantastic!! That did it!!
Thank you so much for you help that worked perfect.

You are awesome!!

Thank you Thank you Thank you
robco32
Level 1
Level 1
 
Posts: 3
Joined: Thu Mar 14, 2013 12:35 am

Re: Wifi not working, Mint Cinnamon 14, 64 bit

Postby kc1di on Thu Mar 14, 2013 3:16 pm

Your Welcome, glad to be of help, Enjoy.
:)
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 7
Level 7
 
Posts: 1522
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wifi not working, Mint Cinnamon 14, 64 bit

Postby eyemeansit on Thu Mar 28, 2013 6:45 pm

kc1di, you are my hero!
eyemeansit
Level 1
Level 1
 
Posts: 7
Joined: Mon Mar 16, 2009 5:20 am

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 4 guests