failed to install wireless drivers in mate 13

Questions about WIFI networks and devices
Forum rules
Before you post please read this

failed to install wireless drivers in mate 13

Postby paulou123 on Wed Mar 20, 2013 11:00 am

i have a Lenovo Tianyi F41 and i set up the linux mint mate 13 (maya) on it. i can now access Internet by only LAN connections. i have now installed the modem driver and Nvidia drivier by the "Menu" "Additional Drivers" but i got the following when i tried to install the wireless driver.

Sorry, installation of this driver failed.
Please have a look at the log file for details: /var/log/jockey.log.


and i list some lines of the jockey.log here:

2013-03-20 19:12:39,923 DEBUG: searching handler for driver ID {'driver_type': 'kernel_module', 'kernel_module': 'wl', 'package': 'bcmwl-kernel-source'}
2013-03-20 19:12:39,924 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: enabled, b43legacy: enabled
2013-03-20 19:12:39,923 DEBUG: found match in handler pool kmod:wl([BroadcomWLHandler, nonfree, disabled] Broadcom STA wireless driver)
2013-03-20 19:12:39,929 WARNING: modinfo for module wl failed: ERROR: modinfo: could not find module wl

2013-03-20 19:12:39,930 DEBUG: BroadcomWLHandler enabled(): kmod disabled, bcm43xx: blacklisted, b43: enabled, b43legacy: enabled
2013-03-20 19:12:39,930 DEBUG: got handler kmod:wl([BroadcomWLHandler, nonfree, disabled] Broadcom STA wireless driver)
2013-03-20 19:12:39,931 DEBUG: searching handler for driver ID {'driver_type': 'kernel_module', 'kernel_module': 'ssb'}
2013-03-20 19:12:39,931 DEBUG: no corresponding handler available for {'driver_type': 'kernel_module', 'kernel_module': 'ssb', 'jockey_handler': 'KernelModuleHandler'}
2013-03-20 19:12:39,931 DEBUG: searching handler for driver ID {'driver_type': 'kernel_module', 'kernel_module': 'b43', 'package': 'firmware-b43-lpphy-installer'}


i also tried download the STA wireless driver 32-bit but i have not fixed it yet.
here is some results that may help analysis.

i open a terminal and type: inxi -N then
Network: Card-1: Broadcom BCM4312 802.11b/g LP-PHY driver: b43-pci-bridge
Card-2: Broadcom NetLink BCM5787M Gigabit Ethernet PCI Express driver: tg3

when i type iwconfig then it shows
lo no wireless extensions.

wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:on

eth0 no wireless extensions.


at last, if i click the network button on the taskbar, there exists a word "firmware missing" after the "Wireless".

i have spent much time on fixing it but failed. is there any one help?
paulou123
Level 1
Level 1
 
Posts: 2
Joined: Wed Mar 20, 2013 9:45 am

Linux Mint is funded by ads and donations.
 

Re: failed to install wireless drivers in mate 13

Postby paulou123 on Wed Mar 20, 2013 11:56 am

okay, run the command i got:

szl@maya ~ $ sudo /usr/lib/linuxmint/mintWifi/mintWifi.py
[sudo] password for szl:
-------------------------
* I. scanning WIFI PCI devices...
-- Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
==> PCI ID = 14e4:4315 (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
lo no wireless extensions.

eth1 IEEE 802.11abg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=200 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off

eth0 no wireless extensions.

-------------------------
* IV. querying ifconfig...
eth0 Link encap:Ethernet HWaddr 00:1e:ec:61:3d:e5
inet addr:59.78.194.14 Bcast:59.78.194.255 Mask:255.255.255.0
inet6 addr: 2001:da8:8005:4057:a9ec:604d:a4ed:2ef5/64 Scope:Global
inet6 addr: 2001:da8:8005:4057:21e:ecff:fe61:3de5/64 Scope:Global
inet6 addr: fe80::21e:ecff:fe61:3de5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:27442 errors:0 dropped:0 overruns:0 frame:0
TX packets:17751 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:32500483 (32.5 MB) TX bytes:1488003 (1.4 MB)
Interrupt:19

eth1 Link encap:Ethernet HWaddr 00:21:00:29:6f:ab
inet6 addr: fe80::221:ff:fe29:6fab/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:702 errors:0 dropped:0 overruns:0 frame:0
TX packets:702 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:67954 (67.9 KB) TX bytes:67954 (67.9 KB)

-------------------------
* V. querying DHCP...
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service smbd reload

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the reload(8) utility, e.g. reload smbd
RTNETLINK answers: File exists
-------------------------
* VI. querying nslookup google.com...
Server: 202.120.80.243
Address: 202.120.80.243#53

Non-authoritative answer:
Name: google.com
Address: 74.125.31.102
Name: google.com
Address: 74.125.31.139
Name: google.com
Address: 74.125.31.101
Name: google.com
Address: 74.125.31.100
Name: google.com
Address: 74.125.31.113
Name: google.com
Address: 74.125.31.138
paulou123
Level 1
Level 1
 
Posts: 2
Joined: Wed Mar 20, 2013 9:45 am


Return to Wireless

Who is online

Users browsing this forum: No registered users and 6 guests