DHCP issue with WiFi connection

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help

DHCP issue with WiFi connection

Postby theknight38 on Wed Mar 20, 2013 8:41 pm

Hello everyone, i recently installed the latest Mint distribution (Nadia) - MATE gdm - since I am a long time fan of this beautiful distro.
I have little experience in wireless, and although I have been working with linux based system for years as part of my job, I'm literally hitting my head in the wall with this issue.

After a clean installation, on a dual boot laptop
Code: Select all
Machine:   System: Sony product: VPCF24C5E version: C60A7RYG serial: 54247547-0000819
           Mobo: Sony model: VAIO Bios: American Megatrends version: R2160V3 date: 09/23/2011


with this NICs

Code: Select all
Network:   Card-1: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169
           IF: eth0 state: down mac: f0:bf:97:e9:92:9d
           Card-2: Atheros AR9485 Wireless Network Adapter driver: ath9k
           IF: wlan0 state: up mac: 64:27:37:97:fd:7d


I tried to connect to my access point, but with little success.

The story so far:
Windows O.S. wireless working properly (well, needless to say, the laptop is Windows tested)
Red-Hat based distrubutions - I used to work mainly on these - (Fedora/CentOS): wireless working properly
Mint: pain. Installed at university, wireless working flawlessly. Come back home, NetworkManager trying to connect repeatedly with no success.

Honestly I tried only the basic checkup routines, since I am really new to Debian based distros (read n00b) and I really haven't much time (any more ç_ç) to mess up with an unknown system.
From the syslog, I reckon that the SSID is correctedly detected as well as the wireless setting. The WPA2 key is entered, but when NM hands over to DHCLIENT to obtain a lease, the process times out repeatedly until it reaches the max number ot attempts and dies.

The very odd thing is, when I connect to the router by cable and THEN try to set up a wireless connection, the DHCLIENT finds a lease in no time.
If I disconnect the cable, disconnect WiFi and reconnect WiFi only, the DHCLIENT still works like a charm.

Now I'm really baffles.

Any help would really be appreciated.
Also, please tell me what information I could provide to...help you helping me.

Thanks in advance :)
theknight38
Level 1
Level 1
 
Posts: 2
Joined: Wed Mar 20, 2013 8:17 pm

Linux Mint is funded by ads and donations.
 

Re: DHCP issue with WiFi connection

Postby theknight38 on Thu Mar 21, 2013 6:41 pm

This

http://tech.danbarrese.com/2012/07/12/xps-8500-atheros-ar9485-wifi-doesnt-work-in-linux-solved/

seems to SOLVE the issue. It basically told me to install a (newer?) version of compact-wireless and selecting "Atheros" driver.
Of course I had to replace

Code: Select all
$ wget http://www.orbit-lab.org/kernel/compat-wireless-2.6/compat-


With the latest version. I actually downloaded the tarball from the website (it was easier to navigate to the seemingly last release).

Thanks all anyway :)
However, curiosity remains about what the issue exactly was...
theknight38
Level 1
Level 1
 
Posts: 2
Joined: Wed Mar 20, 2013 8:17 pm


Return to Wireless

Who is online

Users browsing this forum: Google [Bot] and 7 guests