Mint KDE 14 forgets network within seconds

Questions about WIFI networks and devices
Forum rules
Before you post please read how to get help

Mint KDE 14 forgets network within seconds

Postby Oroborous on Sun Mar 24, 2013 3:22 pm

I am currently trying to do a fresh install of Mint KDE 14 on a computer that has a Windows 7 and had Kubuntu 12.10 working exactly right with the network.
When I run the install DVD and try to go to set up the wireless network before installing, the Interfaces panel shows the WLAN Interface as either Configuring Interface, Waiting for Authorization, or Not Connected.

If I call iwconfig while it is in the Configuring Interface stage, I get

Code: Select all
mint@mint ~ $ iwconfig;date
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"RegrettyMistakovich" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: 20:76:00:58:AE:D4   
          Bit Rate:117 Mb/s   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=55/70  Signal level=-55 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:4   Missed beacon:0

Sun Mar 24 12:57:25 UTC 2013


Then, not even a whole second later:

Code: Select all
mint@mint ~ $ iwconfig;date
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
         
Sun Mar 24 12:57:25 UTC 2013
 


You can actually see the plot being lost while running mintWifi.py. Here are two consecutive calls. The first is when
it is Waiting for Authorization

Code: Select all
$ sudo /usr/lib/linuxmint/mintWifi/mintWifi.py
-------------------------
* I. scanning WIFI PCI devices...
  -- Atheros Communications Inc. AR9462 Wireless Network Adapter (rev 01)
      ==> PCI ID = 168c:0034 (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
-------------------------
* IV. querying ifconfig...
eth0      Link encap:Ethernet  HWaddr 90:2b:34:3f:30:d5 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Memory:f7f00000-f7f20000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 44:6d:57:75:da:89 
          inet6 addr: fe80::466d:57ff:fe75:da89/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:64 errors:0 dropped:0 overruns:0 frame:0
          TX packets:64 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:8640 (8.6 KB)  TX bytes:9920 (9.9 KB)

-------------------------
* V. querying DHCP...
-------------------------
* VI. querying nslookup google.com...
;; connection timed out; no servers could be reached



And then when it is Configuring Interface and gives up.


Code: Select all
mint@mint ~ $ sudo /usr/lib/linuxmint/mintWifi/mintWifi.py
-------------------------
* I. scanning WIFI PCI devices...
  -- Atheros Communications Inc. AR9462 Wireless Network Adapter (rev 01)
      ==> PCI ID = 168c:0034 (rev 01)
-------------------------
* II. querying ndiswrapper...
-------------------------
* III. querying iwconfig...
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abgn  ESSID:"RegrettyMistakovich" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: 20:76:00:58:AE:D4   
          Bit Rate:130 Mb/s   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=56/70  Signal level=-54 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:5   Missed beacon:0

-------------------------
* IV. querying ifconfig...
eth0      Link encap:Ethernet  HWaddr 90:2b:34:3f:30:d5 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Memory:f7f00000-f7f20000

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 44:6d:57:75:da:89 
          inet6 addr: fe80::466d:57ff:fe75:da89/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:68 errors:0 dropped:0 overruns:0 frame:0
          TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9180 (9.1 KB)  TX bytes:10540 (10.5 KB)

-------------------------
* V. querying DHCP...
-------------------------
* VI. querying nslookup google.com...
;; connection timed out; no servers could be reached



Oddly enough, I did have this precise version of Mint running just fine on this computer a couple months back. Don't ask why I could not leave well enough alone.

If I do complete the install, I am asked for secrets for the network every few seconds. Anyone encounter a problem like this before?
Oroborous
Level 1
Level 1
 
Posts: 2
Joined: Sun Mar 24, 2013 2:57 pm

Linux Mint is funded by ads and donations.
 

Re: Mint KDE 14 forgets network within seconds

Postby Oroborous on Sun Mar 24, 2013 9:00 pm

Follow up:

I tried installing the 14.1 Cinnamon instead of KDE. There were no problems with the wireless this time and I was able to successfully install KDE after Cinnamon. I have no idea why I couldn't just start with KDE, but there you have it.
Oroborous
Level 1
Level 1
 
Posts: 2
Joined: Sun Mar 24, 2013 2:57 pm


Return to Wireless

Who is online

Users browsing this forum: No registered users and 5 guests