[SOLVED] Intel PRO/Wireless 2200BG [Calexico2] Not Working

Questions about WIFI networks and devices
Forum rules
Before you post please read this

[SOLVED] Intel PRO/Wireless 2200BG [Calexico2] Not Working

Postby myrlin on Wed Apr 10, 2013 7:52 am

I am trying to install LMDE on a friend's HP Compaq nc6120 laptop. I am new to Mint, but have used ArchLinux for a number of years.

All has gone reasonably well, except that I cannot get the wireless card working.
lspci identifies it as an Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05).

The full output of lspci is
Code: Select all
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
02:04.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
02:06.0 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
02:06.1 CardBus bridge: Texas Instruments PCIxx21/x515 Cardbus Controller
02:06.2 FireWire (IEEE 1394): Texas Instruments OHCI Compliant IEEE 1394 Host Controller
02:06.3 Mass storage controller: Texas Instruments PCIxx21 Integrated FlashMedia Controller
02:06.4 SD Host controller: Texas Instruments PCI6411/6421/6611/6621/7411/7421/7611/7621 Secure Digital Controller
02:06.5 Communication controller: Texas Instruments PCI6411/6421/6611/6621/7411/7421/7611/7621 Smart Card Controller
02:0e.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M_2 Gigabit Ethernet (rev 03)


Mint's Device Driver Manager seems to identify the card incorrectly as the ethernet controller, Broadcom Corporation NetXtreme BCM5705M_2 Gigabit Ethernet (rev 03)

The problem seem to lie with rf_kill, which has set the Hardware Lock on "phy0", and no matter what I try, I cannot clear this. I have tried the wireless switch on the lap top, and tried echoing integers 0 - 3 to rf_kill in /sys/bus/pci/ipw2200/*/rf_kill. This will only toggle the setting between 2 and 3. The full output of "rfkill list all" is
Code: Select all
0: hp-wifi: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: hp-bluetooth: Bluetooth
   Soft blocked: no
   Hard blocked: no
2: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: yes
4: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no

dmesg | grep 2200 gives
Code: Select all
[    0.124608] pci 0000:00:1e.2: reg 14: [io  0x2200-0x223f]
[   10.529002] ipw2200: Intel(R) PRO/Wireless 2200/2915 Network Driver, 1.2.2kmprq
[   10.529010] ipw2200: Copyright(c) 2003-2006 Intel Corporation
[   10.759141] ipw2200: Detected Intel PRO/Wireless 2200BG Network Connection
[   11.077728] ipw2200: Radio Frequency Kill Switch is On:
[   11.081160] ipw2200: Detected geography ZZR (14 802.11bg channels, 0 802.11a channels)
[ 1881.788066] ipw2200: Failed to send POWER_MODE: Command timed out.
[ 1893.528113] ipw2200: Failed to send POWER_MODE: Command timed out.
[ 2072.100101] ipw2200: Failed to send POWER_MODE: Command timed out.
[ 2240.500103] ipw2200: Failed to send POWER_MODE: Command timed out.
[ 2315.848106] ipw2200: Failed to send TX_POWER: Command timed out.

iwconfig gives
Code: Select all
lo        no wireless extensions.

eth2      IEEE 802.11bg  ESSID:off/any 
          Mode:Managed  Channel:0  Access Point: Not-Associated   
          Bit Rate:0 kb/s   Tx-Power=off   Sensitivity=8/0 
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth1      no wireless extensions.

Mint's network manager (from the system tray) gives the wireless hardware address as 00:16:6F:6F:BF:09, and unavailable. The "aeroplane" mode is set, and cannot be unset.

I would be very grateful indeed for any help in solving this, since a lap-top without a wireless connection is about as useful as a chocolate teapot!

Many thanks in advance
myrlin
Level 1
Level 1
 
Posts: 2
Joined: Wed Apr 10, 2013 7:19 am

Linux Mint is funded by ads and donations.
 

Re: [SOLVED] Intel PRO/Wireless 2200BG [Calexico2] Not Worki

Postby myrlin on Mon Apr 15, 2013 10:34 am

I solved this problem by DISABLING the wlan in the BIOS settings. Totally counter-intuitive, but all now works.

Thanks to everyone who has read this post and tried to help.
myrlin
Level 1
Level 1
 
Posts: 2
Joined: Wed Apr 10, 2013 7:19 am

Re: [SOLVED] Intel PRO/Wireless 2200BG [Calexico2] Not Worki

Postby bikrgran on Sun May 04, 2014 12:03 am

I'm brand new to Linux, and having the same problem. Where are the BIOS? I tried the BIOS on boot, but there was nothing (that I saw) that had anything to do with WLAN. Is this something in Linux, itself?

Thanks, so much!
bikrgran
Level 2
Level 2
 
Posts: 84
Joined: Wed Apr 30, 2014 10:14 am

Re: [SOLVED] Intel PRO/Wireless 2200BG [Calexico2] Not Worki

Postby pdc_2 on Sun May 04, 2014 2:16 am

this thread viewtopic.php?f=53&t=1085

is near the top of the wireless list of threads; it asks for information; sadly, wireless folks are not really into feelings and things; they just need facts;

so paste this
sudo /usr/lib/linuxmint/mintWifi/mintWifi.py
into a terminal; copy what it gives; and paste it back here so folks have some more information;

(and do think to start a new thread..............your issue is important to you...................just start a new thread when you have an issue ..)
pdc_2
Level 6
Level 6
 
Posts: 1076
Joined: Mon May 11, 2009 1:21 am


Return to Wireless

Who is online

Users browsing this forum: Google Adsense [Bot] and 6 guests