Wireless not working hp mini 110

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Wireless not working hp mini 110

Postby DrGibby on Mon Apr 22, 2013 11:19 am

first thing is im pretty new to linux so please bare with me

I installed linux mint 14 on my hp mini 110 from a pin drive everything is working properly (i think) except the internet connection. When my computer boots up it gives me the configuring network connection and never finds anything even when connected to lan and says networking manager disabled. Once booted after about 3-4 minutes it finds the lan and i have a lan connection. I cannot get the wireless working and would like to have the computer start with internet connection if able

ive been trouble shooting this for a couple weeks now and have decided to just give up and ask the community. I cannot seem to get the wireless working i have done the software sources >additional drivers for the broadcom enable fix and have even attempted these commands with the proper files associated with them

sudo modprobe -rv b43 ssb
tar xjf broadcom-wl-4.178.10.4.tar.bz2
cd broadcom-wl-4.178.10.4/linux
sudo b43-fwcutter -w /lib/firmware wl_apsta.o

Any help would be greatly appreciated.
DrGibby
Level 1
Level 1
 
Posts: 9
Joined: Mon Apr 22, 2013 11:05 am

Linux Mint is funded by ads and donations.
 

Re: Wireless not working hp mini 110

Postby kc1di on Mon Apr 22, 2013 2:31 pm

Hello DrGibby and welcome to mint.

I don't have a 110 myself do you know which broadcom wireless card it has in it?
if not go to a terminal and type the following
Code: Select all
lspci

it will give you long list but in that list will be your wireless card info.
let me know the card and think I can help.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1484
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless not working hp mini 110

Postby DrGibby on Mon Apr 22, 2013 2:38 pm

thanks for trying to help its really becoming frustrating. The broadcom is the Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
DrGibby
Level 1
Level 1
 
Posts: 9
Joined: Mon Apr 22, 2013 11:05 am

Re: Wireless not working hp mini 110

Postby kc1di on Mon Apr 22, 2013 3:59 pm

DrGibby wrote:thanks for trying to help its really becoming frustrating. The broadcom is the Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

ok that's the same card I have here. it works fine once you have the correct driver installed.

go to software manager click on edit select software sources and then click on the additional driver tab. It should offer you the Broadcom STA driver install that (note: you will have to be connect to you Lan hardwire for this.) after it finish reboot and you should be able to use the WIFI.
Good luck.

If that doesn't work let me know.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1484
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless not working hp mini 110

Postby DrGibby on Mon Apr 22, 2013 4:16 pm

Ive already tried that a couple of times without any luck
DrGibby
Level 1
Level 1
 
Posts: 9
Joined: Mon Apr 22, 2013 11:05 am

Re: Wireless not working hp mini 110

Postby kc1di on Mon Apr 22, 2013 4:45 pm

ok go to a terminal and type the following command:

Code: Select all
sudo modprobe -r b43 ssb brmc80211
sudo modprobe wl


see if it will work then if it does you will need to blacklist b43 and ssb by going to /etc/modeprobe.d/blacklist.conf and add those two to the list.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1484
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless not working hp mini 110

Postby DrGibby on Mon Apr 22, 2013 5:04 pm

After the first command i get Fatal: Module brmc80211 not found.

Is that a mistake or should it say that?
DrGibby
Level 1
Level 1
 
Posts: 9
Joined: Mon Apr 22, 2013 11:05 am

Re: Wireless not working hp mini 110

Postby kc1di on Mon Apr 22, 2013 5:15 pm

DrGibby wrote:After the first command i get Fatal: Module brmc80211 not found.

Is that a mistake or should it say that?

it may not be install if not just remove the first two and leave that one out.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1484
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless not working hp mini 110

Postby DrGibby on Mon Apr 22, 2013 6:11 pm

i left the last one out but it still does not work
DrGibby
Level 1
Level 1
 
Posts: 9
Joined: Mon Apr 22, 2013 11:05 am

Re: Wireless not working hp mini 110

Postby kc1di on Mon Apr 22, 2013 6:28 pm

could you go to a terminal and type the following commands and list the results here?

Code: Select all
rfkill list


then
Code: Select all
modeprobe list --all
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1484
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless not working hp mini 110

Postby DrGibby on Mon Apr 22, 2013 7:03 pm

Code: Select all
drgibby@Gizmo ~ $ rfkill list
0: brcmwl-0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: hp-wifi: Wireless LAN
   Soft blocked: no
   Hard blocked: no
drgibby@Gizmo ~ $ modeprobe list --all
No command 'modeprobe' found, did you mean:
 Command 'modprobe' from package 'module-init-tools' (main)
modeprobe: command not found
drgibby@Gizmo ~ $ rfkill list
0: brcmwl-0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: hp-wifi: Wireless LAN
   Soft blocked: no
   Hard blocked: no
drgibby@Gizmo ~ $ modprobe list --all
WARNING: Module list not found.
DrGibby
Level 1
Level 1
 
Posts: 9
Joined: Mon Apr 22, 2013 11:05 am

Re: Wireless not working hp mini 110

Postby kc1di on Mon Apr 22, 2013 7:18 pm

sorry gave you the wrong modprobe command do this one:
Code: Select all
modeprobe -l wl
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1484
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless not working hp mini 110

Postby DrGibby on Mon Apr 22, 2013 7:37 pm

says no command found for that one to?
DrGibby
Level 1
Level 1
 
Posts: 9
Joined: Mon Apr 22, 2013 11:05 am

Re: Wireless not working hp mini 110

Postby kc1di on Mon Apr 22, 2013 8:57 pm

DrGibby wrote:says no command found for that one to?

Woops must be getting tired ;)
should be
Code: Select all
modprobe -l wl
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1484
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless not working hp mini 110

Postby DrGibby on Mon Apr 22, 2013 9:23 pm

Code: Select all
drgibby@Gizmo ~ $ rfkill list
0: brcmwl-0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: hp-wifi: Wireless LAN
   Soft blocked: no
   Hard blocked: no
drgibby@Gizmo ~ $ modprobe -l wl
updates/wl.ko
drgibby@Gizmo ~ $

DrGibby
Level 1
Level 1
 
Posts: 9
Joined: Mon Apr 22, 2013 11:05 am

Re: Wireless not working hp mini 110

Postby kc1di on Tue Apr 23, 2013 6:20 am

Ok at this point I think the best thing for you to do would be go to synaptic and remove all broadcom drivers and associated files.
then just reinstall broadcom-sta driver. you do not want the b43 driver installed at all.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1484
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless not working hp mini 110

Postby AlbertP on Tue Apr 23, 2013 8:26 am

Please install firmware-b43-lpphy-installer from the Software Manager when connected to wired internet. That worked for me on a Compaq Mini 110 (which is the same computer as the HP Mini 110).
Please do not install the Broadcom STA driver unless you're sure b43 cannot be made working. The Broadcom STA driver often works badly on a 4312 chip.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wireless not working hp mini 110

Postby kc1di on Tue Apr 23, 2013 9:17 am

AlbertP wrote:Please install firmware-b43-lpphy-installer from the Software Manager when connected to wired internet. That worked for me on a Compaq Mini 110 (which is the same computer as the HP Mini 110).
Please do not install the Broadcom STA driver unless you're sure b43 cannot be made working. The Broadcom STA driver often works badly on a 4312 chip.

hi Albert I have the 4312 in my lappy and the STA driver works but will not work if the b43 driver is installed. b43 will not work on my machine.
so I believe he should use the STA Driver.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1484
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wireless not working hp mini 110

Postby AlbertP on Tue Apr 23, 2013 9:33 am

b43 worked for me if installed using the firmware-b43-lpphy-installer package.

Good to know you got wifi working anyway with STA. But since it doesn't work for everybody, I recommend to try installing firmware-b43-lpphy-installer first when I am helping somebody who has a 4312 chip. (But if you already have it working, then you can just keep it that way).
Last edited by AlbertP on Tue Apr 23, 2013 10:09 am, edited 1 time in total.
Registered Linux User #528502
Image
Feel free to correct me if I'm trying to write in Spanish, French or German.
AlbertP
Level 16
Level 16
 
Posts: 6519
Joined: Sun Jan 30, 2011 12:38 pm
Location: The Netherlands

Re: Wireless not working hp mini 110

Postby kc1di on Tue Apr 23, 2013 9:58 am

AlbertP wrote:b43 worked for me if installed using the firmware-b43-lpphy-installer package.

Good to know you got wifi working anyway with STA. But since it doesn't work for everybody, I recommend to try installing firmware-b43-lpphy-installer first.

I'll give it a try on my laptop after i uninstall sta and see if it works but have had no luck with b43 using this card in the past.
John 3:16
Morse code an Early
Digital Mode
Registered Linux User #462608
Image
User avatar
kc1di
Level 6
Level 6
 
Posts: 1484
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Linux Mint is funded by ads and donations.
 
Next

Return to Wireless

Who is online

Users browsing this forum: Resistor and 14 guests