Getting WiFi to start automatically?

Questions about WIFI networks and devices
Forum rules
Before you post please read this

Getting WiFi to start automatically?

Postby gandalfmeister on Thu Apr 17, 2014 2:46 pm

Mint 16 - cinnamon 32 bit
Whenever I boot (or reboot) Mint starts with the Wifi off. I have to use the applet and enable Wifi - and then it connects without a problem.
How do I make Mint enable Wifi by default on every reboot please?
gandalfmeister
Level 1
Level 1
 
Posts: 13
Joined: Fri Nov 15, 2013 2:03 pm

Linux Mint is funded by ads and donations.
 

Re: Getting WiFi to start automatically?

Postby daveinuk on Thu Apr 17, 2014 2:53 pm

Click your network manager icon, then network settings, click the arrow next to your network ID, then settings, and the general tab, put a tick in the box for 'automatically connect etc etc', save and you should be done :)
Lenovo ThinkPad T61 LM16-64 bit Intel T7500/2.2GHz/Cinammon 1.8 Intel GM965. Toshiba Satellite M70: LM16-32bit. Desktop:LM13 Maya 64 bit, on new Intel 3.2ghz proc/asus MB/8gb RAM
User avatar
daveinuk
Level 5
Level 5
 
Posts: 958
Joined: Tue Mar 23, 2010 7:52 pm
Location: Manchester, England.

Re: Getting WiFi to start automatically?

Postby gandalfmeister on Fri Apr 18, 2014 3:56 am

Ah - nope. (but thanks for the fast response anyway!)

The automatic connect to the specified networks are already set and work just fine. What is disabled (and keeps getting disabled every reboot) is the activation of the wifi adaptor. The little "broken connection" icon in the panel. I have to press that - and Mint then goes off and discovers the Wifi - and connects to the specified services.
How do I get the Wifi adaptor to start on reboot?
gandalfmeister
Level 1
Level 1
 
Posts: 13
Joined: Fri Nov 15, 2013 2:03 pm

Re: Getting WiFi to start automatically?

Postby CptFuzzy on Fri Apr 25, 2014 9:01 pm

I have the exact same problem. MINT (MATE) 16 x64 fresh install.
CptFuzzy
Level 1
Level 1
 
Posts: 1
Joined: Thu Jan 03, 2013 5:58 pm

Re: Getting WiFi to start automatically?

Postby gandalfmeister on Sat May 03, 2014 11:54 am

No response from the experts - so its either unique to us - or there is no fix
:-(
gandalfmeister
Level 1
Level 1
 
Posts: 13
Joined: Fri Nov 15, 2013 2:03 pm

Re: Getting WiFi to start automatically?

Postby cvilla on Sun May 04, 2014 3:46 pm

Just looking for a solution myself, Linux Mint 16 Cinnamon 32 bit, v 2.0.14

Same issue I have to manually connect WiFi each time I start up PC, using network settings, then conect to a hidden network.
MTU is automatic (not sure what this means!)

What else do I need to do anyone ideas?
Thanks
Chris
cvilla
Level 1
Level 1
 
Posts: 5
Joined: Wed Jan 01, 2014 3:57 pm

Re: Getting WiFi to start automatically?

Postby Mr. Freeze on Thu May 08, 2014 7:12 am

Same issue here, Linux Mint Cinamon 16 (64bit), HP laptop 6730B. I Have tried google, duckduckgo and others, no succes. My GF's laptop however does connect automaticlly, she has a HP too, but other model but same Mint version.
Mr. Freeze
Level 1
Level 1
 
Posts: 1
Joined: Thu May 08, 2014 7:04 am

Postby JeremyB on Thu May 08, 2014 1:10 pm

I would think there would be errors somewhere, could try a
Code: Select all
dmesg | grep wlan
JeremyB
Level 5
Level 5
 
Posts: 850
Joined: Fri Feb 21, 2014 8:17 am

Re: Getting WiFi to start automatically?

Postby cvilla on Fri May 09, 2014 4:15 pm

I don't understand the code, but I put it into the terminal and this happened:

c@c-Aspire-9300 ~ $ dmesg | grep wlan
[ 20.581233] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 20.581692] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 148.586277] wlan0: authenticate with 30:46:9a:36:ed:1c
[ 148.612502] wlan0: send auth to 30:46:9a:36:ed:1c (try 1/3)
[ 148.616840] wlan0: authenticated
[ 148.620108] wlan0: associate with 30:46:9a:36:ed:1c (try 1/3)
[ 148.626953] wlan0: RX AssocResp from 30:46:9a:36:ed:1c (capab=0x431 status=0 aid=1)
[ 148.627758] wlan0: associated
[ 148.627826] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
c@c-Aspire-9300 ~ $

but I tried and a re-start did not work.
basically a fixed cable is OK, but the WiFi needs manually setting up each time.
MTU is set to automatic, not sure what this is (as mentioned earlier!)
Any other ideas? or info that may help find a solution, sounds like it is a common issue.
Thanks
Chris
cvilla
Level 1
Level 1
 
Posts: 5
Joined: Wed Jan 01, 2014 3:57 pm

Linux Mint is funded by ads and donations.
 

Return to Wireless

Who is online

Users browsing this forum: No registered users and 3 guests