Very inconsistent login behavior

Very inconsistent login behavior

Postby se2131 on Sat Dec 17, 2011 1:10 am

For the past few months, I've been having a lot of issues with the login for Linux Mint. I'm running the 64-bit edition and am running compiz as well

When I start up, occasionally it works fine on the first try. Most of the time it may:

1) Not show my desktop
2) Not show gnome-panel
3) Not start gnome-do
4) May have 1 or more panel applet errors (asking me if I want to delete the applet). It varies which applet doesn't work (such as clock, mint menu, indicator applet, system load applet, etc).

Any combination of the above happen frequently. I usually have to log out and log in 2-3 times (and the behavior changes each time I do this) before it logs in with everything correct.

I realize that I'm not giving enough information to diagnose this right away, please let me know whatever logs or other info is needed
se2131
Level 1
Level 1
 
Posts: 2
Joined: Sat Dec 17, 2011 1:02 am

Linux Mint is funded by ads and donations.
 

Re: Very inconsistent login behavior

Postby DrMartinus on Sat Dec 17, 2011 2:44 am

I just had a similar experience. Yesterday evening, I enabled autologin for me. This morning I started my PC, and found that it showed me the list of bootup-procedures (which processes were turned on), it stopped at a line with something related to ALSA. I thought I wait a while, but no go. After five to ten minutes I rebooted. The same thing. Then I, more for fun than being serious, I switched to the second console (ALT-F2) and found the login prompt there: Mint was waiting for me there. It had disabled the graphical login and in turn enabled the console login.
After login, I got the console, but no gnome. Now I typed in "startx", and gnome started, but without gnome-panel, so no menu, nothing. The desktop behaved as if it was Nautilus. No way to get to some basic gnome commands. After two tries (in the second I ran "gnome-panel" in the gnome-console, which brought me a panel, but not the Mint one) I figured that I might need to disable autologin. Et voilà: everything was back to normal. The only - annoying - thing now: I have to login each time I start the PC. OK, it's security relevant, but no one else gets to my PC. In Mint 11, I always had autologin enabled.
Now, in Mint 12, it doesn't seem possible. :-(
Dr. Martinus, Linux user since 1999
Current system: LinuxMint 12, AMD 64-bit, Gnome Desktop, up-to-date (at least I try)
I'm German, so I might translate terms and software names the wrong way. Please apologize and ask if something is unclear
DrMartinus
Level 2
Level 2
 
Posts: 74
Joined: Tue Apr 06, 2010 1:16 am

Re: Very inconsistent login behavior

Postby se2131 on Fri Dec 23, 2011 3:58 pm

I tried disabling auto-login, but I still seem to have the same issues. Not sure where to go from here
se2131
Level 1
Level 1
 
Posts: 2
Joined: Sat Dec 17, 2011 1:02 am

Re: Very inconsistent login behavior

Postby webass on Tue Feb 07, 2012 6:12 pm

Hi !
I am excactly having the same issues here.
My story is that I have Linux Mint 12 installed and today before I left the house, wanted to tset off autologin, because my Password is kind of radical.

Came back from the travel and it gives out only things like "Checking battery state" [OK] and stops
or stops at trying to start apache!
Always the same two scenarios.
I also updated my xorg drivers after I started synaptic from console.
The same stuff over and over again.
Only startx gives me the desktop, and I would need to use the terminal for everything.

I also think,that the setting for auto login is set to off (it is grey not blue)

Dont know what to do further on.
Anybody any idea?

Cheers.
Andre

EDIT: I cannot use startx anymore, the screen now stays black.
I will try to set off autologin per terminal now.
EDIT 2: Now I set it off and get the login prompt. I have to choose either GNOME, GNOME Classic or the others but after login try I receive this message: "Could not update /home/username/.ICEauthority file" and cannot do anything against it after trying several solutions with chown and dpkg-reconfigure nautilus.

This starts to become really annoying, just because setting the autologin to ON once. :shock:

EDIT 3: I ended up in installing LXDE, so that I could start my work right now.
This really wasnt fun.
I will later try to get rid of everything that has to do with gnome and then start thinking what argument will make me install Gnome ever again.
reboot-the-root-noob.
webass
Level 1
Level 1
 
Posts: 46
Joined: Tue Apr 05, 2011 2:22 pm


Return to MATE

Who is online

Users browsing this forum: No registered users and 2 guests