Enter single or double quotes

Forum rules
Before you post please read how to get help

Enter single or double quotes

Postby JohanHarmsen on Thu Mar 22, 2012 10:31 am

Hello
I´m having the following problem with gnome-terminal v3.0.1 on Linux Mint rel. 12 (lisa)
After each single or double quote character I enter I have to enter a space to get the character on the screen.
In Windows I can select this by setting the input language (if I select Dutch I have the above behavior, if I select English the character appears immediately). Is there some setting somewhere that triggers the 'English' behavior ?
BTW. The problem is generic (I also saw it in LibreOffice Writer and while typing this message)

TIA

Johan
JohanHarmsen
Level 1
Level 1
 
Posts: 2
Joined: Thu Mar 22, 2012 10:21 am

Linux Mint is funded by ads and donations.
 

Re: Enter single or double quotes

Postby xenopeek on Thu Mar 22, 2012 2:05 pm

Yes, this insanity should end :D The default keyboard layout is "English (US, international with dead keys)". Whoever thought dead keys were somehow an improvement was clearly never using the terminal, entering passwords, or programming :roll: You can easily disable it:
- Go to System Tools > System Settings
- Open Keyboard Layout
- Go to the Layouts tab
- Click the + icon at the bottom left, choose "English (US)", click Add
- Highlight "English (US, international with dead keys)" and click the - icon at the bottom left
- Logout, login again (not sure if this step is needed)

You should now no longer have dead keys. If you still need to be able to enter characters like é, ë or è easily, go back to the Layouts tab above and click the Options button. Expand the "Compose key position" and select one key to act as the compose key. If you then press and hold the compose key, press a diacritic key, release both, you can then add a letter and a diacritic will be added to it. You can also make other symbols like ™ and © with this.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15449
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Enter single or double quotes

Postby JohanHarmsen on Fri Mar 23, 2012 5:07 am

Hello Vincent
Thanks, works great, it's not even necessary to logout and login again
Great for an old-fashioned command line junkie !

Bedankt !

Johan
JohanHarmsen
Level 1
Level 1
 
Posts: 2
Joined: Thu Mar 22, 2012 10:21 am

Re: Enter single or double quotes

Postby peileppe on Fri Apr 27, 2012 3:49 pm

Hello,

I had the same problem with Keyboard layout English Macintosh international - I switched to English Macintosh and now quotes and double quotes work as expected
International also means "dead key" :D
confirmed no need to logout/login
:P
User avatar
peileppe
Level 1
Level 1
 
Posts: 20
Joined: Thu Nov 11, 2010 7:29 am


Return to MATE

Who is online

Users browsing this forum: No registered users and 0 guests