no gnome login screen after botched KDE install [SOLVED]

Forum rules
Before you post please read how to get help

no gnome login screen after botched KDE install [SOLVED]

Postby Snake Oil Salesman on Thu Apr 05, 2012 12:08 am

As the title stated, I was trying to see how KDE would look on my Mint 11 before upgrading to twelve (by installing the KDE-full package). While installing, mint complained about a lack of hard drive space in root before gnome crashed and I restarted. From that point on, startup would only to as far as to make the startup noise and show a darkened Linux mint background, but without a login box. From there I panicked, and removed KDE-full and GDM. Starting up would get me a KDE login screen, but no desktop option would work. I then removed kdm, and reinstalled gdm, only to get back to where I started. At that point, starting gdm would complain about a missing config file and start anyways, but with the same result. Again, I panicked and did a forced reinstall of xorg-xserver. Resulting in a lack of even the dimmed startup screen. After another forced reinstall of gdm, I have my dimmed welcome screen, but nothing else, putting me exactly where I started.

I have obviously done much more than I should have, but can could anyone assist me? I'd provide logs and such right now, but this post is already gigantic. Also, I apologize if this is in the wrong section.

In addition, starting gdm from console gives
Code: Select all
** (gdm-binary:1975): WARNING **: failed to acquire org.gnome.DisplayManager
 ** (gdm-binary:1975): WARNING **: could not acquire name: bailing out

Another edit...
Additional snooping shows a segfault in gnome-settings in dmesg. Starting it manually has it complain about GTK+

Yet another edit:
I can only get the dimmed login screen after a fresh reinstall of gdm. Is it even possible to salvage this situation any more?

One more edit:
I see what I was doing wrong before, but running "restart gdm" still only gives me a black screen with a cursor. In addition, :0-greeter.log is a little strange, while :0.log is unremarkable. What the heck is going on here?

Installed 12 :?
Snake Oil Salesman
Level 1
Level 1
Posts: 2
Joined: Thu Aug 11, 2011 5:24 pm

Linux Mint is funded by ads and donations.

Return to MATE

Who is online

Users browsing this forum: No registered users and 1 guest