[solved] KDE session not starting properly after software up

Forum rules
Before you post please read this

[solved] KDE session not starting properly after software up

Postby linuxrev on Sun Aug 12, 2012 12:34 pm

Today I had a problem I'd had before. After updating the kernel with Synaptic I rebooted my computer. The system started neatly, including KDE, but not completely. I have set KDE to start from a manually saved session, but it looked as if it had forgotten what I had saved, and saving again did not work. What was wrong?
  • In the system tray a number of entries was missing, custom ones as well as default ones.
  • The shutdown option did not work, neither from the application launcher, nor from the taskbar widget.
  • Keyboard shortcuts did not work, unless I restarted these manually from System Settings > Shortcuts & Gestures.
I muddled around, beginning at the unnecessarily complicated end, as usual... Finally it was quite simple to solve the problem.

1.
From System Settings > Startup & Shutdown > Session Management, under 'At Login' I ticked 'Restore previous session', and rebooted from a terminal:
Code: Select all
$ sudo reboot

At restart I had my system tray entries all back, and the keyboard shortcuts were working as before.

2.
From System Settings > Startup & Shutdown > Session Management, under 'At Login' I ticked anew 'Restore manually saved session', I saved the session from the application launcher, and rebooted -- et voila! it all worked.

You may need to restart one more time, but this it how the problem seems to be solved.

System: LinuxMint 13 LTS + KDE 4.7
linuxrev
--
cogito quod sum
linuxrev
Level 1
Level 1
 
Posts: 4
Joined: Sun Jul 24, 2011 1:49 pm
Location: Wildervank, The Netherlands

Linux Mint is funded by ads and donations.
 

Re: [solved] KDE session not starting properly after softwar

Postby linuxrev on Mon Sep 03, 2012 3:09 pm

Well, a wee update.

I've had some similar hang-ups now. It seems that for some reasons KDE hangs when KMix or some other part of the sound system is being loaded. The most easy solution is to just push the BRB and switch off your computer. At the next restart the problem will most likely have been solved.
linuxrev
--
cogito quod sum
linuxrev
Level 1
Level 1
 
Posts: 4
Joined: Sun Jul 24, 2011 1:49 pm
Location: Wildervank, The Netherlands


Return to KDE

Who is online

Users browsing this forum: No registered users and 2 guests