krandrtray resolution

Forum rules
Before you post please read this

krandrtray resolution

Postby Estteban on Sat May 04, 2013 11:03 am

Hello,
Can somebody guide me as to how to save the resolution that I want everytime I start the computer?
The highest available display resolution is 1024x768, I am able to get any higher resolution that I want through the command line using krandrtray (I even wrote a script),
But I spent time googling and making changes to different conf files with no luck, I dont want to change the driver. Thank you in advance.
Running Linux Mint KDE 14.

Estteban
Estteban
Level 1
Level 1
 
Posts: 4
Joined: Fri May 03, 2013 7:33 pm

Linux Mint is funded by ads and donations.
 

Re: krandrtray resolution

Postby Estteban on Sun May 26, 2013 11:37 am

Ok I give up, It seem a lot of people has been having this issue for 3 ot 4 years on differents versions of linux running KDE, without actually getting help, I will keep running my krandr script everytime I start the computer.

Jose G.
Estteban
Level 1
Level 1
 
Posts: 4
Joined: Fri May 03, 2013 7:33 pm

Re: krandrtray resolution

Postby hal8000 on Mon May 27, 2013 4:05 pm

In all the distributions I've used (including Mint) KDE has always run at my native resolution , same
as in windows at 1280x1024 on my desktop, and 1024x768 on my laptop.

Post the outpout of

Code: Select all
sudo inxi -G


Code: Select all
xrandr


You cannot run at a higher resolution than your available Video memory and everything should be
detected when Mint boots by kernel mode services.
What make , model is your graphics card, how much video memory is on board, and what resolution
do you want to run at?
User avatar
hal8000
Level 4
Level 4
 
Posts: 234
Joined: Sun May 04, 2008 2:04 pm
Location: UK

Re: krandrtray resolution

Postby Estteban on Wed May 29, 2013 10:24 pm

Hal,
Thanks for responding to my post,
here is the outpost of the commands:

sudo inxi -G
Graphics: Card: NVIDIA C61 [GeForce 7025 / nForce 630a]
X.org: 1.13.0 drivers: (unloaded: fbdev,vesa) FAILED: nouveau tty size: 122x39 Advanced Data:N/A for root

xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
VGA-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768 60.0*
800x600 60.3 56.2
848x480 60.0
640x480 59.9

Memory allocated to the video card is 256 MB, Like I said before I can run a higher resolution (normally 1440x900) without any problems.
I just can get it automatically when start the computer, I have a 24" monitor, so 1024x768 is very small resolution.


Jose G
Estteban
Level 1
Level 1
 
Posts: 4
Joined: Fri May 03, 2013 7:33 pm

Re: krandrtray resolution

Postby hal8000 on Thu May 30, 2013 10:18 am

Estteban wrote:Hal,
Thanks for responding to my post,
here is the outpost of the commands:

sudo inxi -G
Graphics: Card: NVIDIA C61 [GeForce 7025 / nForce 630a]
X.org: 1.13.0 drivers: (unloaded: fbdev,vesa) FAILED: nouveau tty size: 122x39 Advanced Data:N/A for root

xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 4096 x 4096
VGA-1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768 60.0*
800x600 60.3 56.2
848x480 60.0
640x480 59.9

Memory allocated to the video card is 256 MB, Like I said before I can run a higher resolution (normally 1440x900) without any problems.
I just can get it automatically when start the computer, I have a 24" monitor, so 1024x768 is very small resolution.


Jose G


I think your problem is that the Nouveau driver for your Nvdida card has failed to load, (highlighted in red). When I run same test
it shows that my driver is Catalyst (fglrx) for my ATI card.

inxi -G
Graphics: Card: Advanced Micro Devices [AMD] nee ATI Juniper [Radeon HD 5700 Series]
X.Org: 1.12.4 drivers: ati,fglrx (unloaded: fbdev,vesa,radeon) Resolution: 1280x1024@60.0hz
GLX Renderer: ATI Radeon HD 5700 Series GLX Version: 4.2.11672 - CPC

Without the accelerated driver, your card will run at a default resolution.
Follow this guide first:

http://community.linuxmint.com/tutorial/view/176

It contains a second link in Step 1 which you must follow.
This will blacklist the Nouveau driver and allow you to use Nvidias proprirtary driver.
Running nvidia-xconfig will generate an /etc/X11/xorg.conf file (not needed by KMS
but will be parsed and settings loaded).

Looking through sysnaptic current driver may be called nvidia-173 or similar.

Once loaded you should be able to use your 1440x900 resolution. This should
be set by either Xorg.conf, krandr aor nvidia-settings. Install nvidia-settings
from synaptic.

You can test if acceleration is enabled by running

glxgears
User avatar
hal8000
Level 4
Level 4
 
Posts: 234
Joined: Sun May 04, 2008 2:04 pm
Location: UK

Re: krandrtray resolution

Postby Estteban on Fri May 31, 2013 1:42 am

Hal,
I am more familiar with xorg.conf and nvidia driver,but I feel this current driver is working nice without giving high load to the system, May try the nvidia driver in a couple of days or sometime later.

Thanks, again
Jose G.
Estteban
Level 1
Level 1
 
Posts: 4
Joined: Fri May 03, 2013 7:33 pm

Re: krandrtray resolution

Postby markgcollard on Mon Feb 17, 2014 8:26 pm

I've accomplished what you are asking in several distros by putting the xrandr --newmode,
xrandr --addmode and xrandr --output <display> --mode <mode> in your ~/.profile file so it is executed at each login. also accomplished it putting same commands into the xsetup file in /etc/kde4/ folder if i remember correctly.

put the commands between the following two lines in your .profile file:

#umask 022

# if running bash

so it looks like this (obviously substitute the modeline and display name for yours)

# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022
xrandr --newmode "1368x768_60.00" 85.25 1368 1440 1576 1784 768 771 781 798 -hsync +vsync
xrandr --addmode HDMI-0 "1368x768_60.00"
xrandr --output HDMI-0 --mode 1368x768_60.00

# if running bash
if [ -n "$BASH_VERSION" ]; then
# include .bashrc if it exists
if [ -f "$HOME/.bashrc" ]; then
. "$HOME/.bashrc"
fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
PATH="$HOME/bin:$PATH"
fi
markgcollard
Level 1
Level 1
 
Posts: 11
Joined: Wed Nov 13, 2013 10:42 am

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 1 guest