KDE LM 17 great but went back to KDE LM 13. Why?

Forum rules
Before you post please read this

KDE LM 17 great but went back to KDE LM 13. Why?

Postby kspringer on Tue Jul 15, 2014 6:05 pm

Hello. Though I usually visit once or twice a week, I haven't posted here for quite a while and haven't logged in for about a year.

I'm going to explain my disappointment with KDE LM 17 - and with LM 17, in general. I suspect both of my issues result from the carry-over from the Kubuntu release.

I've used KDE LM 13 LTS since it came out and awaited eagerly for KDE LM 17 LTS. I quickly downloaded and explored. I liked it. I STILL like it a lot! But then the problems started...

I installed KDE LM 17 on my Dell Inspiron 1525 (yeah, it's old but realiable) and was quite happy - for about a day.
Issue 1: I really didn't like the fact that "resume" was broken for me. When I opened my laptop, I got a black screen. Yes, I've read every post on the forums with the same symptoms but none worked for me. None. I began shutting my laptop down after every session.
Issue 2: My deal-breaker - for some unknown reason, I routinely LOST my title bar and borders! I couldn't minimize; I couldn't close out a window; I lost the menu functions; keyboard shortcuts usually wouldn't work and when I selected the "start" button, the window would open behind the active window. If I shut down the computer and started it back up, the title bar and borders were still gone. The only fix I found was to reinstall. Re-in-stall. Every time.

So. After about three weeks of installing KDE LM 17 LTS 32bit; then 64bit; then Kubuntu LTS; then Ubuntu LTS; back and forth, I decided to go back to KDE LM 13 LTS. Took a little playing with as some changes had happened. Tried updating my wireless driver (which worked nicely for the last couple of years) and couldn't find "jockey" or whatever. Ended up going to ubuntuforums.org to fix this with a sticky broadcom wireless sticky.

Other than that, I'm right where I used to be. The "resume" works and I don't lose my title bars and borders.

And I'm enjoying KDE LM 13 LTS again. But I really, really liked 17.
kspringer
Level 1
Level 1
 
Posts: 13
Joined: Thu Jun 03, 2010 6:19 pm

Linux Mint is funded by ads and donations.
 

Re: KDE LM 17 great but went back to KDE LM 13. Why?

Postby lauren on Thu Jul 17, 2014 5:11 am

Hi!
I have some problems with Qiana KDE (slow, bluetooth); for me there is one fundamental question concerning Maya:
There are no point releases - if you make a fresh installation und update the system:
1. how many updates?
2. how much time?
lauren
Level 5
Level 5
 
Posts: 588
Joined: Thu Nov 26, 2009 10:50 am

Re: KDE LM 17 great but went back to KDE LM 13. Why?

Postby kspringer on Sat Jul 19, 2014 9:27 pm

Hey, lauren...

1. How many updates? Not as many as you would think. I think I had 600+ files; about 500 meg if I remember correctly...
2. How much time? I didn't download everything all at once. But from downloading start to finish, I probably had two or three hours until it was back up.
kspringer
Level 1
Level 1
 
Posts: 13
Joined: Thu Jun 03, 2010 6:19 pm

Re: KDE LM 17 great but went back to KDE LM 13. Why?

Postby EmpireITtech on Wed Jul 23, 2014 11:09 am

Yea, the Ubuntu/Mint resume from sleep issue is very annoying, and actually the main reason I don't use my Linux laptop for work. I too have to shutdown after every session (LM17 Cinnamon).
Funnily enough, it worked fine on LM13, but every Mint since has failed (14,15,16,17....I try them all lol). I'm using a HP Probook 4545. :(

Good luck!
Linux: Mint 17 Qiana Cinnamon 64-Bit
Box: Intel Core 2 Quad | 8gb RAM | 500 gb WD 7200rpm | nVidia Geforce GTS250
Pants: 32x30
User avatar
EmpireITtech
Level 4
Level 4
 
Posts: 315
Joined: Fri Oct 12, 2012 8:45 am

Re: KDE LM 17 great but went back to KDE LM 13. Why?

Postby hal8000 on Sun Jul 27, 2014 6:23 am

What graphics chipset is in your Dell Inspiron 1525 ?

inxi -Gx

lspci -v | grep -i vga


I run LM16 KDE on an Acer Aspire 5734Z with Integrated Intel GMA4500 chipset and suspend/resume and brightness work fine.
A black screen may be graphics or the updated Xorg1.15 (not sure just a guess).

Will download a DVD on LM17 KDE and test in live mode before I decide to upgrade though.
User avatar
hal8000
Level 4
Level 4
 
Posts: 233
Joined: Sun May 04, 2008 2:04 pm
Location: UK

Re: KDE LM 17 great but went back to KDE LM 13. Why?

Postby PatH57 on Sun Jul 27, 2014 6:34 am

Hi,

I also have Dell 1525 with a discrete graphic card, it took me 2 weeks to get erevything to work the way I like it.
My biggest problem was resume and the fan going nuts.
So driver change and a new kernel did a lot of good, still comapred to XP my Mint17 Mate is asking a lot more from my old faithfull Dell.
I have a newer laptop and had less problems with Mint (don't like to say problems it's not, I'm running a brand new OS on an older PC)
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
PatH57
Level 11
Level 11
 
Posts: 3982
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Re: KDE LM 17 great but went back to KDE LM 13. Why?

Postby kspringer on Mon Jul 28, 2014 6:33 pm

Hey, hal8000 as requested:

---------
Inspiron-1525 ~ $ inxi -Gx
Graphics: Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary) bus-ID: 00:02.0
X.Org: 1.11.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1280x800@60.0hz
GLX Renderer: Mesa DRI Intel 965GM x86/MMX/SSE2 GLX Version: 2.1 Mesa 8.0.4 Direct Rendering: Yes
Inspiron-1525 ~ $ lspci -v | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c) (prog-if 00 [VGA controller])
---------

I don't know if it's easily fixable - may be too much work to get "small" things to work.

Ok, I REALLY like linux. And I LOVE Linux Mint. I have an "old" laptop. It's been a workhorse; it's been great; and well worth the money for the initial purchase price (Ubuntu loaded!). But it really may be time to upgrade. So: laptop or tablet. I REALLY like linux, but...

Thanks for the comments, people!

k.
kspringer
Level 1
Level 1
 
Posts: 13
Joined: Thu Jun 03, 2010 6:19 pm

Re: KDE LM 17 great but went back to KDE LM 13. Why?

Postby Whell on Thu Aug 14, 2014 9:44 pm

kspringer wrote:Hey, hal8000 as requested:

---------
Inspiron-1525 ~ $ inxi -Gx
Graphics: Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary) bus-ID: 00:02.0
X.Org: 1.11.3 drivers: intel (unloaded: fbdev,vesa) Resolution: 1280x800@60.0hz
GLX Renderer: Mesa DRI Intel 965GM x86/MMX/SSE2 GLX Version: 2.1 Mesa 8.0.4 Direct Rendering: Yes
Inspiron-1525 ~ $ lspci -v | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c) (prog-if 00 [VGA controller])
---------

I don't know if it's easily fixable - may be too much work to get "small" things to work.



This one is a mystery to me as well. Mint 13 is the last version of Mint to work really well with Intel (Mesa?) graphics cards. But its not just a Mint issue. Just about every newer version of Linux I've tried with my laptop, that also has a similar Intel graphics chip, require me to use a cheat code at boot time (acpi_osi=Linux) to overcome a backlight issue. Even when I do get to the desktop, HDMI video refuses to work. Works fine in Mint 13 and other older Linux distros (Mepis 11 for example, which is based on Debian Squeeze) but not newer (Debian Wheezy) distros.

I'll continue to scratch my head over this one I guess. :?

Here's my inxi output in Mint 13, for anyone interested:

Graphics: Card: Intel Mobile 4 Series Chipset Integrated Graphics Controller bus-ID: 00:02.0
X.Org: 1.11.3 drivers: intel (unloaded: vesa,fbdev) Resolution: 1366x768@60.1hz
GLX Renderer: Mesa DRI Mobile Intel® GM45 Express Chipset GLX Version: 2.1 Mesa 8.0.4 Direct Rendering: Yes
Whell
Level 1
Level 1
 
Posts: 15
Joined: Mon Sep 26, 2011 9:03 pm

Re: KDE LM 17 great but went back to KDE LM 13. Why?

Postby PatH57 on Fri Aug 15, 2014 3:24 am

discovered this tool
checkbox-gui


witch is meant to check for compatibility issues (I did run it but I already had fixed my power management issues with adding the correct drivers for my Dell 1535 and adding i8k to monitor fans)
People disagree with me. I just ignore them.
(Linus Torvalds, regarding the use of C++ for the Linux kernel.)

Please Add [Solved] to the topic-title of your first post when appropriate so others know they might find a solution here.
User avatar
PatH57
Level 11
Level 11
 
Posts: 3982
Joined: Tue Mar 25, 2014 12:11 pm
Location: here and there

Linux Mint is funded by ads and donations.
 

Return to KDE

Who is online

Users browsing this forum: No registered users and 3 guests