Autoplay CD in VLC - not working

Forum rules
Before you post please read this

Autoplay CD in VLC - not working

Postby wonderdog on Sun Oct 28, 2012 2:51 am

Hi,

Running Linux Mint 13, w. XFCE, Intel chipset.

Installed VLC, uninstalled whatever default music app was set up (banshee or totem, can't remember) but when I put a CD in the drive, nothing comes up. I would like VLC to start and hopefully start playing the disc when a CD is inserted, but nothing!

Some notes:
VLC does work, as does the CD drive. I can open the CD from inside VLC and play it, no problems.
Have tried setting mime types (both in GUI and terminal) and editing x-content/audio-player and x-content/audio-cdda in defaults.list but that hasn't helped.
I would like a digital camera to do the same thing, but that's less of a priority.
Some other posts refer to a Media tab in the preferences, but that doesn't appear to be available (is that Mint 13 or XFCE that's responsible?)
All updates are installed, otherwise computer working fine.

Completely out of ideas except to start again with another frontend or distro.

Thanks!
wonderdog
Level 1
Level 1
 
Posts: 5
Joined: Mon Oct 22, 2012 11:49 pm

Linux Mint is funded by ads and donations.
 

Re: Autoplay CD in VLC - not working

Postby cwsnyder on Sun Oct 28, 2012 6:37 am

Your problem may not be Xfce or Mint, it may be VLC. The version of VLC (2.0.2) which I am running also has no media tab, and Preferences is under Tools, which it wasn't, as I remember, under older versions of VLC. Media is one of the top level menu selections now for VLC.
LMDE Mate 64-bit, LM16 Mate 64-bit
Debian Xfce 64-bit, Xubuntu 13.10 64-bit, Xubuntu Trusty Tahr 64-bit, Antergos Xfce 64-bit, PCLinuxOS LXDE 64-bit
cwsnyder
Level 6
Level 6
 
Posts: 1039
Joined: Wed Oct 20, 2010 6:49 am
Location: Nappanee, IN, USA

Re: Autoplay CD in VLC - not working

Postby wonderdog on Sun Oct 28, 2012 8:58 pm

Can't find any such thing anywhere in VLC. I did have to change the CD drive input device to dev/sr0, but I did this awhile ago. I think the tab I was referring to is a Mint tab that comes with a different front-end, running Nautilus, which is not running on my machine.

I have a new theory though: It's not mounting the audio disc. DVD mounts and starts VLC (but doesn't auto-play, but one issue at a time) but CD just sits there unmounted. Something to go on though.
wonderdog
Level 1
Level 1
 
Posts: 5
Joined: Mon Oct 22, 2012 11:49 pm

Re: Autoplay CD in VLC - not working

Postby caribriz on Sun Oct 28, 2012 11:14 pm

Hi wonderdog -
I couldn't get a cd to autoplay in Mint 13 xfce either with Banshee or VLC.
Inserted the cd and Banshee or VLC window would open, but not play the cd automatically - you had to click on it and click play.

Following this post on Ubuntu forums has worked for me in VLC.
http://ubuntuforums.org/showpost.php?s=eb93d9560f210e00892dedb8afafbe64&p=5306530&postcount=11

I didn't change any other settings or files besides these:
In Settings > Removable Drives and Media:
Storage > Removable Storage - checked all boxes (don't know if this was really necessary :? )
Multimedia > Audio CDs - checked "Play audio CDs when inserted"
and in the Command box: /usr/bin/vlc cdda:///dev/cdrom

I got the command from bluepowder7's post:
I figured out the cdda: part by manually opening up vlc, going "file"-"open disc", going to the 2nd tab, clicking the "audio cd" box, and looking what it spits out on the bottom for the "customize"


If you try this, your command may be different.

Edit: It's working in VLC, but still can't get it to autoplay with a similar command for Banshee :? .

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 901
Joined: Mon Nov 28, 2011 7:43 am

Re: Autoplay CD in VLC - fixed!

Postby wonderdog on Tue Oct 30, 2012 2:31 am

Thanks caribriz, got me to the right direction!

Fixed.
1. I'm not sure at which version this was implemented, but the Media/CD (and DVD, camera, etc.) autoplay settings moved from Preferred Applications to Removable Drives and Media, (I think, as some screenshots show the latter) which I guess makes sense but I never even chose Removable Drives and Media as it looked like hardware settings for USB sticks or possibly removable hard drives. Also not sure if this is a Mint 13 issue or XFCE issue. (I think Mint as I can't find it on my Ubuntu machine running XFCE, so there you go)

2. Anyway, In Settings > Removable Drives and Media > Multimedia tab > Audio CDs : I checked the Play box and changed the command to vlc cdda:///dev/sr0 which seems to be the DVD drive on this computer (found this through VLC by choosing to Open Disc and cycling through the Media options in the Disc device pulldown (or maybe I found it some other way in VLC, can't remember)). There is also option to set a default in VLC for this in the advanced preferences.

All in all much easier than tampering with all the settings files! Thanks again to caribriz for the help.
wonderdog
Level 1
Level 1
 
Posts: 5
Joined: Mon Oct 22, 2012 11:49 pm

Re: Autoplay CD in VLC - not working

Postby xntryk1 on Sun Dec 09, 2012 6:29 pm

Newbie, here. I think I'm having the same problem (or similar). Whenever I insert a CD or DVD, it spins for a little while, but doesn't open any program. I can only start it manually, by opening the program (say, VLC), finding the DVD in the drive and starting it. That can't possibly be the only way to do it. In reading this thread, it says to go to "In Settings > Removable Drives and Media > Multimedia tab > Audio CDs". But where do I find that at? I can't find any of those term, anywhere. Help! Thanks!

Sorry if this was posted in the wrong area. It was the only thread that seemed to be similar to my problem. Let me know if I should go post this in the newbie area, instead.
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Re: Autoplay CD in VLC - not working

Postby caribriz on Sun Dec 09, 2012 6:47 pm

What version of Mint 13 Maya are you using? Cinnamon, mate or xfce?
The solution will vary depending on which version.

The above worked in Mint 13 xfce.

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 901
Joined: Mon Nov 28, 2011 7:43 am

Re: Autoplay CD in VLC - not working

Postby xntryk1 on Sun Dec 09, 2012 6:49 pm

How do I determine that? Sorry to be such a pain. :-(
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Re: Autoplay CD in VLC - not working

Postby caribriz on Sun Dec 09, 2012 8:50 pm

If you can right-click the bottom panel > click About panels
If About the MATE panel window opens - you're using mate

If you cannot do this, then
Right-click the Menu button > click Panel settings
If Cinnamon Settings > Panel window opens .... you're using cinnamon

Try this first.

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 901
Joined: Mon Nov 28, 2011 7:43 am

Re: Autoplay CD in VLC - not working

Postby xntryk1 on Sun Dec 09, 2012 9:24 pm

Thanks. Sure enough, "The MATE Panel 1.2.1. Do you know if there's a solution for that version?
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Re: Autoplay CD in VLC - not working

Postby caribriz on Sun Dec 09, 2012 9:49 pm

Don't know for sure, but I'll try it on my mate install.

Maybe this would now be better continued on your other thread:
CD or DVD autoplay doesn't work in Mint 13 Maya
in "Newbie questions" as we now know it doesn't relate to Mint 13 xfce. :)

If I find anything useful, I'll respond there.

caribriz
Image
Desktop: C2D E6400 / Asus P5LD2SE / 2GB ram / Asus GeForce 210 / 320GB (WinXP) & 1TB (Mint - various)
Laptop: Asus A53E-SX1455V - i5 2450M / 4GB ram / Intel HD 3000 / 500GB (Win7/Mint 17 Cinnamon)
caribriz
Level 5
Level 5
 
Posts: 901
Joined: Mon Nov 28, 2011 7:43 am

Re: Autoplay CD in VLC - not working

Postby xntryk1 on Sun Dec 09, 2012 10:13 pm

Thank you. :-)
xntryk1
Level 1
Level 1
 
Posts: 19
Joined: Sun Nov 04, 2012 10:58 am

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 2 guests