Cannot stop windows from snapping to fullscreen SOLVED

Forum rules
Before you post please read this

Cannot stop windows from snapping to fullscreen SOLVED

Postby Thugette on Fri Jan 11, 2013 1:52 am

Hello. I just tried Linuxmint. Seems to work just fine but I am rather lost trying to find settings for common things. Unfortunately some aspects of the default setup are more or less deal breakers for me. One of them is this resizing of windows when you move them to the side or the top of the screen. I'm using Maya XFCE on a USB stick at the moment. But what are the ways to turn this off not just on this version but on on any and all versions of LinuxMint?

In Menu-Settings-Window Manager-Advanced tab is found the option: window snapping. This is the closest linguistic match to what I am looking for but unchecking this does not do anything. In Settings Editor there are thousands of settings but I don't see anything with words that imply a window is resized when moved to the edge or top of the screen. Menu-Settings-Appearance, Menu-Settings-Desktop, Menu-Settings-Display, don't show anything likely.

How do I turn this "feature" off?
Last edited by Thugette on Sat Jan 12, 2013 1:29 am, edited 1 time in total.
Thugette
Level 1
Level 1
 
Posts: 3
Joined: Fri Jan 11, 2013 12:02 am

Linux Mint is funded by ads and donations.
 

Re: Cannot stop windows from snapping to fullscreen

Postby abnvolk on Fri Jan 11, 2013 3:00 am

I think it's Snap windows to other windows.
Each desktop has a different method to disable snapping.
abnvolk
Level 4
Level 4
 
Posts: 495
Joined: Thu May 10, 2012 11:05 am

Re: Cannot stop windows from snapping to fullscreen

Postby Thugette on Fri Jan 11, 2013 4:56 am

Hello,

Yes, in Window Manager under the advanced tab is the option to untick snap windows to screen border and the option to unsnap to other windows. I tried them both of course, even though snap to other windows doesn't mean what I'm looking for cause you never know what words mean in distro xyz.

I thought this was funny: There was a solution to the same problem years ago:
"Disable snapping windows in compiz-fusion" by Kevin van Zonneveld
http://kvz.io/blog/2007/10/18/disable-s ... pizfusion/

..."It’s a subsetting of the Wobbly Windows plugin called: Snap Inverted. Turn it off and the snapping stops"...

What? Wobbly Windows plugin? Snap Inverted? Isn't that an absurd name for a setting which controls a changing of window size? Well anyhow, I don't know what the problem is. This is an insanely stupid way for a desktop to behave. If you can find a way out let me know.

Thanks.
Thugette
Level 1
Level 1
 
Posts: 3
Joined: Fri Jan 11, 2013 12:02 am

Re: Cannot stop windows from snapping to fullscreen

Postby palo on Fri Jan 11, 2013 6:05 pm

Thugette wrote: this resizing of windows when you move them to the side or the top of the screen. I'm using Maya XFCE on a USB stick at the moment. But what are the ways to turn this off not just on this version but on on any and all versions of LinuxMint?


Well for the version you are using try...Window Manager Tweaks>Accesibility tab - untick Automatically tile windows when moving toward the screen edge and tick - Use edge resistance instead of window snapping. The other versions have solutions reported in other threads.

Pat
~/mintmaya/xfce/enlightenment
Help Vampires: A Spotter's Guide
User avatar
palo
Level 4
Level 4
 
Posts: 434
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: Cannot stop windows from snapping to fullscreen

Postby Thugette on Sat Jan 12, 2013 1:08 am

That's it. Thank you!

Damn. I tried unticking "Snap window to screen border" in the Windows Manager because I don't know, I guess I'm from another planet and erroneously I associated snap and border to this behavior of snapping to borders. When it didn't work I opened Window Manager Tweaks but I didn't look under the accessiblility tab. Snapping window and accessibility? I didn't see the connection. But shouldn't be surprising. After all, in another distro the setting is listed under Wobbly Window pluggin. Meanwhile in an alternate universe...this is listed under "Things you want to turn off" not default behavior. I apologize for the rant. Can't stop myself from opining about this.

Thanks again Pat.
Thugette
Level 1
Level 1
 
Posts: 3
Joined: Fri Jan 11, 2013 12:02 am


Return to XFCE

Who is online

Users browsing this forum: getaway and 2 guests