No "busy" mouse pointer?

Forum rules
Before you post please read how to get help

No "busy" mouse pointer?

Postby ander111 on Tue Feb 26, 2013 8:45 pm

Hi,

Mint XFCE is super! It's noticeably faster than KDE or MATE on my pokey little netbook. An excellent implementation---I have nothing but good things to say about it.

There's just one small oddity I'd like to ask about. When I run a bigger app like Firefox or The GIMP, the mouse pointer should change to the animated "busy" pointer. But it usually doesn't. Sometimes I can see it by moving the pointer to the panel area, but not always.

Anyone know what's up with that? Should I file a bug report? If so, where?
User avatar
ander111
Level 3
Level 3
 
Posts: 152
Joined: Sat Jul 17, 2010 5:18 am

Linux Mint is funded by ads and donations.
 

Re: No "busy" mouse pointer?

Postby xenopeek on Wed Feb 27, 2013 4:20 am

The libraries needed for the busy cursor are installed on Linux Mint Xfce. However, only applications that support that standard will show the busy cursor while loading. For example, both Firefox and LibreOffice are known to integrate poorly with the Linux desktop and neither of them supports this standard (so no busy cursor). GIMP does support the standard, and so should do the busy cursor.

It also depends on your mouse cursor theme (in Mouse and Touchpad > Theme), but is sounds like you have a theme with a busy cursor.

Which version of Linux Mint are you using? Perhaps you are using one an older one, with an older Xfce version?
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15276
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: No "busy" mouse pointer?

Postby ander111 on Tue Mar 05, 2013 5:30 am

xenopeek wrote:The libraries needed for the busy cursor are installed on Linux Mint Xfce. However, only applications that support that standard will show the busy cursor while loading. For example, both Firefox and LibreOffice are known to integrate poorly with the Linux desktop and neither of them supports this standard (so no busy cursor). GIMP does support the standard, and so should do the busy cursor.

So it's the laurched app that controls the cursor? Not XFCE? I thought maybe XFCE, or a more fundamental part of the OS, showed the "busy" cursor till the app finished launching.

But that doesn't explain why, while FF (for example) is loading, I can move the mouse pointer down to the panel and the "busy" cursor does appear. Then when I move it back to the desktop, it disappears again... Doesn't that mean XFCE does know the app's still loading? Try it yourself and you'll see what I mean. You may need to do this on a slow PC, with many plug-ins added to your FF. ;?)

xenopeek wrote:It also depends on your mouse cursor theme (in Mouse and Touchpad > Theme), but is sounds like you have a theme with a busy cursor.

Yup.

xenopeek wrote:Which version of Linux Mint are you using?

Mint XFCE 14, with all updates... Anyway, it's curious.
User avatar
ander111
Level 3
Level 3
 
Posts: 152
Joined: Sat Jul 17, 2010 5:18 am

Re: No "busy" mouse pointer?

Postby xenopeek on Tue Mar 05, 2013 10:55 am

I don't know, perhaps a full-time Xfce user can pitch in with an answer :wink: AFAIK, the application is responsible for telling Xfce it is busy.
User avatar
xenopeek
Level 21
Level 21
 
Posts: 15276
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: No "busy" mouse pointer?

Postby ander111 on Fri Mar 08, 2013 3:42 am

Hey, this is great---I've done some updates (including a dist-upgrade) and now the "busy pointer" appears right away. So someone else out there noticed. Isn't it cool how quickly stuff can get fixed in the Linux world?
User avatar
ander111
Level 3
Level 3
 
Posts: 152
Joined: Sat Jul 17, 2010 5:18 am

Re: No "busy" mouse pointer?

Postby iaselle on Wed Aug 06, 2014 7:17 am

When creating the launcher, the launcher has "name.desktop" as its name attributes.

Just use your favourite editer to edit this launcher file and add "StartupNotify=true" without the quotes at the end of the file. Save and exit - launch and you will see the mouse pointer change to its working sign!

source :
http://ubuntuforums.org/showthread.php?t=1260355
iaselle
Level 1
Level 1
 
Posts: 7
Joined: Mon Jun 30, 2014 5:34 pm
Location: Toulouse, France

Re: No "busy" mouse pointer?

Postby ByeByeXP on Wed Aug 06, 2014 8:01 pm

Ime, as you get used to xfce-panel's "Launchers" (panel-buttons/-shortcuts that launch your apps), you have an option to control a button's "busy" cursor: right-click on a button > left-click on "Properties" > left-click its "Edit" (aka "pencil") button > left-click "Use startup notification" option > left-click "Save" button ... Done! Ime, this tweak works in LM13, 14, 15, 16 & 17.

PS: if you use the "Whisker"-menu, you can you chose to add a launch-button to your panel via right-clicking a menu-entry; note that this new launch-button does NOT have its startup notification option turned/clicked to "on" -- you'll need to do this yourself.
ByeByeXP
Level 1
Level 1
 
Posts: 29
Joined: Fri Sep 27, 2013 10:42 pm
Location: USofA

Linux Mint is funded by ads and donations.
 

Return to XFCE

Who is online

Users browsing this forum: No registered users and 3 guests