Mounted Drives not showing in places

Forum rules
Before you post please read this

Mounted Drives not showing in places

Postby lilpaul on Sun Aug 31, 2008 12:00 pm

Im new to linux, so please be gentle.

I have just installed the latest Linux Mint 5 XFCE version, and upon completion I noticed my hard drives where not mounted on startup. I have performed the following actions so far:-

-- Identify Partitions Available
Disk /dev/sda: 37.0 GB, 37019566080 bytes
255 heads, 63 sectors/track, 4500 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x9e129e12

Device Boot Start End Blocks Id System
/dev/sda1 * 1 4310 34620043+ 83 Linux
/dev/sda2 4311 4500 1526175 5 Extended
/dev/sda5 4311 4500 1526143+ 82 Linux swap / Solaris

Disk /dev/sdb: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x3bb47bdf

Device Boot Start End Blocks Id System
/dev/sdb1 1 19582 157292383+ 7 HPFS/NTFS
/dev/sdb2 19583 38913 155276257+ f W95 Ext'd (LBA)
/dev/sdb5 19583 38913 155276226 b W95 FAT32

Disk /dev/sdc: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xfcd2fcd2

Device Boot Start End Blocks Id System
/dev/sdc1 1 6527 52428096 7 HPFS/NTFS
/dev/sdc2 6528 38913 260140545 f W95 Ext'd (LBA)
/dev/sdc5 6528 38913 260140513+ 7 HPFS/NTFS

-- Identify UUID of partitons to be added into fstab
lilpaul@smiley1 ~ $ sudo blkid /dev/sdb1
/dev/sdb1: UUID="5276E19976E17DDB" LABEL="MOVIES" TYPE="ntfs"
lilpaul@smiley1 ~ $ sudo blkid /dev/sdb5
/dev/sdb5: LABEL="MUSIC" UUID="8B75-22B6" TYPE="vfat"
lilpaul@smiley1 ~ $ sudo blkid /dev/sdc1
/dev/sdc1: UUID="041A84721A846312" LABEL="APPS" TYPE="ntfs"
lilpaul@smiley1 ~ $ sudo blkid /dev/sdc5
/dev/sdc5: UUID="BEDC96B5DC966803" LABEL="DOWNLOADS" TYPE="ntfs"

-- backup fstab
sudo cp /etc/fstab /etc/fstab_310808

-- make file system mount point names
sudo mkdir /media/apps
sudo mkdir /media/downloads
sudo mkdir /media/movies
sudo mkdir /media/music

-- add mountpoints into fstab
sudo vi /etc/fstab

# /dev/sdb1
UUID="5276E19976E17DDB" /media/movies ntfs defaults,umask=007,gid=46,noatime 0 0
# /dev/sdb5
UUID="8B75-22B6" /media/music vfat defaults,umask=007,gid=46,noatime 0 0
# /dev/sdc1
UUID="041A84721A846312" /media/apps ntfs defaults,umask=007,gid=46,noatime 0 0
# /dev/sdc5
UUID="BEDC96B5DC966803" /media/downloads ntfs defaults,umask=007,gid=46,noatime 0 0

I then performed a sudo mount -a, and i was able to access my drives.

However the drives are not showing in places or thunar side panel. I have tried adding the drives into the fstab, by UUID, LABEL and device name /dev/sdb1 etc. No matter what i do i cannot get the drives to show in places or in thunar side panel. From the little experience I have with linux i know these should show, but I aint got a clue why they aint for me. (I have rebooted a number of times during the changes made)

Any help would be appreciated.
lilpaul
Level 1
Level 1
 
Posts: 4
Joined: Sun Aug 31, 2008 11:53 am

Linux Mint is funded by ads and donations.
 

Re: Mounted Drives not showing in places

Postby Husse on Mon Sep 01, 2008 6:02 am

You say newbie...
This is exemplary!
Although UUID may have sideeffects.
I have too little knowledge in xfce and I'll move it to the xfce section and you will probably get better help there
Image
Don't fix it if it ain't broken, don't break it if you can't fix it
Husse
Level 21
Level 21
 
Posts: 19710
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Mounted Drives not showing in places

Postby merlwiz79 on Mon Sep 01, 2008 6:19 am

It will not show in the panel.
You can add the mount folder to the panel.(example /media/videos )
Just right click --> send to --> side panel.(not sure might be different.)
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Mounted Drives not showing in places

Postby Guest on Tue Sep 02, 2008 5:46 am

I thought it was meant to list all your mount points in the left panel under filesystem.

Am i wrong in my thinking?

First time ive used XFCE, i have little experience with it.

Also does it not create icons to the mount points on the desktop similar to gnome, or do you need to create these manually.

Im ok with unix / linux commands just not with the desktop enviroments and their setup and configuration.
Guest
 

Re: Mounted Drives not showing in places

Postby merlwiz79 on Tue Sep 02, 2008 6:33 am

I'm not really sure what happen.
I believe Gutsy(Daryna) did this automatically.
For some reason it doesn't work in Xubuntu hardy/Elyssa XFCE correctly.
I haven't looked into it yet.
I think it might be the something in the newer xfce as Zenwalk couldn't do it as well.
You could just send to the desktop like sending it to the side panel.
User avatar
merlwiz79
Level 11
Level 11
 
Posts: 3637
Joined: Wed Apr 04, 2007 1:50 pm
Location: Here again :)

Re: Mounted Drives not showing in places

Postby lilpaul on Wed Sep 03, 2008 9:33 am

Ive created bookmarks on both the desktop and side panel for now.

Im hoping there is a better fix tho.

Will check around the net
lilpaul
Level 1
Level 1
 
Posts: 4
Joined: Sun Aug 31, 2008 11:53 am


Return to XFCE

Who is online

Users browsing this forum: No registered users and 12 guests