Mint 13 / Maya - Cinnamon doesn't run any more

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

Mint 13 / Maya - Cinnamon doesn't run any more

Postby Majikthise on Mon Oct 22, 2012 7:38 pm

Hey dear Minters,

after being an avid fan of Ubuntu I thought I'd try Mint for a change - after buying a new sys I had to do a clean install anyway. And it only took me about ten attempts to get it runnung on a UEFI system! :roll:

When finally it did start, Cinnamon performed flawlessly. For about five minutes. Because right then I decided to hook up my second screen and use Nvidia-X-Server-Settings to extend the desktop like I used to in Ubuntu/Gnome.
But after the necessary restart of X, while the desktop was extended, it was also not Cinnamon anymore. I think my installation is now running a corrupt form of Gnome.

It doesn't matter if I click Gnome or Cinnamon when starting a session, I always get Gnome. Looking like it does in the screenshot:
Screenshot Majik.png
Screenshot Majik.png (9.25 KiB) Viewed 1467 times

(Yes, it's in German. What you see are three task bars, three menus, three representation of one Chromium instance (I counted 'em), basically three of everything,)

So how do I get back Cinnamon, preferably with a working task bar? I tried replacing xorg.conf from backup but no cigar.

Default display manager is /usr/sbin/mdm according to /etc/X11/default-display-manager. When I try to start that with
Code: Select all
sudo mdm

I get an abort error message because it is already running. However, when It try to configure it with
Code: Select all
sudo mdmsetup

I get an error message claiming that mdm is NOT running ..... wut?

FInally, in ~/.xsession-errors I find this

Code: Select all
/etc/mdm/Xsession: Beginning session setup...
localuser:<censored> being added to access control list
Setting IM through im-switch for locale=de_DE.
Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default.
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
Failed to connect to the VirtualBox kernel service
gnome-session-is-accelerated: No composite extension.
gnome-session-check-accelerated: Helper exited with code 256
gnome-session[2492]: WARNING: Session 'cinnamon' runnable check failed: Exited with code 1


Apparently, Cinnamon fails and the system defaults to Gnome. Would a reinstall help? Only if it is the the settings files that are corrupted that wouldn't work. Any ideas?

Regards Majikthise
Majikthise
Level 1
Level 1
 
Posts: 1
Joined: Mon Oct 22, 2012 7:10 pm

Linux Mint is funded by ads and donations.
 

Re: Mint 13 / Maya - Cinnamon doesn't run any more

Postby Johnson85 on Sun Nov 11, 2012 12:40 pm

Hi, probably got the same bug/error here. Installed Nvidia drivers from Nvidia.com and now
cinnamon has lost his menu bar. Starting in Gnome classic only gives me a black screen.

Have you found a solution for your/our problem?

Greetings from Germany
Johnson85
Level 1
Level 1
 
Posts: 1
Joined: Sun Nov 11, 2012 12:35 pm

Re: Mint 13 / Maya - Cinnamon doesn't run any more

Postby gnuts on Sun Nov 18, 2012 4:09 pm

Hello, I am running lmde 64, and I get the same error when starting cinnamon 1.6 (also happened in 1.4), while MATE works just fine. I am using ATI dual head setup with three screens. I read somewhere about cinnamon crashing if there are both top and bottom menus, I haven't tested yet if that is related. Also, this is on a fresh install, Cinnamon has never worked with the ATI drivers and the multiple screens.

+++ I removed all top menus and it had no effect cinnamon still crashes and gives the same error +++
gnuts
Level 1
Level 1
 
Posts: 1
Joined: Sun Nov 18, 2012 3:59 pm

Re: Mint 13 / Maya - Cinnamon doesn't run any more

Postby jamsterthecool on Sun Mar 17, 2013 8:18 pm

I can't get cinnamon to run in mint 14 !.

Seems to default to gnome also .

ANy of you guys found out why?
Linux Mint Debian Edition- 64bit- Cinnamon (latest update)
User avatar
jamsterthecool
Level 2
Level 2
 
Posts: 63
Joined: Tue Mar 05, 2013 8:42 am


Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: No registered users and 6 guests