ATI Proprietary Drivers for VGN-FW480J/T

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

ATI Proprietary Drivers for VGN-FW480J/T

Postby laifuthegreat on Mon Jul 08, 2013 5:01 pm

For some reason, the fglrx drivers don't seem to install properly on my system. Currently, when I run lspci, I receive
Code: Select all
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV730/M96 [Mobility Radeon HD 4650/5165]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI RV710/730 HDMI Audio [Radeon HD 4000 series]
06:00.0 Network controller: Intel Corporation WiFi Link 5100
08:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller (rev 14)
0a:03.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
0a:03.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
0a:03.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)

The most relevant bit being:
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV730/M96 [Mobility Radeon HD 4650/5165].
Anyways, when I install fglrx through apt-get or install proprietary drivers through some other method, it always detects the graphics card as compatible. However, once I run aticonfig and reboot the computer, it's detected as an incompatible generic VGA controller, gives me a 640x480 resolution, fails to render any 3D effects in any desktop environment, and generally shows symptoms of having no graphics card installed. Is there any way for me to use proprietary drivers? Did Sony somehow modify the graphics hardware in this laptop such that it only works with drivers they distribute?
laifuthegreat
Level 1
Level 1
 
Posts: 3
Joined: Sun Jun 30, 2013 2:34 am

Linux Mint is funded by ads and donations.
 

Re: ATI Proprietary Drivers for VGN-FW480J/T

Postby jp734 on Mon Jul 08, 2013 6:41 pm

Might want to try this. I've heard a lot having good luck with this help: http://ubuntuforums.org/showthread.php?t=2160592
IBM-X41 1.5GHz 1GB 32Gb - Lubuntu 12.10
---
Custom PC: Core2Quad 2.83GHz - 4GB - (3) Dell E197FP, (2) Radeon HD 5450
--- Linux Mint 15 Mate - Lubuntu 13.04 - CrunchBang Waldorf


Image
jp734
Level 3
Level 3
 
Posts: 174
Joined: Wed Apr 27, 2011 12:18 pm

Re: ATI Proprietary Drivers for VGN-FW480J/T

Postby Mark Phelps on Wed Jul 10, 2013 8:18 am

What Mint version are you running? If it's newer than Mint13, you're out of luck because AMD dropped Linux driver support for the HD 2x/3x/4x-series cards last summer and all Ubuntu-based Linux distros since then upgraded the X-server to a new version that is incompatible with those AMD drivers.
Mark Phelps
Level 5
Level 5
 
Posts: 898
Joined: Mon Jun 10, 2013 4:39 pm

Re: ATI Proprietary Drivers for VGN-FW480J/T

Postby laifuthegreat on Wed Jul 10, 2013 4:32 pm

I'm on Mint 15. I guess I'll try what jp734 posted and if it doesn't work, I should probably get a new computer anyways.
laifuthegreat
Level 1
Level 1
 
Posts: 3
Joined: Sun Jun 30, 2013 2:34 am

Re: ATI Proprietary Drivers for VGN-FW480J/T

Postby Mark Phelps on Thu Jul 11, 2013 6:02 pm

Wish folks would STOP posting that link!

It forces a downgrade of your X-server to an older version -- trading short-term improvement of AMD drivers for the risk of long-term instability and unknown problems down the road.
Mark Phelps
Level 5
Level 5
 
Posts: 898
Joined: Mon Jun 10, 2013 4:39 pm

Re: ATI Proprietary Drivers for VGN-FW480J/T

Postby jp734 on Thu Jul 11, 2013 8:13 pm

Ooh, that sucks. Wish I knew that....All I see so far are good results and never heard of such a thing before that's why I posted it....but NOT ANYMORE!!!! Thanks for the info.
IBM-X41 1.5GHz 1GB 32Gb - Lubuntu 12.10
---
Custom PC: Core2Quad 2.83GHz - 4GB - (3) Dell E197FP, (2) Radeon HD 5450
--- Linux Mint 15 Mate - Lubuntu 13.04 - CrunchBang Waldorf


Image
jp734
Level 3
Level 3
 
Posts: 174
Joined: Wed Apr 27, 2011 12:18 pm

Re: ATI Proprietary Drivers for VGN-FW480J/T

Postby superramboo007 on Sat Jul 13, 2013 10:55 am

ATI radeon graphics I have the HD 4200 and Tryed the ati driver on mint 15 no dice so i took the advice and installed mint13 maya and the ati driver works find all is well!!! http://support.amd.com/us/gpudownload/l ... linux.aspx says Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4

viewtopic.php?f=59&t=31845
Your card may well be supported on an older version of Mint though, e.g. the LTS release, so if the open-source driver is not good enough for you, then installing the older version of Mint is your only option. Don't try to force the drivers to install,
2 hints there mate

Linux Mint 13 “Maya” meets the ati needs having K 3.2 xorg 1.11.3 etc... So i now play 25assist AArmy2.5 on my 64 bit mint os sudo apt-get install ia32-libs coz Aarmy2.5 is 32 bit it's a free game for linux mac and win. I am superamboo007 or just ramboo007 so come and lets shoot something lol
superramboo007
Level 1
Level 1
 
Posts: 2
Joined: Sat Jul 13, 2013 5:36 am

Linux Mint is funded by ads and donations.
 

Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: No registered users and 4 guests