Linux Mint becomes black screen after logo

Screen resolution, 3D Acceleration, nVidia, ATI
Forum rules
Before you post please read this

Linux Mint becomes black screen after logo

Postby tir.karthi on Sun Feb 23, 2014 2:37 am

I have Linux Mint 15 installed on my Laptop with Windows 7 with mint4win . I had problems with dual graphics driver of AMD that drained my 100% battery in 50 minutes and so I installed the fglrx driver but had some flashy distortions while volume up and down. Had no boot problems . I had installed the updated driver from the website of AMD by extracting .deb packages from the downloaded file and installing the .deb files.It works well with no distortions . But I get a black screen a lot of times in the boot after the installation of the driver. So I have to force restart and go in the recovery mode and then say to boot and it boots well. The black screen occurs when I try to boot my laptop it is charging and few other times . Usually the Linux Mint logo appears and then I get a blinking cursor for a few seconds and get to the Login screen. But sometimes the cursor stops and my keyboard doesn't respond as I try to use alt+sysreq+REISUB so I have to force restart by pressing the power button and start in the recovery mode and boot my Mint. Is there any way to solve the problem? The output of
Code: Select all
inxi -Fzx
is as follows

Code: Select all
System:    Host: linuxmint Kernel: 3.8.0-19-generic x86_64 (64 bit, gcc: 4.7.3) Desktop: Gnome Distro: Linux Mint 15 Olivia
Machine:   System: Hewlett-Packard product: HP Pavilion g6 Notebook PC version: 0792100000205610000610100
           Mobo: Hewlett-Packard model: 184A version: 57.35 Bios: Insyde version: F.26 date: 02/21/2013
CPU:       Quad core AMD A8-4500M APU with Radeon HD Graphics (-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 15172.9
           Clock Speeds: 1: 1400.00 MHz 2: 1400.00 MHz 3: 1400.00 MHz 4: 1400.00 MHz
Graphics:  Card-1: Advanced Micro Devices [AMD] nee ATI Trinity [Radeon HD 7640G] bus-ID: 00:01.0
           Card-2: Advanced Micro Devices [AMD] nee ATI Thames XT [Radeon HD 7670M] bus-ID: 01:00.0
           X.Org: 1.13.3 driver: fglrx Resolution: 1366x768@60.1hz
           GLX Renderer: AMD Radeon HD 7600M Series GLX Version: 4.3.12618 - CPC 9.01 Direct Rendering: Yes
Audio:     Card-1: Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel bus-ID: 00:14.2
           Card-2: Advanced Micro Devices [AMD] nee ATI Trinity HDMI Audio Controller driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture ver: k3.8.0-19-generic
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           driver: r8169 ver: 2.3LK-NAPI port: 2000 bus-ID: 05:00.0
           IF: eth0 state: down mac: a0:b3:cc:84:f7:e8
           Card-2: Atheros AR9485 Wireless Network Adapter driver: ath9k bus-ID: 02:00.0
           IF: wlan0 state: up mac: 74:e5:43:86:29:01
           Card-3: Atheros usb-ID: 0cf3:311d
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 500.1GB (17.3% used) 1: id: /dev/sda model: Hitachi_HTS54755 size: 500.1GB
Partition: ID: / size: 17G used: 7.5G (47%) fs: ext4
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 52.8C mobo: N/A gpu: 50.00C 51.50C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 170 Uptime: 20 min Memory: 760.9/3363.1MB Runlevel: 2 Gcc sys: 4.7.3 Client: Shell inxi: 1.8.4



The fglrxinfo is as follows

Code: Select all
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 7600M Series
OpenGL version string: 4.3.12618 Compatibility Profile Context 9.01
tir.karthi
Level 1
Level 1
 
Posts: 43
Joined: Sat Jun 22, 2013 12:24 pm

Linux Mint is funded by ads and donations.
 

Return to Graphic Cards & Monitors

Who is online

Users browsing this forum: Google [Bot] and 5 guests